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Projects and Files 
  
GFLOW is a database program with groundwater modeling capabilities. As such data 
management does not occur in RAM to be saved to disk by an explicit user action (clicking on 
Save), but any data modifications in GFLOW are immediately implemented in a database, 
which resides on the disk. This is similar to the way the database program Access works. 
Consequently, GFLOW has no Save option, but you will find a Make Duplicate DatebaseÖ  
option on the Project menu. If you want to make changes in a model and not loose the current 
model, you must make a duplicate database under a new name before you make your 
modifications. The database on disk is also referred to as the project file and has the 
extension .gfl. 
  
The graphical user interface (GUI) uses various additional files to communicate with the 
Solver. The GUI generates a unique Base Filename (DOS) that will be used for naming the 
Solver interaction files.  
Below follow the basic steps for opening or creating a project file. 
  
Click on the Project menu and select New Database to create a new project data base or 

select Open Database to open an existing data base: filename.gfl 
  
When creating a new project file you may select one or more base maps, see below. Once you 

have opened or created a data base file (project file), GFLOW will display the map or maps 
and you are ready to setup a groundwater flow model on screen. Any changes to the model 
parameters are immediately updated in the database and incorporated in the project file. 
When it is necessary to create a duplicate project file under a different name you should 
use the Make Duplicate DatabaseÖ  option on the Project menu. 

  
There is one other filename you may specify: the Base Filename. You will find this option on 

the Project Settings dialog box. The Base Filename has a maximum length of 8 characters 
and no spaces (DOS filename) and is the name used for the Solver data files. When 
creating a new project a default unique Base Filename is automatically entered, but it is 
rather cryptic. You may enter a more recognizable, but unique Base Filename yourself. 
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Warning: If you do not use a unique Base Filename for each new project, the GUI may 
mistake the solver output for one project as the solution for another (currently open) project. 

  
NOTE:  The GFLOW installer will create a folder on your c:-drive under <user> (my) documents called 
GFLOW projects in which it places three sub-folders: "example," "example2," and "validations.."  Note: 
An exact path cannot be specified here as it is diferent for different Windows versions. 
You are encouraged to use this folder GFLOW projects to add sub-folders for each of your own projects. 
Base Maps 

  
GFLOW supports various raster and vector graphics file formats to serve as base maps for 
groundwater flow models. Associating base map files with your project is managed on the 
Project Settings dialog under the Project menu. When clicking on Add Map.. a file 
management dialog appears. Clicking on All Supported Types opens a drop down list of the 
file types supported by GFLOW. Note: all maps must be georeferenced, which means they 
must contain coordinate information in either UTM or State Plane coordinates. All file types, 
except for the vector maps contained in BBM files, are rendered by MapObject LT 2.0, a 
software product by ESRI. 
  
BBM files contain 1:100,000 USGS DLG data in binary format. This binary format has been 
developed especially for use in the WhAEM and GFLOW groundwater flow models. The 
GFLOW installation will deliver some these BBM files as part of the example projects (see 
Tutorial). BBM maps may also be obtained from a USEPA website: 
  
https://www.epa.gov/exposure-assessment-models/whaem2000-bbm-files-us 
  
You can graphically locate the area for your bbm maps or click on a state and then quad name 
below the map of the US and state, respectively. 
Select to download the map or maps to the download folder on your computer. The file that is 
being downloaded is a self-extracting zip file with the extension .exe. You will have to overrule 
the Windows security warnings and select "run anyway" when trying to run the executable.   
IMPORTANT: EPA is in the process of converting old 16-bit self-extract files, which fail to run 
on 64-bit machines to newer 64-bit executables. In case the xxxx.exe fails to run (16-bit 
version), simply right-click the file and select Winzip or some other unzipping program on your 
computer to force the extract process. 
  
  
Note 1: Base map files from different sources may have different coordinate systems and 
units. GFLOW will maintain the original units of the base map! You must know these units 
when you specify the base maps during the creation of a new project. For instance, the units 
for the .bbm files derived from DLG files are METERS. Hence, you must set the "Distance 
units in Basemap Files" to meters. You may still select feet and days as the units for entering 
heads, pumping rates, recharge rates, etc. The latter units are called "Units for Computations" 
in GFLOW. You must tell GFLOW (at the time you create a new project) what "Units for 
Computations " you will be using.  
There is an option on the Project Settings Dialog to change these units, however, this option is 
only for the case that you made a mistake during the initial phase of creating a project. 
Resetting the units will not change any data! For instance, if your distance units in the 
basemap files are in meters, but you mistakenly specified feet, you can correct this setting on 
the Project>Project Settings Dialog; there will be no change in the coordinate data. 
  
Note 2: Large vector or raster graphics maps may be very slow to draw. In particular, when 
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using a large Shapefile, with many attributes selected as labels for display, some delay may 
occur before the maps are drawn. Use judgment in the selection of basemap files. Overlaying 
modeling results on very detailed and complex maps, for instance for report production, may 
best be done by exporting the model information (Tools>Export) and importing it in a 
professional CAD or GIS program. 
  
Hydrography and Water Levels 
  
A map of all surface water features is called a hydrography map, which should be part of your 
base maps in GFLOW. In order to translate this hydrography map into boundary conditions for 
the groundwater flow model (average) water levels along streams, creeks, and in lakes must 
be known. 
  
Streams and lakes will be represented by strings of straight line elements (line-sinks) with each 
assigned a head that is set equal to the water level in the stream or lake. In preparation for the 
task of creating these line-sinks you may want to mark up your hydrography map by adding the 
contour elevation of the terrain surface next to the stream at those locations where such an 
elevation contour line crosses the stream. As a source for these surface water levels you may 
use USGS 71/2 minute topographic maps, which are available in paper form or in digital form, 
see http://edcwww.cr.usgs.gov/ Digital topographic maps that are georeferenced, may also 
be used as a base map in GFLOW. 
  
When entering line-sink strings you will be prompted for the starting and ending surface water 
elevations for the string (in GFLOW referred to as starting head and ending head, 
respectively), which you can now read directly from the base map on the screen. 
  
See also Creating new Line-sinks under the Element menu.  
Aquifer Parameters 
  
GFLOW requires the user to specify four aquifer parameters, which is done by clicking 
Settings on the Model menu and selecting the Aquifer tab. 
  
Base elevation in feet or meters with respect to mean sea level (msl). The aquifer base in the 
model is a (fictitious) horizontal plane that acts as a no-flow boundary.  In reality, the aquifer 
base may be a clay layer or rock surface, which is usually not a perfect horizontal surface. The 
base elevation entered on this menu is the regional aquifer base. Locally, you may select a 
different base elevation using the Inhomogeneity option under New on the Element menu.   
Warning: It is important that the model aquifer base in a domain is not higher than the lowest 
water level assigned to line-sink strings in that domain. In the event that the aquifer base is 
above an assigned surface water elevation, the model will limit the heads in the aquifer to the 
aquifer base in that area, which is often noticeable by ragged potentiometric contour lines. 
  
Thickness of the aquifer is the actual thickness of aquifer material above the background 
aquifer base (the one entered on this menu), regardless of how much is saturated. In fact, 
when the aquifer base elevation plus aquifer thickness exceeds the potentiometric head in the 
aquifer the model automatically assumes unconfined flow conditions. If you want to ensure 
unconfined flow conditions throughout the model domain, regardless of the groundwater 
elevation, you may set the aquifer thickness to a very large value, much larger than the actual 
aquifer thickness.  
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Hydraulic conductivity, is the regional background value for the model domain. You may locally 
select a different hydraulic conductivity by use of the Inhomogeneity option under New on the 
Element menu. 
  
Porosity in GFLOW is an effective porosity that is constant for the model domain. The porosity 
value is used for tracing path lines and calculating groundwater residence times (travel times).  
  
The Add Salt Water Interface option may be checked to model fresh water flow in coastal 
aquifers with a stationary salt water interface.   
Analytic Elements 
  
Analytic elements are mathematical functions (real or complex) that represent hydrogeologic 
features in a groundwater flow model. For instance, a meandering creek or river is represented 
by a string of straight-line elements, which approximates the geometry of the stream. In 
GFLOW each of these line elements is associated with a "line-sink function", which generates 
the discharge potential and stream function for a sink distribution along a straight line (with 
constant sink density).  The discharge potential and stream function are the real and imaginary 
part of a complex potential function generated by the line-sink function.  
The discharge potential is defined in terms of the potentiometric head, the hydraulic 
conductivity, and the saturated aquifer thickness in such a way that the discharge vector is the 
(negative) derivative of the discharge potential. Under unconfined flow conditions the 
discharge potential is defined as: 

 
Under confined flow conditions the discharge potential is defined as: 

 
where k is the hydraulic conductivity,   is the potentiometric head measured with respect to 
the aquifer base, and where H is the aquifer thickness as defined in the model. The governing 
differential equation in terms of is linear and is the same for both confined and unconfined 
flow. This makes superposition (in terms of the discharge potential) possible under both flow 
conditions. The use of these discharge potentials is transparent to the user; they are handled 
internally in the solver. The user may specify surface water elevations with respect to mean 
sea level at streams and lakes and will get potentiometric head contours with respect to mean 
sea level as output from the groundwater flow model. 
Other examples of analytic elements are wells (fully or partially penetrating), line-doublets or 
"double layers" to represent inhomogeneities or horizontal flow barriers in GFLOW and areal 
recharge due to precipitation (a recharge inhomogeneity).  
  
The contributions of all analytic elements to the discharge potential (in GFLOW perhaps more 
than several hundred) are added together (superimposed) to create a comprehensive solution 
to the groundwater flow problem. The discharge potential is directly related to the 
potentiometric head in the aquifer (water table in an unconfined aquifer). The derivative of the 
discharge potential with respect to the two (x and y) coordinate directions yields the discharge 
vector, which is the total groundwater flow rate (integrated over the aquifer height) per unit 
width of the aquifer. The discharge vector is calculated in GFLOW by superimposing so-called 
derivative functions, which are the derivatives of the potential functions. The groundwater flow 
velocity in GFLOW is calculated by dividing the discharge vector by the saturated aquifer 
thickness and the (effective) aquifer porosity. 
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Analytic elements are defined in GFLOW by selecting New under the Element menu.  
Wells 
  
There are three different wells in GFLOW: steady state wells, transient wells, and partially 
penetrating wells. The first two are fully penetrating and represented by two-dimensional 
functions (x and y only). The partially penetrating well is a fully three-dimensional analytic 
function, but can only be included in a confined flow domain. The transient well is a well that 
starts pumping at a certain time. Its transient response is calculated by use of the Theis 
solution, see Haitjema (1995). 
  
The most commonly used well in GFLOW is a fully penetrating steady state well that is entered 
on the General tab of the Well Properties dialog box. This well in GFLOW is represented by 
Thiem's equation, which generates the discharge potential for a continuously pumping well 
under steady state groundwater flow conditions. Thiem's equation in terms of the complex 

potential is: 
 

where  Q is the pumping rate of the well,  
 

is the complex coordinate of the point at which the potential due to the well is calculated, 
 

is the complex coordinate of the location of the well, and R is some arbitrary constant with the 
dimension of length. 
  
In GFLOW a steady state well is assigned a location, pumping rate, radius, and label. When 
path lines are to be traced from the well (particle tracking), the number of particles to be used 
is also specified. The particle tracking from the well is performed backwards in time, starting at 
the well and ending at a specified groundwater residence time from the well. The particle 
tracking parameters are defined on the Other tab of the Well Properties dialog. 
  
Wells are defined in GFLOW by selecting Wells under New from the Element menu. 
Line-sinks 
  
Line-sinks are used to represent streams (creeks, ditches, and rivers) and lake boundaries. A 
line-sink in GFLOW has a constant sink density (constant groundwater extraction rate along 
the line element). The discharge potential for a line-sink is obtained by integrating a point sink 
(Thiem's equation) along a (straight) line element, see Strack (1989) and Haitjema (1995). The 
sink density of a line-sink that represents a stream section or a section of a lake boundary is in 
general not known. In GFLOW this is handled by specifying a potentiometric head at the center 
of the line-sink, which is selected equal to the average water level in the stream section or lake 
that is represented by the line-sink. For every unknown sink density there exists one known 
head. This leads to a system of equations that is solved for the unknown sink densities of the 
line-sinks. Every change in data in the GFLOW model, therefore, requires a new solution 
procedure to recalculate the sink densities. The sink density of the line-sink represents the 
groundwater infiltration rate into the stream section that is represented by the line-sink, in 
volume per time per unit length of the line-sink (stream or lake boundary). 
The use of line-sinks along lake boundaries implies that a lake receives or loses groundwater 
along its boundary only. This appears to be a good approximation of reality when the size of 
the lake is large compared to the saturated thickness of the aquifer. For streams that have a 
width that is large compared to the aquifer thickness, the realism of the model may be 
improved by positioning line-sinks along both sides of the river. 
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The number of line-sinks required to represent a stream depends on two factors: (1) the need 
to follow detailed stream geometry, and (2) the need to allow for variations in the groundwater 
discharge or recharge along the stream or lake boundary. Representing stream geometry is 
more important in the near field (area of interest) than in the far field. Similarly, the need to use 
many small line-sinks to allow discharge or recharge variations along the stream is most 
pressing in the near field, particularly near a high capacity well, which may draw water from the 
stream and tends to cause significant variations of stream inflow or outflow opposite the well. 
Consequently, surface water features in the area of interest (near field) should be represented 
with more and smaller line-sinks than surface waters in the far field, remote from the area of 
interest. See also near field and far field. 
  
Line-sinks in GFLOW may be given a resistance (in days), which represents the resistance to 
flow into or out of the surface water body due to a silt layer on the bottom or due to a low 
permeable layer between the surface water and the aquifer. To implement this resistance 
properly, a width and a depth parameter must be specified in addition to the resistance 
parameter. Detailed information on how to define these parameters is provided as context 
sensitive help on the Linesink Properties dialog and in the document "Dealing with Resistance 
to Flow into Surface Waters.pdf" in the documents folder (and accessible from the Help menu) 
or on the website www.haitjema.com.  
  
Line-sink strings that represent stream networks can support stream flow routing, which 
improves the realism of the groundwater flow solution by limiting the infiltration rate of loosing 
streams to the available stream flow. In fact, head waters of streams that do not receive 
groundwater cannot infiltrate water into the aquifer either and will be removed from the 
groundwater solution. Line-sink strings can be made part of a stream network by specifying the 
proper parameters on the Routing tab of the Linesink String Properties dialog. To implement 
these stream networks in GFLOW the option Conjunctive Surface water - Groundwater 
Solution must be checked on the Solver tab of the Model Settings dialog. 
  
Line-sinks are defined in GFLOW by selecting Linesinks under New from the Element menu.  
Inhomogeneities 
  
Inhomogeneities are closed domains inside of which the hydraulic conductivity, aquifer base, 
recharge rate and porosity can be redefined. These domains are defined by polygons of line-
doublets (also called "double layers"), which may be nested or abut each other, but may not 
overlap each other. An exception is an inhomogeneity domain inside of which only the 
recharge is redefined. That domain may be placed everywhere and overlap with other 
inhomogeneity domains.  
  
Inhomogeneities may be used to incorporate aquifer heterogeneity in zones. Typical examples 
are the more permeable channel deposits surrounding many streams. These channel deposits 
may also have a different (often lower) aquifer base and recharge rate due to precipitation. To 
add recharge, enter it on the inhomogeneity dialog box. 
  
Areal recharge due to precipitation in the model area may be specified by entering an 
inhomogeneity with only the "Change recharge rate from default" box checked. 
  
Note: Inhomogeneities that do not redefine the hydraulic conductivity or the aquifer base can 
be defined by a few large line elements (for instance a rectangle with four line elements). 
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These line-doublets do not add equations to be solved for. 
In contrast, inhomogeneity domains that redefine the aquifer base and/or hydraulic conductivity 
should be defined with sufficient line elements to allow the conditions along the domain 
boundary to be adjusted to local flow conditions. Like for the case of line sinks, small line-
doublets are needed in areas with rapidly varying flow (heads). Each line-doublet adds  two 
equations to the system of equations to be solved. Note: Line-doublets along common domain 
boundaries occur only once in the system of equations. 
Horizontal Barriers 
  
Horizontal barriers are slurry walls or rock outcrops that block or restrict groundwater flow in 
the horizontal direction. In GFLOW horizontal barriers may be defined that are open or closed 
strings of (straight) line elements (line-doublets). The barrier is given a width, depth, hydraulic 
conductivity and porosity. If the barrier does not reach down to the aquifer base, most or all 
groundwater flow will occur underneath the barrier. A horizontal barrier with a conductivity of 
zero defines a no-flow boundary (provided the barrier depth is at or below the aquifer base). 
Open barriers may be used to represent part of a rock outcrop boundary in the near field or to 
represent a slurry wall. Closed barriers may be used to define local rock outcrops in the near 
field, model the inside of a closed flow domain (aquifer basin), or model flow both in and 
outside a closed leaky slurry wall. 
Warning: In order to obtain a stable and accurate solution for barriers with a low resistance 
(high conductance) a rather large amount of line-doublets are needed. Most partially 
penetrating barriers have a high conductance. 
  
Horizontal barriers are defined in GFLOW by selecting Horizontal Barrier under New from the 
Element menu. 
Uniform Flow 
  
The Uniform flow option on the Element menu allows for conceptual modeling of regional flow 
without the introduction of areal recharge and surface water features in the model. It is 
provided for educational purposes. For instance, the modeler may compare capture zones for 
the well or wellfield obtained from a complex model, with capture zones that would result from 
approximating the regional flow field by uniform flow in the area of the wellfield.  In general, the 
uniform flow option should not be used in combination with other analytic elements, except 
with the wells for which capture zones are to be generated.  
  
In summary, the uniform flow option is not intended for routine groundwater flow modeling with 
GFLOW.  
Near Field and Far Field 
  
When defining analytic elements it is important to distinguish between the near field and the far 
field of the model area. The near field is the area of interest; e.g the area near a well field or 
containing a plume of contaminated groundwater. The far field is the surrounding area that 
contains hydrologic features that control the groundwater flow toward or out of the near field. 
The far field area is only included in the model in order to properly define hydrologic 
"boundaries" for the near field. Streams and lakes in the far field are represented rather 
crudely with large line-sinks. Closer to the near field, more care is taken in representing stream 
and lake-geometry. Inside the near field, close to a well field, for instance, the highest 
resolution of line-sinks is used. This selective use of line-sink resolution makes it possible to 
include a large area in the model while at the same time preserving computational efficiency. A 
computationally efficient model invites experimentation with different assumptions, which 
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makes for a better modeling exercise, hence a better understanding of the groundwater flow. 
  
An example of the use of different line-sink resolutions in the far field and near field is found in 
the project file example.gfl. The infiltration or extraction rates of line-sinks in the near field 
are representative for the actual groundwater discharge or recharge of the stream sections in 
the field. 
For instance, when comparing the line-sink strength of stream sections close to a well field, the 
groundwater discharge into those sections will be reduced when increasing the pumping rate 
of the well. Some line-sinks may actually switch from positive strength to negative strength; 
hence from groundwater discharge to groundwater recharge, in order to supply water to the 
well field.  
In contrast, the line-sink strengths in the far field are devoid of any hydrologic meaning. These 
line-sinks extract or infiltrate water as needed to maintain specified potentiometric heads in the 
far field, which is why they were entered in the model. In the absence of more remote line-
sinks (hydrologic features), outside the far field, these far field line-sinks strengths are not 
representative for the actual discharge or recharge of the streams or lakes they represent.  
  
Line-sinks in the far field should not be given a width, depth or resistance, nor should they be 
part of a stream network (no surface water routing). Only line-sinks with zero properties 
(except for the starting and ending head) will maintain the desired far field conditions. To 
ensure proper use of line-sinks in the far field you should select the box "Use as Far-Field" on 
the Linesink String Properties dialog. 
Model Runs 
  
A groundwater flow solution can be generated after all aquifer parameters and analytic 
elements have been defined. The analytic element solver is started by clicking Solve on the 
Model menu, clicking on the calculator icon or pressing F9. The solver generates the sink 
densities for the line-sinks and strength parameters for the line-doublets (inhomogeneities and 
horizontal barriers). A solution may require several iterations, depending on the complexity of 
the model. Most problems converge in 4 to 5 iterations. However, when stream flow routing is 
active (conjunctive surface water and groundwater flow solutions) many more iterations may 
be necessary (say 15 or more). A report on the accuracy of the solution scrolls inside the 
solver box on screen and may be reviewed after the solution process by inspecting the 
Runtime Message File (Model>View Model Run Files..).  
The user can define so-called convergence criteria for the various types of analytic elements to 
allow the solver to abort the iteration process if all criteria are being met. This can be useful for 
series of batch runs as occur during parameter optimalization with PEST (integrated in 
GFLOW). These criteria are defined in the file convergence.tab, which can be edited on the 
Model>Settings>Solver tab. 
  
Depending on the Settings on the Model menu, heads or stream flow at test points 
(Piezometers and Gages, respectively), potentiometric contours, and path lines will be 
generated as well. There are three types of test points: piezometers where the head is known, 
gages where the stream flow is known, and lake stages to be used inside lakes (defined by 
line-sinks) for which the lake stage is being calculated. Piezometers may be wells in which a 
static water level has been measured (no pumping) or an open gravel pit with a known water 
elevation.  Gages are locations where the stream flow is known, for instance because they 
coincide with official USGS gaging stations at  streams. Lake stages are like piezometers, but 
they compare the expected or measured lake stage to the one calculated by GFLOW. This 
type of Test Point should only be used near lakes for which the lake stage is being solved for 
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(Lake option on the Linesink String Properties dialog).Test points defined in the model are 
used for model calibration purposes, comparing the head and stream flow calculated by the 
model with those observed in the field. Test points and associated observed heads or stream 
flows can be entered by the Add Test Point command on the Model menu. Gaging station data 
will only be used when conjunctive surface water and groundwater flow solutions are created. 
It is recommended to start generating groundwater flow solutions only with piezometer test 
points and contours, but without path lines. Once aquifer parameters and analytic elements 
have been adjusted to obtain a satisfactory groundwater flow solution, conjunctive surface 
water and groundwater solutions may be created and gaging stations and path line traces may 
be added for further analysis. 
  
Note 1: After every change in aquifer data or analytic element data, as well as after making 
changes in Settings on the Model menu, a new groundwater flow solution must be generated 
(clicking on the calculator icon). 
  
Note 2: After opening a project file for which a solution has been generated earlier, you may 
import that solution from Tools>Import>Previous Solution File.. Select the basefilename.sol 
file with the basefilename specified on the Project Settings dialog box (Project>Project 
Settings). 
Contour Plots 
  
Contours of equal potentiometric head (equipotentials) are plotted on top of the background 
map after a groundwater solution is created, provided that: (1) the Contouring option is 
selected on the View menu and  (2) the Compute Contours box is checked and contouring 
parameters are set under the Contouring tab of the Settings option on the Model menu. The 
latter action ensures that the solver returns the necessary contour data, while the Contouring 
option on the View menu controls whether the contours will actually be displayed. Any changes 
in the contouring parameters (Model>Settings>Contouring) require a recalculation of a grid 
filled with values to be contoured. 
When zooming out or selecting a different window, contours will only appear in the original 
window domain for which they were generated. If it is necessary to display contours in the new 
window a new grid must be calculated. Simply click on the calculator icon and click yes for 
using the existing groundwater flow solution. 
Note: In most cases you will want potentiometric contours, which requires the radio button for 
Heads to be checked on the Contouring tab of the Model>Settings dialog . 
  
Path Line Tracing 
  
There are three path line tracing options in GFLOW, (1) multiple path lines toward a well, (2) 
single path lines from selected points in the model domain and (3) instant single path line 
traces from the cursor position. All path lines in GFLOW are traced in a three-dimensional 
space. 
  
(1) Multiple path line traces from wells are realized by distributing a number of (fictitious) 
particles around the well perimeter and tracing them backward in time (moving away from a 
pumping well).  
A bundle of these path lines will fill the capture zone of the well. By adding markers (circles) on 
the path lines for equal time intervals, for instance one year, isochrones of groundwater travel 
times emerge when connecting markers of equal time. The number of particles for a well is 
specified as a property of the well (on the Other tab of the Well Properties dialog), while the 
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program automatically distributes these particles around the well bore. The starting elevation of 
the particles, to be set on the Other tab, influences the extent of the traces. Particles near the 
aquifer bottom will often extend the furthest, while particles traced from an elevation close to 
the aquifer top may stop after a short distance (at the point where the water enters the aquifer). 
See also Time of travel capture zones. 
  
(2) Single path line traces from specified points (other than those at wells) can be created both 
forward or backward in time. These particles are created by the Add Particle option on the 
Model menu or by the associated icon on the tool bar. 
  
(3) An instant path line trace from the cursor position is obtained by holding down the Ctrl and 
Shift key and left-clicking the mouse. Note: On the Mac running a virtual machine with 
Windows (e.g. Parallels) this key stroke combination may be different, e.g. Ctrl-Shift-
Command. The elevation of the starting point and the direction of the trace (forward or 
backward in time) can be set under Tools>Instant Inspector Settings. To set the starting 
elevation of the instant trace type it in the box labeled Inspection Elevation. 
  
Path line traces and an associated maximum travel time are selected prior to solving, see 
Tracing tab under Settings on the Model menu. 
  
Two different markers may be added to the path lines, time markers and elevation markers. 
The intervals for these markers may be selected under the Pathlines option on the View menu. 
  
Particle traces in GFLOW may or may not stop at a line-sink, depending on circumstances. 
When the hydraulic gradient on both sides of a line-sink is away from the line-sink (loosing 
stream) particle traces that occur backward in time from the well will end at that line-sink. 
However, a stream may be losing water while the hydraulic gradient on the side of the stream 
(line-sink) opposite from the well may still be toward the line-sink. In that case the well receives 
water from both the stream and the area across the stream. The particle traces, for that case, 
will either end at the stream or extend beyond the stream, depending on the elevation of the 
particle in the aquifer. 
  
Time-of-Travel Capture Zones 
  
Time of travel capture zones are obtained by use of multiple path line traces toward wells with 
time of travel tic-marks, see Path Lines on View menu. These path lines are defined when 
creating wells, while tracing is activated by selecting Compute Particle Paths on the Tracing 
tab on the Model menu. When defining single time of travel capture zones, for instance 5-year 
time-of-travel (TOT) capture zones, no time tic-marks are needed. Instead the Maximum 
Travel Time on the Tracing tab on the Model menu may be set to 1825 days (5 years). This will 
result in a bundle of path lines, which will occupy the 5-year time of travel zone. 
  
Note: The actual envellope of the capture zone is often not included, but is being approached 
when increasing the number of particle traces for the well. Hence, for a final assessment of the 
TOT capture zone it is advisable to set the number of path lines from the well quite high, e.g. 
50. 
Instant Inspector 
  
Shift left-click     (instant data display) 
Input and output data at any location in the model domain can be accessed by use of the 
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"instant inspector" feature. Move the cursor to the desired location on the base map, hold 
down the Shift key and left-click the mouse. A box will appear with the following data: 
coordinates (x,y,z), porosity, hydraulic conductivity, aquifer bottom elevation, net recharge rate, 
head, average groundwater flow velocity (Vx,Vy,Vz). The elevation of the point at which this 
data is obtained is entered in the box Inspection Elevation under Tools>Instant Inspector 
Settings. 
Solver Integrity Check: If the option Solver Integrity Check on the Tools menu is checked, a 
second data box will appear with a comparison of the analytic and numerical values of the 
three velocity vector components and the divergence of the specific discharge and discharge 
vectors. This feature is for quality assurance and debugging purposes only. 
  
Ctrl Shift left-click     (instant pathline tracing) 
A path line may be traced from the current cursor location by holding down the Shift and Ctrl 
key and left-clicking the mouse. The starting elevation of the particle and the direction of the 
trace (forward or backward in time) are defined under Tools>Instant Inspector Settings. Use 
the box Inspection Elevation to set the starting elevation of the instant particle trace. An instant 
particle trace does not define a new particle as is done on the Model menu. Consequently, the 
instant particle trace is a one time event and is not repeated after a new solve or retrace 
command. 
  
Note: On the Mac, when running a virtual machine with Windows (e.g. Parallels) these 
keystroke combinations may differ. For instance, Instant Data Display ("Model Results" data 
box) may require fn-Shift or Command-Shift.  The Instant Pathline Trace may require CTR-
Shift-Command. Depending on virtual machine setup these combinations may vary and 
require some experimentation.  
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