
What is new in GFLOW 2.1.2? 
 
Version 2.1.2 is a minor upgrade from version 2.1.1. Most modifications are related to 
minor bug fixes in the GUI and some improved efficiencies in the Solver. There are, 
however, a few noteworthy changes: 
 

1) The web access by GFLOW (Tools>Base Map Browser..) has been modified to 
avoid the “plugin.ocx”  dependency, which caused re-installation problems after 
automated MS Windows updates. In version 2.1.2, when clicking “Use Web,”  
GFLOW will now open your default web browser with the EPA website for 
downloading BBM files (basemaps). 

2) The directory structure has been changed. There are no longer any project files in 
the C:\Program Files\GFLOW\ folder. The folders “example,”  “example2,”  and 
“validations”  have been placed in a new folder C:\GFLOW projects\ which may 
also be used by the user for organizing GFLOW runs in project specific folders. 
This modification is necessary for GFLOW to work properly under Windows 
Vistas. 

 
IMPORTANT:   GFLOW Help under  Windows Vistas 
GFLOW will work correctly with Windows Vistas, except for the Help system. Microsoft 
no longer supports the WinHelp system (GFLOW.hlp file) and, in fact, prevents any 
install script to install the “WinHlp32.exe”  file needed to run the Help system. Vistas 
users must download this file themselves from the MS website: 
http://www.microsoft.com/downloads/details.aspx?FamilyId=6EBCFAD9-D3F5-4365-
8070-334CD175D4BB&displaylang=en 
 After downloading and installation of the WinHlp32.exe the GFLOW Help system 
should work under Vistas. A transition of the GFLOW Help system to HTML Help 
(supported by Vistas) is in progress. 
 
 

What is new in GFLOW 2.1.1? 
 
 
Users that are upgrading from an earlier version of GFLOW (previously named GFLOW 
2000) should read this document, since some paradigms of the earlier versions have been 
modified. There are many new features and enhancements, the most important ones are 
summarized below. 
 

1. Back ground maps (base maps) now include several different vector and raster 
graphics file formats (in addition to the EPA supplied BBM format). 

2. The solution process has been speeded up, made more stable, and provided with 
convergence criteria. 

3. The line-sink width parameter is now automatically calculated by the Solver. 



4. Several new model calibration tools have been added. These include three types 
of Test Points (piezometers, stream gages, and lake stages), a Scenario feature to 
perform calibration and sensitivity runs, and integration of parameter optimization 
using PEST or UCODE. 

5. Inhomogeneity domains can now have shared boundary sections. 
6. Large models may be broken up in several smaller models based on USGS 

defined Hydrologic Units. 
7. A right-click on a selected analytic element will provide element specific 

modeling results. 
8. There is a database search feature that lets you quickly locate a specific analytic 

element or a group of analytic elements with a shared attribute. 
9. The contouring of heads has been expanded to include contours of potentials, 

stream function, absolute value of the discharge, and drawdowns. 
10. There is now a GUI options dialog to customize certain GUI defaults. 
11. Particle tracking has been expanded to allow the introduction and management of 

grids of particles. 
12. The line-sink based lake feature now has an automatic nullification of recharge on 

the lake surface. 
 

A more detailed description of each of these features follows on the next pages. 
 
GFLOW version 2.1.0 is fully compatible with earlier versions except for the following: 

·  The project files for earlier versions must be updated by version 2.1.0, 
which will be automatic. 

·  The format of * .tp files, used for the import and export of Test Points has 
been changed to accommodate the three different types of Test Points 
(piezometers, gages, and lake stages). Consequently, * .tp files prepared for 
or written by earlier versions of GFLOW must be adapted to this new 
format. Consult the Help system for details by opening the Tools menu, 
pressing “F1”  to open a Help dialog, and clicking on Import. 

·  Line-sink based lake features that have an inhomogeneity to cancel 
recharge on the lake surface will still work provided they fully cover the 
lake. However, it may be best (and computationally more efficient) to 
delete these inhomogeneities, since the Solver will add one automatically. 

 
 



 

Background maps 

 
Figure 1. Various types of vector and raster graphics files are supported. 
 
In addition to the EPA supplied BBM vector file format (which contain USGS DLG 
maps) the new GFLOW versions 2.1.0 now supports several different vector and raster 
graphics files. In Fig. 1. one BBM file, two Shapefiles, two DXF files, and one TIF file 
are shown. Several more file formats are supported, as seen by clicking on All Supported 
Types on the Select Basemap File dialog (which opens when clicking Add Map on the 
Project Settings dialog, see Fig. 1.) Note: The list of types is cut off in Fig. 2 after the 
first two entries. 



 
Figure 2. Click on All Supported Types to get a complete list of files that can be used as 
base maps in GFLOW. Note: list in the figure is cut off after the first two entries. 
 
Vector and raster graphics maps added to the Project Settings may be selected for display 
on the View menu (View>Base Map), see Fig. 3. There are three base map management 
options: Vector Graphics, Raster Graphics and Select BBM Group. The first two options 
open a file window in which individual maps (files) can be selected or deselected for 
display. The Vector Graphics window also offers an editing option for Shapefiles, as they 
contain non-standard attributes. The editing option allows the Shapefile maps to be 
colored (in case color information is not in the Shapefile) and attributes displayed as text 
labels. The Select BBM Group overlays the graphics screen with boxes each of which 
contains a group of BBM files (each file is an overlay of roads, hydrography, etc. inside 
that box). You can click in a box and select or deselect some or all of the files for display. 
 
Note: The Tools>Convert menu still contains conversion utilities for CAD and Shapefile 
into BBM, but these conversion options are obsolete in view of the direct import of these 
files on the Project Settings dialog. 
 
 
 



 
Figure 3. Base map management tools on the View menu. 



 

Solution process 
There are several enhancements of the solution process, the most important ones are 
described below. 

 
Fig. 4. The Solver tab of Model>Settings 
 
Solution control files 
The Solver will attempt to read two solution control files in addition to the instructions 
provided in the main input file “basename.dat” . These files are: converge.tab and 
relax.tab. If these files are not found, default values will be used. 
 



 
Fig.5. The editing window for the file converge.tab, which opens upon clicking 
Advanced behind Number of iterations (inner loop). 
 
The first file, converge.tab, contains a table with solution convergence criteria, one for 
each analytic element type. The default (no file in working directory) is that the specified 
number of iterations is used. The file can be created (edited from a default file) by 
clicking the Advanced button after the number of iterations option on the 
Model>Settings>Solver tab (see Fig. 4) and saved to disk using the Save button. I 
recommend that you use this option. When defining these convergence criteria, the 
meaning of the number of iterations on the Model>Settings>Solver becomes that of the 
maximum number of iterations. The “minimum iterations 4”  line in the example file (Fig. 
5) stipulates that, even if the convergence criteria are met, the inner loop must contain at 
least 4 groundwater flow solutions.  In general, when using proper convergence criteria, 
the solution process will be faster and the solution will be more reliable.  
Warning: These criteria only apply to the groundwater flow solution, the surface water 
solution is not being monitored. In most cases, however, the groundwater flow solution 
will only converge if the surface water solution has already converged to a reasonable 
degree.  
Note: The use of these convergence criteria is of special importance when conducting 
parameter optimization with UCODE or PEST. 
 
 



 
Fig. 6. The editing window for the file relax.tab, which opens upon clicking Advanced 
behind Conjunctive Surface Water – Groundwater Solution. 
 
The second file, relax.tab, contains a table with under-relaxation factors for the surface 
water solution process. The default (no file in working directory) is that the relaxation 
factor is 1 (no under-relaxation) for all iterations. An under-relaxation factor as low as 0.5 
may be needed to obtain convergence on large complex stream networks. You may start 
with a low value, say 0.5, and after 5 or more iterations increase the factor to, for 
instance, 0.75. For many difficult to solve stream networks, the relaxation factor should 
be kept well below 1 (e.g. 0.75) for all iterations. The use of an under-relaxation factor 
will increase the number of iterations required for convergence. It will also leave small 
residual errors in the stream flow solution, but they tend to become insignificant (small 
compared to the average stream flow).  
Note: Always try a factor 1 first for all iterations. Only if you observe that the surface 
water solution does not converge (cyclic patterns of smaller errors followed by larger 
errors, etc.) should you experiment with under-relaxation. 
 
Outer  loop for  lake stage calculations 
The option Apply outside loop iterations. Number of iterations on the Solver tab (Fig. 4) 
should be selected only when line-sink lake features are present, see the document 
“Modeling lake – groundwater interactions in GFLOW.pdf.”  Briefly, the lake stage for 
these lakes is calculated iteratively by use of a lake water balance. This requires 
conjunctive surface water – groundwater solutions to be calculated for different lake 
stages, thus the “outside loop”  iterations. As a minimum I recommend 5 outside loops, 
but it is best to specify a lake water balance criterion on the converge.tab file (last 
criterion in Fig. 5) and specify a large number of outside loop iterations on the Solver tab 
(Figure 4), say 20.  
Note: Line-sink type lake features are defined by use of the Lake radio button on the 
Linesink String Properties dialog, see Fig. 7. 



 
Speeding up groundwater  solutions 
The option Store decomposed matrix on disk for faster solve on the Solver tab (Fig. 4) 
may be checked to implement a numerical “ trick”  that speeds up the groundwater flow 
solution, see Using the Sherman-Morrison Formula section in the document “Solution 
strategies in GFLOW.pdf” . In some cases of a difficult to solve problem, the groundwater 
solution may not converge when this option is selected. I recommend that you always try 
this option, but if you have persistent convergence problems, try a run with that option 
deselected. 
 
 
 

Line-sink width parameter 

 
Figure 7. Linesink String Properties dialog 
 
The paradigm of the Resistance, Width, and Depth parameters are described in the 
document “Dealing with resistance to flow into surface waters.pdf.”  Briefly, the Width 
parameter must be set equal to some effective inflow zone in order for the correct amount 
of flow into or out of the surface water feature (stream or lake) to be calculated by the 
Solver. In the previous version of GFLOW this calculation of the appropriate Width 



parameter was the responsibility of the user. The current GFLOW release, however, 
allows for an automatic calculation of the effective Width parameter by the Solver.  
To invoke this feature, you must select the proper line-sink configuration in the box 
Linesink Location (see Fig. 7). When set to Unkown, the user must provide the correct 
Width parameter as in the previous GFLOW versions. All existing project files (* .gfl) 
will default to this option. When set to Along stream centerline (line-sink string along 
centerline of relatively small stream), or Along surface water boundary (double line-sink 
string, one on each side of a wide stream, or line-sink string along a lake boundary), the 
actual surface water width must be entered as the Width parameter (the parameter B in the 
above mentioned document). The Solver will automatically calculate the correct effective 
Width parameter, which will be reported back to the GUI as the width of the line-sink in 
the Model Results table (on Model menu). The Width parameter on the Linesink String 
Properties dialog will remain set to the actual surface water width. 
In case you load a project file from a previous version for further modeling, I recommend 
that you take the time and modify the Width parameter and Linesink Location setting on 
all (nearfield) line-sink strings. While the existing settings will work, the automatically 
calculated Width parameters are preferred since they will remain valid when resistance or 
transmissivity is changed during, for instance, model calibration. When using parameter 
optimization with PEST or UCODE, you must use the automatically calculated Width 
parameter to obtain valid results. 
 
 

Model calibration tools 
 
The GFLOW graphical user interface (GUI) has been significantly enhanced to support 
either manual or automatic calibration. To this end the Test Point feature has been 
expanded, the use of symbolic names for model parameters has been expanded, a 
scenario implementation feature has been added, the calibration statistics have been 
expanded, and a management facility for running PEST and UCODE parameter 
optimizations has been added. In fact, both PEST and UCODE executables and manuals 
are supplied with GFLOW 2.1.0 and integrated into the GUI. 
 
 Test points 

 



Figure 8. Three different types of Test Points.  
 
GFLOW now supports three different types of Test Points: Piezometer, Gags, and Lake 
Stage. Piezometers are identical to the original Test Points where observed heads are 
compared to modeled heads, e.g. in non-pumping wells (piezometers), gravel pits, etc. 
Gages are Test Points that are placed near a line-sink of a stream network to compare the 
observed stream flow with the modeled stream flow. Lake stages are Test Points that are 
placed near line-sinks that define a lake feature for which a lake stage is calculated (thus 
the radio button Lake is selected for that line-sink string (Fig. 7) and outside loop 
iterations applied (Fig. 5).  Each lake needs only one Lake Stage Test Point, of course. 
Each of these Test Point types has its own calibration statistics tab sheet, see 
Model>View Calibration Statistics. Each of these Test Point types forms also a separate 
calibration target group in the PEST and UCODE simulations. Make sure not to use 
Gages and Lake Stages (at least do not make use of their results) when not performing 
conjunctive solutions and lake stage simulations, respectively.  
 
Note: When using Tools>Export or Tools>Import to export or import Test Points using 
* .tpl files, make sure to consult the on-line Help System since the file format has been 
modified to include the Test Point type. 



 
Implement Scenar ios 

 
Figure 9. Dialog opens from Model>Implement Scenario. Symbolic names for model 
parameters are used to run different calibration or sensitivity scenarios. 
 
The Model>Settings dialog, the Linesink String Properties dialog and the Inhomogeneity 
Properties dialog each have a Scenario tab sheet where a symbolic name may be 
specified for some model parameters. These include symbolic names for the hydraulic 
conductivity and aquifer base on the Aquifer tab (not present in Fig. 9), for the resistance 
of one or more line-sink strings, and for the hydraulic conductivity and Added recharge 
rate of inhomogeneties, see the tables in Fig.9). Initially, the Model>Implement 
Scenarios dialog will show the same Current values and Default values. The Current 
values can be modified in this table for calibration purposes or for a sensitivity analysis. 
When clicking Update Database, the Current values are applied to the respective features 
(will show up on their Properties dialogs), but the Default values are retained for possible 
future use. If the calibration procedure has been completed you can overwrite the Default 
values by the Current values by clicking Replace all Default values with Current. If a 



sensitivity analysis is completed, you can restore all Current values to their defaults by 
clicking Replace all Current values with Default. 
After completion of a PEST or UCODE optimization run you can import the optimized 
parameters into the GUI. They will be stored in the Current values. You can test these 
optimized parameters by running the Solver. If satisfied with the results, you can make 
these optimized parameters the new defaults by clicking Replace all Default values with 
Current. 
 
 
 
PEST and UCODE 
 
Parameter optimization (also referred to as automatic calibration) has become rather 
routine practice for most comprehensive modeling projects.  

 
Figure 10. PEST control panel from which to set up and run a PEST session. Optimized 
parameters can be imported directly into GFLOW. 
 
GFLOW has fully integrated parameter optimization facilities using PEST or UCODE. In 
Fig. 10 the PEST control panel is shown as accessed from Tools>PEST. In order to run a 



PEST session, you must have defined symbolic names on the Scenario tabs of the 
Model>Settings dialog, Linesink String Properties dialog, and/or Inhomogeneity 
Properties dialog. You must also have defined a set of relevant Test Points (piezometers, 
stream gages, and/or lake stages) that will serve as calibration targets. Finally, you must 
have set up the proper solution parameters and convergence criteria on the 
Model>Settings>Solver tab. A PEST parameter optimization session is implemented as 
follows: 

1. Delete any previous input and output files using the Delete All PEST Related 
Files button. 

2. Click on Assign Weights to modify any default weights for individual 
observations (Test Points in GFLOW) as desired. These weights are stored in the 
project database and written to the relevant PEST input file. 

3. Click on the Write PEST Input Files button to write default input files. 
4. Edit the file “basename.pst”  (example.pst in Fig. 10) to set up the desired PEST 

run. 
5. Click on Run PESTCHEK and review the program response in the View window 

on the control panel. Correct any errors that are reported by PESTCHEK. 
6. Click on the Run PEST button to execute the PEST simulation. 
7. You can view any or all PEST output files in the View window by double 

clicking them. 
8. If you performed a parameter optimization run, you may import the optimized 

parameters in GFLOW by clicking on the Import Optimized Parameters button. 
The optimized parameters will become the current values as shown on the 
Model>Implement>Scenario dialog, see Model>Implement Scenario. You can 
test them out by performing a model run and make them the default parameters, 
see Fig. 9. 

You may at any time consult the PEST manual by clicking on the View PEST Manual 
button. All PEST components are installed with the GFLOW software. 
 
An example view of the PEST optimization results as they are transferred from PEST 
to GFLOW is shown in Figure 11. 
 



 
Figure 11. PEST optimized parameters can be automatically imported in GFLOW as 
shown by the import log file “PEST2GFLOW.log”  
 
 
A very similar implementation has been provided for UCODE, see Tools>UCODE, 
except that the UCODE optimized parameters cannot be automatically imported. 



 

Inhomogeneity domains 
 

 
Figure 12. The Inhomogeneity Properties dialog. 
 
The organization of the Inhomogeneity Properties dialog has been modified to more 
clearly distinguish between different functionalities of the inhomogeneity domains. As 
may be seen in Fig. 12, there are four (4) different functionalities: the inhomogeneity 
domain redefines the hydraulic conductivity, porosity, aquifer base elevation, or added 
recharge (subtracted if negative). If the only option that is checked is Change recharge 
rate  from default, the polygon that defines the domain can have large sides and the 
domain can overlap other domains. In all other cases, the domains cannot overlap! In case 
one or both of the options Change hydraulic conductivity from default or Change base 
elevation form default is checked, the polygon that defines the domain must have 
relatively small line elements. In unconfined aquifers it is recommended to check Provide 
estimate of average head and provide as good an estimate of the average head along the 
domain boundary as possible. This will improve the convergence of the solution process. 
 
Note: In the previous release of GFLOW the option Provide estimate of average head 
invoked a special procedure, at least under conditions of unconfined flow. In that case, 



the Solver would first treat the change in base elevation as a change in hydraulic 
conductivity (using approximately the same change in transmissivity) and only at the end 
of the iterative solution procedure add a few iterations with the actual base elevation 
change. This procedure is no longer in use. The average head estimate is now only used 
as a starting head for an iterative solution procedure that includes the base elevation 
change for all iterations. 
 
Common domain boundar ies 

 
Figure 13. Yellow and red inhomogeneity boundaries exhibit shared vertices that show 
up with a gray border around the vertex marker. 
 
Inhomogeneity domains can now have common domain boundaries. In order to make a 
boundary section of a new inhomogeneity coincide with a boundary section of an existing 
inhomogeneity you must hold down the CTRL-key when clicking to enter a vertex on top 
of an existing vertex. Coinciding vertices will be marked by a gray border around the 
vertex marker, see Figure 13. You can also move a vertex onto an existing vertex by 
highlighting the vertex using a CTRL-M key stroke, placing the cursor over the other 
vertex, and perform a CTRL-left click.  
 
Note: when moving coinciding vertices (CTRL-M and left-click on new position), both 
will be moved. 
 



Warning: Always check to make sure that common boundaries have truly coinciding 
vertices (gray border around vertex marker), not just vertices that are close. In the latter 
case a nonsensical solution may result. You can check this by selecting View>Show 
Vertices>Inhomogeneity Vertices. 
 
 

Managing hydrological units (HUCs) 
Large model domains may lead to large models in terms of the number of line-sinks, 
inhomogeneity domains, etc. Such large models lead to large numbers of equations that 
slow down the modeling process or cannot be solved at all (too big for the computer 
memory). In many cases, such large model areas may be subdivided into several smaller 
watersheds. Watersheds that are remote from each other, will not impact each others 
groundwater flow regime, at least not directly. Here in lies an opportunity to improve 
modeling efficiency. Instead of solving one big model at once, a set of smaller local 
models may be solved that, when taken together, provide the same representation of the 
groundwater hydrology in the domain. 
 
GFLOW has some management tools to perform the combined modeling of several sub-
domains. These utilities have been developed for the North Carolina Department of 
Environmental and Natural Resources (NCDENR) and the sub-domains used were based 
on the USGS hierarchical watershed categories called HUCs (Hydrological Unit Codes). 
The abbreviation actually refers to the digital coding of these sub-watersheds. I 
recommend that the smallest sub-watersheds be used, which are the 12-digit HUCs. 
 
The implementation of sub-models, based on HUCs, is described in the document   
“Managing Hydrologic Units in GFLOW.pdf.”  Briefly, HUC domains are defined on the 
Model menu, see Fig. 14. Each Hydrological Unit has a Hydrologic Unit Boundary, an 
associated Farfield Boundary, and a Model Boundary. These boundaries are shown in 
Fig. 15. The line-sinks that define streams and lakes inside a hydrologic unit domain are 
written to disk in separate files for each HUC domain. Inhomogeneity domains are also 
written to disk in separate files. This is done on the Tools>Export menu, see Fig. 16. 
These files will later be read back to form a local model. 
 



 
 
Figure 14. Defining Hydrological Unit Boundaries, associated Farfield Boundaries, and 
associated Model Boundaries. 
 



 
Figure 15: The inner red polygon defines a nearfield HUC domain, the green boundary its 
associated farfield boundary, and the yellow polygon is its associated model boundary. 
 
The inner red polygon in Figure 15 defines a nearfield HUC domain, the green boundary 
its associated farfield boundary, and the yellow polygon is its associated model boundary. 
The surrounding red polygons are domain boundaries of HUCs adjacent to the one shown 
in the center (the one with the missing smaller tributaries). Line-sinks inside the center 
domain boundary are treated as nearfield. Line-sinks inside adjacent HUCs and inside the 
farfield boundary (green polygon) are treated as semi-nearfield. Line-sinks between the 
farfield boundary and the model boundary (between the green and the yellow polygon) 
are treated as farfield. Finally, all line-sinks outside the yellow model boundary are 
ignored (not included in the model for the inside HUC).  



 
The model described above is defined in a file * .huc which is an ASCI file edited by hand 
or generated by a GIS system. The file is imported using Tools>Import>Hydrological 
Unit and it will trigger the importation of the data associated with the domains shown in 
Fig. 15. An example * .huc file is listed below. 
 
Path "C:\gflow\models" 
nearfield 
lcc_01.lss 
farfield 
lcc_02.lss 
lcc_03.lss 
lcc_04.lss 
CC_01.lss 
HC_03.lss 
HC_04.lss 
Tar_T3e.lss 
inhomogeneities 
LCC_Recharge.inh 
 
The “Path”  identifies the location of the * .lss files and * .inh files. In the above example, 
the file “ lcc_01.lss”  contains all the line-sinks in the nearfield HUC as well as the 
Hydrologic Unit Boundary, the Farfield Boundary and Model Boundary for that domain. 
The * .lss listed under “ farfield”  contains the same data for the surrounding HUC 
domains. There is only one inhomogeneity domain specified, which defines recharge. 
 
The idea is to solve the model shown in Fig. 15 and make the necessary model 
modifications to achieve calibration. Once calibrated the inside HUC, which serves as the 
nearfield, is written back to disk, see Fig. 16. A new * .huc file is created for a model with 
one of the other HUC domains as nearfield. After model calibration, that nearfield HUC 
is written back to disk. The procedure is repeated until all HUCs that define the larger 
model have been included as nearfield in a local model. This series of overlapping 
models describes the groundwater flow regime in the entire model area. Of course, only 
the solutions in the nearfield HUCs should be relied upon (for instance the inner HUC 
domain in Fig. 15). 
 
 
 
 



 
Figure 16. A Hydrologic Unit containing a Hydrologic Unit Boundary, Farfield 
Boundary, Model Boundary and all line-sinks with attributes that define streams and 
lakes inside the domain are written to disk in ASCI files (option Hydrologic Unit). 
Similarly all data associated with a selected inhomogeneity domain are written to disk 
(option Inhomogeneity is gray, since no inhomogeneity is selected). 
 
  



 

Right-Click to get model results 
 
In case a line-sink or line-doublet (inhomogeneity domain element) is selected, a right-
click will open a data panel with model results that are specific to that element. In Fig. 17 
the data panel is shown for a line-sink that is a stream feature. 

 
Figure 17. The yellow line-sink has been selected (left-click on down gradient vertex) 
and a right-click brings up a Linesink Information panel. 
 
Note that the Width parameter on this data panel has been calculated by the Solver. The 
Width parameter on the Linesink String Properties dialog is set to the actual stream width 
(10 feet in this case). The Discharge is the sink density [L2/T] (extraction rate per unit 
length), the Total Discharge is the total extraction rate for the line-sink [L3/T] (Discharge 
times Linesink Length). The Cumulative Discharge is the total discharge for the entire 
line-sink string. The Base flow (=Stream flow for this case) is the cumulative discharge 
from the head waters down to the end of the yellow line-sink in Fig. 17. 



 

Database searches 
 

 
Figure 18. A database search is carried out on line-sink strings that define streams with 
the condition that the resistance be larger than 1 day. 
 
A database search may be conducted by clicking on the looking glass icon or clicking on 
Tools>Search. In the above example, all line-sink strings that define a stream network 
are searched for strings that have a resistance parameter larger than 1 day. The strings 
found are highlighted and their labels listed in the Search window, see Fig. 17. Similar 
searches may be done for all analytic element types and all attributes. 



Contours 
 

 
Figure 19. There are 6 different types of contours and a custom setting for the contour 
grid resolution. 
 
The Contouring tab on Model>Settings has been expanded to include new Contour Types 
and a custom setting for the contour grid resolution. Potentials are for special use when 
the “discharge potential”  is to be contoured. The Discharge option provides a contour 
plot of the magnitude of the discharge vector, which is helpful in identifying stagnation 
zones. Stream Function is useful for producing stream lines in cross-sectional models, see 
the document “Modeling flow in the vertical plane with GFLOW.pdf.”  Warning: in the 
presence of areal recharge, the stream function contours do not represent stream lines! 
The Drawdowns option will subtract the current heads from those contoured during a 
previous run. For instance, if the previous run has a zero pumping rate for a well, while 
the current run has that well active, drawdowns due to the well will be obtained. For this 
to work you must have contoured heads for the previous run. For the current run you 
must select Drawdowns. Warning: Do not change the window or the Grid Resolution 
settings, otherwise the contour grids are incompatible and heads cannot be subtracted by 
GFLOW to produce the drawdowns. Also, remember to select proper Contour Level data 
for the drawdowns. Finally, remember to set the Drawdowns option back to Heads before 
making a new contour plot. 
 



The Grid Resolution is defined as the number of grid points along the horizontal 
dimension of the window. The vertical grid points are selected based on a square grid. 
The Coarse grid setting is 40 points, the Detailed grid setting is 80 points, and the 
Custom grid setting may be as high as 200 points. Note: for Stream Function contours a 
high grid resolution is recommended to reduce the size of so-called “branch cuts” . 
 
 
 

GUI options 

 
Figure 20. GUI options dialog to customize the GUI. 
 
Use Tools>GUI Options to customize contours and path lines. When using raster 
graphics base maps, analytic element, contour and path line overlays may be difficult to 
distinguish from the busy background. The GUI Options allow you to add a shading to 
line-sinks and haze the background map for better contrast with the overlays. 



 

Particle tracking 
 

 
Figure 21. Use Model>Add Particle Grid to enter a grid of particles for path line tracing. 
 
In addition to entering single particles, you can now also enter a grid of particles by 
clicking Model>Add Particle Grid which brings up a + sign. Drag a window (hold left-
mouse button down) in which to distribute the particles. After the window is complete the 
dialog in Fig. 21 opens. Define the number of particles in the grid and their attributes, 
click OK.  Now click the calculator icon to calculate the pathlines. An example particle 
grid and associated traces are shown in Fig. 22. 
 
You can delete particles by simply clicking on them when in “delete particle mode,”  see 
Edit>Delete Particle Mode. You may also delete all particles in the database at once 
selecting Edit>Delete All>Particles. 
 



 
Figure 22. Multiple path line traces from a particle grid. 
 
 

Line-sink based lake features 
The Lake option on the Linesink String Properties dialog invokes a line-sink based lake 
feature for which the lake stage will be calculated using a complete lake water balance, 
see the document “Modeling lake-groundwater interactions in GFLOW.pdf”  In the 
previous version 1.3.2 it was necessary to add an inhomogeneity domain, coinciding with 
the lake, to remove any recharge. This was the responsibility of the user, who also had to 
make sure that the cumulative recharge in the area of the lake was exactly canceled by 
defining an equal, but negative value as the “added recharge”  for that inhomogeneity. 
This procedure is incompatible with parameter optimization using PEST or UCODE. 
These programs would manipulate the areal recharge, but do not know how to nullify it 
over the lake.  
In version 2.1.0 the Solver will automatically add a “ recharge only”  inhomogeneity and 
assign an “added recharge”  such that the net recharge over the lake is zero. This 
inhomogeneity will coincide exactly with the line-sinks that define the lake and are 
invisible in the GUI. The only place where the inhomogeneity may be seen is in the * .xtr 
file (see Model>View Model Run Files..>Inquiry File). Here the “ recharge only”  
inhomogeneity is written with GFLOW labels that are the same as for the line-sinks that 
define the lake, except that the prefix “LS” is replaced by “ IN” .  
In theory, this modification is backward compatible with the project files created with 
version 1.3.2 that contain user defined inhomogeneity domains for canceling recharge. 
However, it will only be full proof if the inhomogeneity fully covers the lake area. To 
avoid problems, it is best to delete these inhomogeneities after loading an older project 



file in version 2.1.0. This is also more computationally efficient since the Solver will add 
its own inhomogeneity. 
 
 


