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The Project menu facilitates the selection and composition of project files and printing. Each 
project file may have one or more base maps associated with it. The base maps must be 
georeferenced vector or raster graphics files supported by GFLOW. An existing project file is 
selected using Open Database. A new project file is created using New DatabaseÖ . The base 
maps associated with a project file are added or removed on the Project Settings... dialog 
window.  
New Database 
  
Clicking the New DatabaseÖ  option on the Project menu prompts for a project file name. After 
the project file name is entered you are prompted for your choice of units. First select the units 
associated with your base map (meters or feet). Next select either "meters and days" or "feet 
and days" for all input data, the "Units for Computations".  
  
IMPORTANT: These unit choices require some explanation. GFLOW maintains the original 
units associated with the base map files. For instance, when using .bbm files (converted from 
DLG files) these units are METERS. Check the radial button for meters under "Distance units in 
Basemap files". It will display these units on the right-hand side of the status bar.  
Independent from the base map units you are free to use either meters or feet to specify heads. 
If you select feet, you must also enter pumping rates in cubic feet per day and recharge rates in 
feet per day, etc. You must tell GFLOW what you will use by specifying the "Units for 
Computations".  

Incidentally, the GUI converts the map units to the same units as used for computations 
before submitting data to the GFLOW solver (GFLOW1.EXE), hence the solver works in 
consistent units. When the solver hands data back to the GUI, the distance units are 
converted back to the "map units" in use by the GUI.  

Next you enter the Project Settings dialog window. By clicking on Add Map a file dialog window 
is opened. To view a list of all supported file types, click on "All Supported Types". Click on the 
file name to be added to the project file and click OK. Repeat this procedure for the next base 
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map, etc.  
You may add several maps at once in the usual manner (left-click on first file and shift left-click 
on last file of the group of files to be added). Next click OK. 
  
The GUI has created a default Base Filename that is unique for your project. This Base 
Filename will be used to transfer data between the GUI and the Solver. The default filename is 
rather cryptic and may be replaced by a more meaningful name. However, it must be a unique 
and valid DOS name of no more than 8 characters. Like MODFLOW, the solver GFLOW1 is a 
DOS program that cannot read the Project Filename (filename.gfl), which may be longer than 8 
characters and contain spaces. Note: You can also select the working directory where GFLOW 
will store all its intermediate files. It is recommended to keep all project files for a particular 
project in that same directory. 
Warning: The Change Units button allows you to rename the map units or computational units 
in case they were incorrectly set. You are only renaming the units, however. No unit 
conversions take place when changing the units here! 
Click OK to leave the Project Settings dialog window and wait for the maps to be drawn on the 
screen.  
Open Database  
  
Clicking the Open Database option on the Project menu prompts for a project file name. An 
existing project file name may be selected from a list displayed in the browser window. 
  
Make Duplicate Database 
  
Clicking Make Duplicate DatabaseÖ  allows you to duplicate the project file under a different 
name. This is useful when you want to make changes, but retain the original model.  
Note: You may also want to change the name of the Base Filename on the Project Settings 
dialog box. Make sure it is unique. If not, GFLOW may refer to the wrong solution! 
  
Close Database 
  
Clicking the Close Database option on the Project menu clears the current project file. This is 
done automatically when opening a new project file.  
Project Settings 
  
Clicking the Project SettingsÖ  option on the Project menu displays a description of the current 
project (under Description) and associated base maps (under Currently Used Base Maps). You 
may add base maps by clicking on Add Map.. and clicking on the base map name in the 
browser window to highlight a base map name. Click on OK to add it to the project. You may 
select more than one file at the time using the Shift left-click sequence. You may remove a base 
map from the project file by clicking on the base map in the "Currently Used Base Maps" 
window and clicking on the Remove Map.. 
  
The Change Units option is a rescue function in case the Distance units in Basemap Files or the 
Units for Computations have been entered incorrectly in the New Database Wizard, but the 
units of the maps and data entered are correct. For instance, if the coordinates of the basemaps 
are UTM, but the Distance units in Basemap Files have been inadvertently entered as feet, you 
can use the Change Units option to change that in meters.   
Page Setup  
  

Page 2 of 55Menus

4/8/2016file://C:\Documents and Settings\Administrator\Local Settings\Temp\~hhA34F.htm



Clicking the Page SetupÖ  option  on the Project menu will allow you to format the printer page. 
  
Print 
  
Clicking the Print option on the Project menu will open the printer dialog for your printer. Here 
you can control printer options (depending on your printer and printer drivers) and print the 
current graphics screen.   
Exit 
  
Clicking the Exit option on the Project menu will terminate the execution of GFLOW and remove 
the program from the desktop. 
Edit Menu 
  
Select with Window   
Properties  
Move  
Delete  
Refine  
Delete All  
Delete Particle Mode  
Add Text  
Draw Wellhead Protection Area  
Copy to Clipboard  
  
The Edit menu facilitates modifications in model input data.  
You can move, delete, or edit the various analytic elements, delete particles (for particle 
tracing), add text to the graphics screen and copy the graphics screen to the clipboard for 
including it in a Word document, for instance.  
Select with Window 
  
Allows the selection of a group of wells, particles or test points for editing or deletion. After 
selecting the element type on the Select Area dialog and clciking OK you can drag the cursor to 
define a window. 
  
Properties 
  
Will display the properties dialog window for the analytic element selected (with a left-click on 
the cursor), e.g. well, line-sink string, inhomogeneity, horizontal barrier, etc. Alternatively you 
may double click on the vertex to bring up the properties dialog window.  
Move 
  
Will allow you to move the vertex selected (with a left-click on the cursor). The mouse pointer 
will change into a "plus" sign that should be positioned at the new vertex location. Left-click the 
mouse to move the vertex. Alternatively you may press CTRL M to invoke this move feature. 
  
Delete 
  
Will delete the vertex selected (with a left-click on the cursor). Alternatively you may press the 
"delete" key on the key board. 
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Refine 
  
Will add a vertex on either side of the vertex selected (with a left-click on the cursor). The new 
vertices will be placed at the center of the line-elements that are adjacent to the highlighted 
vertex. Alternatively you may press CTRL R to invoke this feature.  
Delete all 
  
Select Hydrography Labels to remove all hydrography labels from the model. 
Select Test Points to remove all Test Points (piezometers, gages, and lake stages) from the 
model. 
Select Particles to remove all particles used for pathline tracing from the model. 
Select Text Labels to remove all text labels (permanent and hydrography) from the model. 
Select Discharge Specified Wells to remove all of them from the model. 
Select Head Specified Wells to remove all of them from the model. 
  
  
Delete Particle Mode 
  
Allows the user to delete multiple particles (for pathline traces) by simply clicking on them. 
Intended for fast delete of particles entered with the Add Particle Grid option on the Model 
menu.  
Text Label Properties 
  
The Add Text option may be used to annotate the base map. Simply click on Add Text and 
move the cursor to the desired starting of the text and click the left mouse button. Type the text 
in the dialog box and press Enter. The text will appear on the base map and is now part of the 
database.  
The Text Label Properties dialog box has two radial buttons:  
  
Permanent Labels  The labels will be permanently displayed. These labels are used to add 
names to towns and roads, etc. 
  
Hydrography Labels  The labels can be activated or deactivated (hidden) by checking or 
unchecking  Hydrography Labels on the View menu. This option is used for indicating surface 
water levels at points along streams. When creating line-sink strings the hydrography labels can 
be made visible to facilitate the definition of starting and ending heads on line-sink strings. 
When not in the process of entering line-sink strings the hydrography labels may be turned off 
to avoid clutter on the graphics screen.  
Draw Wellhead Protection Area 
  
The option Draw Wellhead Protection AreaÖ  may be used to draw an envelope around the 
particle traces from the well or wells. This is also a useful drawing tool for other base map 
annotations.   
Copy to Clipboard 
  
The option Copy to Clipboard saves a bitmap of the graphics box on the clipboard for easy 
inclusion in reports. This option is particularly useful for users of the educational version of 
GFLOW, who do not have a Print option.  
View Menu 
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Elements  
Contours  
Pathlines  
Test Points  
Results Overlay  
Wellhead Protection Areas  
View Hydrography Labels  
Toolbar  
Refresh  
Show Vertices  
Show Stream Linkages  
Manual Redraw  
Base Map..  
Hydrologic Unit  
Haze Background  
  
  
The View menu controls what will be displayed on the graphics screen. The analytic elements, 
various base maps, Contours, Path lines, Test points, Results Overlay, Wellhead Protection 
Areas,  Hydrography Labels, etc. can all be shown together or combined in any way desired. 
Each of these features is seen as a map layer. The various options will only produce results if 
the underlying data layers have been created. For instance, for contours to be displayed, a 
solution with contours must have been generated. To do so, check the Show Contours box 
Model>Settings>Contouring, etc.   
Elements 
    
Check to show a layout of the analytic elements (line-sinks, line doublets, wells, etc.). This 
option is almost always checked. 
Contours 
  
Check to show contour lines, which may be potentiometric contours or any other contour type 
as selected on the Model>Settings>Contour tab. 
Pathlines 
  
When pointing to Path Lines a menu appears from which you may select: 

Show Paths When checked the pathlines will be shown on the screen. 
Time of Travel Tics When pointing at Time of Travel Tics a menu appears from which 
you may select: 

Show Tic Marks If checked, small circles are placed on the pathlines at 
predefined travel time intervals. These travel time intervals are selected on the 
same Time of Travel Tics menu, see below. 
Every 1 year Sets the travel time interval to 365 days. 
Every 2 years Sets the travel time interval to 730 days. 
Every 5 years Sets the travel time interval to 1825 days. 
Custom Ö  Enter the travel time interval for time tics in days.  

Pathline Elevation Tics 
When pointing at Pathline Elevation Tics  you are prompted to  

Show Tic Marks If checked, small green circles will be placed on pathlines to for 
every rise of a predefined interval and blue circles will be placed on the pathlines 
for every drop of a predefined interval. The rise or drop intervals are set using the 
Enter Spacing option, see below. 
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Enter Spacing. If, for example you enter 5, circles are plotted on top of the path 
line at elevations that are multiples of five, e.g. 535, 540, 545, etc. If the path line 
goes downward in the aquifer the circles are green, if the path line goes upward 
the circles are blue. To identify the actual elevations you must count the circles on 
the screen starting at the known starting elevation of the path line as specified for 
the particle. Double (left-)click the particle to display its properties or double click 
the well and select the Other tab to find the starting elevation of particle traced 
backward from the well. 
Note: Three-dimensional pathlines may be displayed outside the GFLOW GUI, for 
instance by exporting the pathlines as a BLN file using the Export option on the 
Tools menu. These BLN files may be imported in SURFER.  

Test Points    
  
When pointing to Test Points a menu appears from which you can select: 

Show Test Points If checked will display at piezometer locations the difference between 
measured heads and modeled heads on the screen as scaled symbols. Similarly the 
difference between modeled streamflow and measured streamflow will be displayed at 
gage locations. The symbol is a triangle centered at the test point location that points 
upward if the model head is larger than the measured head and downward if the reverse 
is true. The triangle is scaled as indicated below. 
Numerical Values If checked the difference ?h between the modeled heads and the 
measured heads will be printed next to each piezometer symbol: ?h=model head - 
measured head. The difference ?Q between modeled stream flow and measured stream 
flow will be printed as a percentage of the measured streamflow: ?Q=((model Q - 
measured Q)/measured Q)*100%  
Scaled Symbols (Piezometers) When pointed at the following option appear: 

+/- 5     If checked the maximum size up and down arrow will indicate a ?h of 5 
feet/meters or larger. 
+/- 10   If checked the maximum size up and down arrow will indicate a ?h of 10 
feet/meters or larger. 
+/- 20    If checked the maximum size up and down arrow will indicate a ?h of 20 
feet/meters or larger. 
  

Scaled Symbols (Gages) When pointed at the following option appear: 
+/- 10%     If checked the maximum size up and down arrow will indicate a ?Q of 
10% of the measured stream flow. 
+/- 50%   If checked the maximum size up and down arrow will indicate a ?Q of 
50% of the measured stream flow. 
+/- 100%    If checked the maximum size up and down arrow will indicate a ?Q of 
100% of the measured stream flow. 
  

Scaled Symbols (Lake Stages) When pointed at the following option appear: 
+/- 5     If checked the maximum size up and down arrow will indicate a ?h of 5 
feet/meters or larger. 
+/- 10   If checked the maximum size up and down arrow will indicate a ?h of 10 
feet/meters or larger. 
+/- 20    If checked the maximum size up and down arrow will indicate a ?h of 20 
feet/meters or larger. 
  

   
Results Overlay  
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When checking the Results Overlay a dialog box appears with Results Overlay Selections: 
  
By checking the box Display Graphical Results Information the layout of line-sinks will exhibit 
line thicknesses proportional to what is checked under What to Display:  

Percent Error Is the difference between calculated and specified head at the center of 
line-sinks with a zero resistance, or is the difference between the line-sink discharge 
(sink density) calculated from Darcy's law applied to the resistance layer and the actual 
discharge calculated by the model. For the case of a head difference the percent error is 
relative to the saturated thickness underneath the line-sink. For the case of the 
resistance line-sinks the percent error is relative to the average discharge for all line-
sinks. 
Strength Is the discharge or sink-density of the line-sink in square feet or square meters 
per day. It will be displayed as a blue line when positive and a pink line when negative. 
Baseflow Only functional when a conjunctive surface water and groundwater flow 
solution is available. When the stream section has no flow it will be displayed by a gray 
line. 
Streamflow  Only functional when a conjunctive surface water and groundwater flow 
solution is available. When the stream section has no flow it will be displayed by a gray 
line. 
Highlight Recharging Colors all recharging line-sinks (negative discharge) light green. 
Highlight Percolating Colors all line-sinks that "percolate" (head in aquifer below the 
resistance layer) as light green. 

  
Note: In order to force the default scaling values, based on the minimum and maximum values 
in the model, you may have to select another option and than select the desired option again.   
Wellhead Protection Areas  
  
Check to show the wellhead protection boundaries drawn with the wellhead protection drawing 
tool.  
View Hydrography Labels 
  
Check to show hydrography labels on the basemap. Hydrography labels are used to determine 
beginning and end heads for line-sink strings. After having created the necessary line-sink 
strings the Hydrography Labels may be turned off to avoid clutter on the screen. See also Add 
TextÖ  on the Edit menu. 
Toolbar  
  
Check to display a toolbar with shortcuts to menu options. 
  
Refresh   
  
The Refresh option redraws the map, which is used in conjunction with the Manual Redraw 
option discussed below. 
  
Show Vertices  
  
Produces a submenu with the following choices: 
  
Line-sink Vertices, when checked, makes the vertices on all line-sink strings visible. This is 
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important when entering inhomogeneity domains to ensure that a line-sink is either entirely 
inside or outside a domain. 
  
Inhomogeneity Vertices. When checked makes all inhomogeneity vertices visible.  
  
Domain and Boundary Vertices, when checked makes vertices on HUC domain boundaries and 
HUC farfield boundaries visible. See also "Managing Hydrologic Units in GFLOW.pdf" in the 
documents folder.  
Show Stream Linkages  
  
The Show Stream Linkages is available only when a solution is present (else it is grayed out). 
The downgradient point of the last line-sink in a string is connected by a red line to the 
upgradient end of the line-sink to which it is connected (to which it gives its streamflow). When 
zoomed out correct linkages will show up as red dots. The end of an "Endstream" linesink string 
is marked with a black dot. Note: Lake features (Lake selected on the General tab of the 
Linesink Properties menu) will have a black dot somewhere on the lake boundary, since they 
are defined as Endstreams even though they may be inside a network (have one or more inlet 
streams and outlet streams. Line-sink strings connected to line-sink lakes that form inlet 
streams should show a connection (red dot). If not they may have been checked as Inlet 
stream, which is reserved for high-k lakes (see comment on Routing tab of Linesink Properties 
menu).  Line-sink strings connected to lakes that form outlet streams, should be checked Outlet 
stream on the Routing tab, but do not show a connection (no red dot).  
Hydrologic Unit  
  
When pointing at Hydrologic Unit a menu appears with the following options: 

Hydrologic Unit Boundary Check to display the boundaries of the hydrological unit 
domains. 
Farfield Boundary Check to display the farfield boundaries associated with the 
hydrological unit domains. 
Model Boundary Check to display the model boundaries associated with the 
hydrological unit domains. 
  

See also "Managing Hydrologic Units in GFLOW.pdf" in the documents folder. 
Manual Redraw   
  
The Manual Redraw option, when checked, prevents the maps from automatically being 
redrawn after data manipulation or solutions. This is useful when working with many maps on a 
slow computer. The user can redraw the maps at will by clicking on Refresh (View menu or 
Window menu).  
Base Map  
  
When pointing at Base Map a menu appears with the following options: 

Show Editor Grid When checked grid lines are drawn with a spacing defined by Editor 
Grid Settings, see below. 
Snap to Grid When checked the locations of vertices of line-sinks or other analytic 
elements are rounded to the nearest grid point. 
Editor Grid Settings Opens the Change background grid spacing dialog box. Enter the 
desired grid spacing in current map units. 
Vector Graphics Opens a dialog to select and unselect vector graphics files for display. 
When unselected, the files will remain associated with the project. They may be 
permanently deleted under Project>Project Settings. 
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Click the Shapefile Settings button to edit Shapefile attributes, click here for details. 
Raster Graphics Opens a dialog to select and unselect raster graphics files for display. 
When unselected, the files will remain associated with the project. They may be 
permanently deleted under Project>Project Settings. 
Select BBM group brings up a box around each group of BBM maps and enters a BBM 
map editing mode. Click inside a box to select the associated BBM maps. A dialog 
comes up that shows the file names of the BBM maps. You can select one or more of 
these files and Hide Maps, Show Maps or Remove Maps  them (from the model). Click 
Apply and then OK to go to another box or click Done Editing BBM Groups to exit the 
BBM editing mode.   

Shapefile Properties 
  
Shapefiles do not have standardized attributes, like CAD files have. The GFLOW GUI will scan 
for color attributes and try to display these colors, but colors may or may not be in the file, or not 
in a form recognized by the GUI.   
The Shapefile Properties dialog provides an opportunity to display attributes of a selected 
Shapefile as text labels and to edit attribute colors or assign a single color for the entire map, in 
case color information is missing. There are two tables of attributes displayed on the dialog: one 
with all attributes that could potentially be displayed as text labels, and one with all attributes 
that could potentially be refer to color information.  
  
Displaying Text Labels.  
Simply highlight the fields in the table that you like to be displayed as text labels on the graphics 
screen. 
  
Displaying the map in color. 
You may overrule color selections for the color types listed in the table. Simply replace the color 
code (integer) by a different code.  
If the table does not show color information the entire map will be displayed in a default color: 
black. To overrule this default, select the radio button "Pick a fixed color" and click on Choose 
Color. The entire map will be drawn in this newly selected color. 
  
These attribute modifications will be saved in the database when clicking Apply Map Changes. 
Repeat this procedure for all Shapefiles in the project database.  
Haze Background 
  
Checking this option will place a haze over the background map. This feature is useful when the 
background map is too busy to clearly see potentiometric contours and other modeling results. 
You can select hazing properties (intensity and color) under Tools>GUI Options. 
Element Menu 
  
To create a new analytic element click on the Element menu and point at New. The following 
options appear.  
  
New 
  

Well 
Linesink 
Horizontal Barrier 
Inhomogeneity 
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The links lead to the Help screens for the Properties dialog windows. Below follows a 
general description of the use of these analytic elements. 

  
  
Uniform Flow 
A Uniform FlowÖ  option on the Element menu allows for conceptual modeling of a well in an 
ambient (uniform) flow regime. Such a solution may provide a first approximation to a capture 
zone for that same well in a flow regime generated by recharge and controlled by surface 
waters which serve as boundaries to the flow field. The Uniform FlowÖ  option is not an analytic 
element. As a rule it should not be used when solving regional flow subject to hydrologic 
boundary conditions. This issue is presented in a text box that appears after clicking on Uniform 
Flow. To enter Uniform Flow, click on Yes and place the cursor (+ sign) on a location where you 
want to enter a reference head (location of known head). Enter the reference head (head at the 
location you placed the + sign), regional hydraulic gradient and its orientation. The orientation of 
the uniform flow is in degrees measured counter clockwise from the positive x-axis. For 
instance, if the flow is due North enter 90, while if the flow is due South enter -90.  Flow that is 
due East may be entered as 180 or -180. 
  
  
  
Wells 
To create a new well click on Element, point at New, and click on Well. Move the cursor to the 
point on the map where the well is to be placed and click the left mouse button. The well is 
drawn on the map and a dialog box appears. 
There are four tab sheets. Most of the time you will need to select the General tab sheet. There 
you can select whether the well is Head-Specified or Discharge-Specified. The coordinates are 
from the map, but if you know exact coordinates you may overwrite them.  
If you intend to use the MODFLOW extract feature and want the well in a particular layer, or if 
you want to specify a partially penetrating well (three-dimensional solution) in GFLOW, you 
should refer to the 3-D Geometry tab sheet. As a rule, you do not need to Use 3-D Partially 
Penetrating Function. It can only be used in GFLOW in areas of confined flow and is 
computationally intensive. However, if you do specify the Top of Screen and Bottom of Screen 
the MODFLOW extract feature will place the well automatically in the proper layer, even though 
GFLOW treats the well as fully penetrating. 
The Transient Well tab sheet is particularly useful when simulating pumping tests. However, 
when the transient effects of the well (e.g. drawdowns) reach a stream or other type of 
boundary condition the conditions at that boundary section will be violated; GFLOW is not a fully 
transient model.  
The Other tab sheet allows for the drawing of a circle around the well, e.g. a sanitary setback 
radius or a fixed radius capture zone (wellhead protection zone). You may also specify how 
many particles should be traced (backward in time) from the well. The starting elevation should 
be below the aquifer top or water table to avoid a trace to prematurely end because the 
streamline entered the aquifer too close to the well. Remember that, although GFLOW is a 
Dupuit-Forchheimer model (2D equations) it does trace streamlines in three-dimensions.  
  

For further details on the well dialog see Well 
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Line-sinks 
To create a new line-sink string click on Element, point at New, and click on Line-sink. A dialog 
box will appear to let you specify a label for the line-sinks (line-sink string). Below it are three 
tab sheets. 
          
The General tab sheet 
This is where you select the type of line-sink string you want to create and provide its 
parameters. 
  
Head-Specified line-sinks 
Usually you will select Head-Specified to represent streams or lakes. You must give a Starting 
Head, which is the water level in the stream at the start of the string you are about to create. 
The Ending-Head, of course, is the water level at the end of the string. You may enter it now or 
after having completed the string, when the dialog box reappears. After clicking on OK move 
the cursor to the location for the first vertex of the line-sink string and click the left mouse 
button. Continue to move the cursor to subsequent vertices and click the left mouse button to 
enter these vertices. Click on the right mouse button after having entered the last vertex of the 
line-sink string. At this point the dialog box reappears and now you must specify the head 
(surface water level) at the end of the string, if you have not already done so. The heads for 
each of the line-sinks entered will be added to those line-sinks by linear interpolation between 
the starting and ending heads you defined in the dialog box. Note: if you marked up the streams 
with water levels (Hydrography labels) you may activate these labels on the View menu prior to 
creating line-sinks.  
Line-sinks can be a near field or a far field feature. If a line-sink is entered in the far field you 
must check the box Treat as "far-field", which will prevent you from specifying a resistance, 
width, and depth parameter. Only if a string occurs in the near field should you uncheck the box 
Treat as "far-field"  to activate these attributes. Once you unchecked the Treat as "far-field" box 
you may specify a Resistance, Width and Depth for the line-sink.  
Important: Line-sinks in the far field should have zero resistance, zero width and zero depth. In 
other words, they must have the box Treat as "far-field" checked. 
Note: Line-sink strings that are used for modeling surface waters with a bottom resistance must 
be given an appropriate width parameter to accurately model the rate of groundwater inflow or 
surface water outflow. You may select the line-sink location as "Along surface water boundary" 
or "Along stream center line" to have the Solver calculate this effective leakage zone 
automatically. For these cases the width parameter is the actual surface water width at the 
location of the line-sink string. 
Note: When the Resistance, Width and Depth parameters are all set to zero, the line-sink string 
must have the box Treat as "far-field" checked. You may opt to give a line-sink string in the 
near-field at least a width parameter other than zero, in which case the maximum infiltration rate 
of the line-sink (when it represent a loosing stream) will be limited to the aquifer conductivity. 
  
Discharge-Specified line-sinks 
When you select Discharge Specified you will be prompted for the Sink Density (line-sink 
strength) at the start of the string and at the end of the string. The Sink Densities for each of the 
line-sinks will be determined by linearly interpolating between these values. Note: Each line-sink 
has one constant sink density, which is the total inflow into the line-sink (cubic feet per day) 
divided by the line-sink length. Hence, the Sink Density is defined in square feet per day or 
square meters per day. When you check Discharge Specified all other options are turned off, 
e.g. you cannot use these line-sinks as part of stream networks. 
  
Drain 
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When Drain is checked the head specified line-sinks will be prevented from recharging the 
aquifer. This option is similar to the drain cells in MODFLOW. 
  
Gallery 
When the Gallery option is checked the line-sink string becomes a horizontal well (gallery) with 
a specified total discharge (pumping rate). The head inside the gallery will be constant along the 
gallery and depend on the pumping rate and hydrogeology of the aquifer. 
  
Lake 
When the Lake option is checked the line-sink string is assumed to define the perimeter of a 
lake. The user must supply lake level estimates and the solver will iterate toward a lake level 
that provides water balance for the lake. For this to occur you must check the box Apply outside 
loop iterations and specify a number of iterations (>3).  
  

For further details, see General Tab under Linesink 
  
  
The Routing tab sheet 
  

The Routing tab sheet is used to make the string you entered part of a stream network in 
GFLOW. The Routing tab sheet is only active when the Treat as Far-Field box is 
checked off, in other words the line-sink strings must be in the near-field. In such a 
network base flow accumulation (routing) will be implemented and line-sinks will not be 
allowed to lose (infiltrate) more water then available as stream flow (base flow plus a 
specified Overland Flow. The End Stream box must be checked if the string is the last 
section of the stream network, hence if it does not connect to any other string. Each 
stream network must contain one End Stream! For a further explanation of the options 
see Routing Tab under Linesink 

  
  
Note: To implement the stream flow routing you must check the box Conjunctive Surface Water 
- Groundwater Solution on the Solver tab of the Model menu.  GFLOW will automatically make 
the stream network connections for the strings. You need more iterations for conjunctive 
solutions than for groundwater flow solutions alone (depending on the complexity of the 
problem 6 iterations or more). When you uncheck the box Conjunctive Surface Water - 
Groundwater Solution the routing settings in the GUI are preserved, but only a groundwater flow 
solution will be generated (no stream flow solutions). 
  
Important: Line-sinks in a stream network (when Use streamflow routing is specified) should 
have an appropriate Resistance, Width and Depth. If these parameters are zero the solution 
may not converge. Line-sink strings that are part of a stream network should only occur in the 
near field. In other words do not declare a line-sink string a near-field feature (Treat as Far-Field 
turned off) when it actually occurs in the far field. 
More details about the theory and implementation of stream flow in GFLOW may be found in 
"Modeling Steady State Conjunctive Groundwater and Surface Water Flow with Analytic 
Elements", Sherry Mittchell-Bruker and Hendrik M. Haitjema, Water Resources Research, Vol. 
32, No. 9, pages 2725 - 2732. 
  

For further details, see Routing tab under Linesink 
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The Scenarios tab sheet 
  
The Scenarios tab sheet facilitates the assignment of a symbolic name to the Resistance of the 
line-sink string. This symbolic name is included in a template file that can be exported for use 
with the automatic calibration tool PEST, see PEST on the Tools menu. 
Note: Symbolic names should not be longer than 12 characters and not contain spaces or any 
of the following characters: , - _ 
Warning: The width parameter on the Line-sink Properties dialog, when properly entered, 
depends on the "characteristic leakage length." For more details click here.  When PEST 
replaces the scenario name with resistance values, this width parameter will not be updated. To 
overcome this problem, the width parameter in the *.tpl file will be set to w=1.0 whenever a 
scenario name is specified. The PEST user must specify the range for the resistance values to 
be used by PEST as the range for c*=c/w, where c* is an effective resistance, where c is the 
actual resistance, and where w is determined in accordance to the "characteristic leakage 
length," which depends on both the actual bottom resistance and the aquifer transmissivity in 
use.  
  
  
  
Horizontal Barriers 
  
To create horizontal barriers click on Element , point at New, and click on Horizontal Barrier. 
You will be prompted for the name of the barrier. If you want to model a closed slurry wall or a 
rock outcrop, or a closed aquifer basin, check the box for Barrier bounds a closed domain. You 
have the option to prevent the plotting of contours in the area inside a rock outcrop, to do so 
check Inside Boundary for the Ignore Region option. If you want to prevent contours outside a 
closed aquifer basin check the box before Outside Boundary. This will lead to cleaner graphics 
and will also instruct MODFLOW to create inactive cells in case you use the MODFLOW extract 
option (see Grid menu). Next enter the hydraulic conductivity of the barrier material, its 
thickness and the depth of the barrier. GFLOW will calculate a conductance for the barrier that 
is based on the barrier properties and its degree of penetration. Groundwater flow will occur 
through the barrier as well as underneath it, unless the barrier extends down to or below the 
aquifer base. 
After clicking on OK move the cursor to the location for the first vertex of the barrier and click 
the left mouse button. Continue to move the cursor to subsequent vertices and click the left 
mouse button to enter these vertices. Click on the right mouse button after having entered the 
last vertex of the barrier.  
Note 1: A horizontal barrier that is a closed no-flow boundary divides the aquifer into two 
independent flow domains. Consequently, at least one head specified boundary condition must 
be specified on the inside of a closed no-flow boundary! 
Note 2: A horizontal barrier creates a jump in the potentiometric head across that boundary. 
Consequently, potentiometric contour lines are bundled up and often ragged next to these 
barriers. This is an artifact of the contouring routine trying to make a smooth potentiometric 
head surface out of the jump. It does not in any way influence the validity of the groundwater 
flow solution.  
Note 3: Horizontal barriers may require a rather high resolution (many vertices). This is 
particularly true for barriers with a rather low resistance, such as partially penetrating barriers. 
Also, open barriers should have rather small line segments near their ends (increased vertex 
density near the ends). 
Note 4: When entering a new horizontal barrier, the bottom of the barrier on the dialog box 
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defaults to the aquifer base elevation (fully penetrating) as specified on the Aquifer tab of 
Model>Settings. If the barrier occurs inside an inhomogeneity area with a different aquifer base 
elevation you should not forget to adjust the bottom elevation of the barrier to keep it fully 
penetrating. 
  

For further details see Horizontal Barrier  
  
  
Inhomogeneity 
  
To create areas with different hydraulic conductivity, aquifer base elevation, porosity and 
recharge due to precipitation, inhomogeneity areas may be used. Before introducing an 
inhomogeneity area it is advised to check the Line-sink Vertices option on the View menu. This 
will make all line-sink vertices visible on the graphics screen, which is important to ensure that a 
line-sink is either entirely inside or outside an inhomogeneity. To enter an inhomogeneity 
domain open the inhomogeneity dialog box by clicking on Inhomogeneity on the Elements 
menu. 
  
The General tab sheet 
  
When only changing the Recharge, leave all other check boxes unchecked and enter the 
recharge rate. The recharge rate will be added to what may have been specified in the area 
with another inhomogeneity. Areas that only define a change in recharge may be placed 
anywhere and may overlap any other analytic element or inhomogeneity domain. This is not 
true for domains that redefine other parameters, see below. 
  
To change the hydraulic conductivity check the box Change hydraulic conductivity from default 
and enter the proper value in the box Conductivity. This value will replace whatever hydraulic 
conductivity was defined earlier on the Aquifer tab sheet or by use of another inhomogeneity 
domain.  Domains with a different Conductivity may not overlap each other, but they may be 
nested or abutted, and should intersect line-sink strings at a vertex (select Line-sink Vertices 
option on View menu to display these vertices). Avoid sharp corners in inhomogeneity domains 
with differing hydraulic conductivity. When the hydraulic conductivity inside an inhomogeneity is 
more than one or two orders lower than the surrounding value a rather large number of vertices 
may be needed along the inhomogeneity boundary.  
  
To change the porosity check the box Change porosity from default and enter the new porosity. 
This value will replace whatever porosity was defined earlier on the Aquifer tab sheet or by use 
of another inhomogeneity. Domains with differing porosity may not overlap each other (they 
may be nested or abutted). Domains with only the porosity defined (all other boxes left 
unchecked) can have any shape and any element sizes (can have few vertices). They do not 
add equations to the solution procedure. 
  
To change the base elevation check the Change base elevation from default box. Enter the new 
base elevation in the Base Elevation box.  
Under unconfined flow conditions, the Solver needs the head distribution along the 
inhomogeneity boundary to arrive at a correct solution. This head distribution is, of course, not a 
priori known. The Solver will use an iterative solution process starting at iteration 1 by using the 
average specified head in the model domain as the head along the inhomogeneity boundary. 
During successive iterations the newly calculated heads along the boundary will be used. You 
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can optionally provide an estimate of the Average Head along the boundary of the domain to 
improve on this iterative solution procedure. This is useful when you encounter solution stability 
problems. Check the box Provide average head for the domain and enter an estimate of the 
average head in the Average Head box. Warning: The default value of the Average Head is 
arbitrarily set equal to the aquifer top, which may be a very poor estimate of the average head 
along the boundary of the domain. Make sure to provide a more reasonable estimate.  Under 
confined flow conditions the head along the inhomogeneity boundary is not being used, 
hence no Average Head needs to be provided. 
  
You may provide the inhomogeneity domain boundary with a unique color using the Color 
selection option on the Inhomogeneity dialog box. 
Click OK to start entering vertices for the inhomogeneity domain. When you entered the last 
vertex right-click the mouse and the domain will automatically be closed. Remember when 
entering domains where the box Change hydraulic conductivity from default or Change base 
elevation from default is checked that you should intersect line-sink strings only at vertices, and 
should avoid making sharp corners. 
Note 1: Make sure the new base elevation does not exceed the anticipated groundwater table 
or the aquifer top! 
Note 2: Make sure that other elements are adjusted to the new base elevation. For instance, 
the elevation of the top and bottom of a well screen and the bottom elevation of a horizontal 
barrier should be set at or above the new aquifer base if they occur inside the inhomogeneity. 
Note 3: The default value of the Average Head is arbitrarily set equal to the aquifer top, which 
may be a very poor estimate of the average head along the boundary of the domain. Make sure 
to provide a more reasonable estimate. 
Note 4: Providing an average head estimate will add three extra iterations to the number 
specified on the Model>Settings>Solver tab. 
  

For further details see General tab under Inhomogeneity 
  
  
The Scenarios tab sheet 
  
The Scenarios tab sheet facilitates the assignment of a symbolic name to the Conductivity of 
the domain or Added Recharge of the domain. This symbolic name is included in a template file 
that can be exported for use with automatic calibration tools such as PEST, see PEST  on the 
Tools menu. 
Note: Symbolic names should not be longer than 12 characters and not contain spaces or any 
of the following characters: , - _ 
  
  
  
  
Well Properties Dialog 

  
The Label is a user definable label for the well, which must be specified. 
  
  
The General tab sheet: 
  
Head-Specified should be selected if the head at the well screen (water level in the well) 
is known and the discharge is to be calculated by the model. This type of well will add 1 
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equation to the solution procedure. 
  
Discharge Specified should be selected if the pumping rate of the well is known. This 
type of well will not add an equation to the solution procedure. 
  
X coordinate and Y coordinate define the location of the well in map units and are 
obtained from the cursor position on the map and may be altered. 
  
Discharge is the average rate at which the well pumps. It must be entered in cubic feet 
per day or cubic meters per day, see units displayed!  Some useful conversion: 
  
Multiply                      by                               to obtain 
GPM                      192.528                     cubic feet per day 
GPM                      5.452393                   cubic meters per day 
GPD                      0.1337                       cubic feet per day 
GPD                      0.0037864                 cubic meters per day 
  
Radius of the well must be set sufficiently large to ensure that the head remains above 
the aquifer base. Most high capacity wells have a radius of 0.5 feet or more (0.2 meters 
or more). 
  
  
The 3-D Geometry tab sheet 
  
Check the Use 3-D Partially Penetrating Function box to use a complete three-
dimensional function for the partially penetrating well. This type of well adds 2 or 3 
equations to the solution procedure, depending on the well being discharge or head 
specified, respectively. 
Note: For most applications this feature is unnecessary. Three-dimensional effects occur 
only in the immediate vicinity of the well (about within two aquifer thicknesses). For 
discharge specified wells the flow regime outside that small domain is the same for a fully 
or a partially penetrating well. 
Warning: This 3-D function (partially penetrating well) can only be used in a confined flow 
zone. This means that inside a radius of about two times the aquifer thickness the head 
must be above the aquifer top. When applying the 3-D functions for a discharge specified 
well in an unconfined aquifer zone an incorrect solution will occur near the well (not 
remote from the well). 
  
The Top of Screen and Bottom of Screen must occur within the confined aquifer near 
the well.   
Important: This option must be set regardless whether the Use 3-D Partially Penetrating 
Function option has been checked if a MODFLOW model will be extracted. The well 
screen settings will place the well in the proper MODFLOW grid layers. 
  
  
The Transient Well tab sheet 
  
Use Theis transient well function box may be checked to create a discharge specified 
well that starts pumping at some specified time (larger than zero).  
  
Cycling pumping box may be checked to create a well that alternatingly pumps and is 
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off for a specified time interval. Cyclic pumping always starts at time zero. For further 
details on how cyclic pumping is implemented refer to Haitjema (1995) section 3.6.3 
  
Storage Coefficient is the dimensionless storage parameter S obtained by multiplying 

the "specific storage coefficient" by the saturated aquifer thickness, see Haitjema 
(1995) equation 3.329 on page 152. In an unconfined sandy aquifer, for instance, the 
Storage Coefficient is a little less than the effective porosity. In a confined aquifer the 

Storage Coefficient is the elastic specific storage (Haitjema, 1995 equation 3.331 on 
page 152) times the saturated aquifer thickness.  
  
Starting head is the (approximate) head at the well prior to pumping. It is used to define 
the saturated aquifer thickness used in the storage term of the Theis equation. 
  
Starting time is the time, larger than or equal to zero, when the well starts pumping. This 
option is replaced by On/Off time period when the Cyclic pumping option has been 
checked.  
  
On/Off time period is the time that the well pumps and the time that the well is off.  
  
Number of cycles is the number of times that the well is turned on and off. For instance, 
with On/Off time = 1 (days) and Number of cycles = 3 the well will be on from time 0 to 1 
(during first day), off from 1 to 2, on from 2 to 3, off from 3 to 4, on from 4 to 5 and off 
after 5 days. 
  
Note: To implement the transient well you must first make a new solution (click the 
calculator icon), which will occur for a default time of zero (no transient effects). Next set 
the time using Model>Time. After that the program will regenerate the contour plot for the 
specified time. The transient well can only be used for a limited pumping time (see 
warning below).  
  
Warning: Transient wells (Theis function) are isolated features that are added to the 
steady state groundwater flow solution. The effects of the transient well are not 
incorporated in the sink densities or strengths of line-sinks or inhomogeneities, 
respectively. Consequently, adding transient wells is only valid so long as their impact 
(drawdowns) does not extend to other analytic elements. The effect of a nearby stream 
on the transient well solution may be approximated by use of an image well, see 
Haitjema (1995) page 159 and figures 3.66 and 3.67. 
  
  
  
The Other tab sheet: 
  
Setback radius defines a circle around the well that may serve as a "sanitary setback" 
or which may reflect a "calculated fixed radius capture zone". The latter calculated fixed 
radius R may be obtained from: 

                                
  
where Q is the pumping rate of the well, t the desired travel time for the fixed radius 

Page 17 of 55Menus

4/8/2016file://C:\Documents and Settings\Administrator\Local Settings\Temp\~hhA34F.htm



capture zone, N the areal recharge rate, n the effective aquifer porosity, and H the 
saturated aquifer thickness. The parameters should, of course, be entered in consistent 
units. Make sure R is in meters or feet as indicated on the dialogue box. A conservative 
(large) value for R is obtained by ignoring recharge; N=0.  
  
Trace particles from well may be checked to create time of travel capture zones for the 
well. Particles will be traced back in time starting at the well and stopping at a travel time 
defined as Maximum Travel Time on the Model>Settings>Tracing tab sheet. 
  
  
Number of particles define the number of path line traces that will occur.  Fifteen path 
lines are suitable for single wells. For more complicated situations, like several nearby 
wells, a higher path line resolution may be needed, e.g. 20 to 25 path lines. The particles 
will be distributed evenly around the well. 
  
Starting elevation is the elevation at which the particles will be distributed around the 
well. GFLOW performs 3D path line tracing, hence the particle starting elevation may 
influence the extent of the path line trace. For instance, if the path line starts close to the 
saturated aquifer top, the path line may stop at the aquifer top before the Maximum 
Travel Time has been obtained. Conversely, if the Starting elevation is set at the aquifer 
bottom, the path line will remain at the aquifer bottom, unless it enters a stream (line-
sink). 
  

Linesink String Dialog 
  
Label is a user definable label for the line-sink string, which must be specified.  
  
General tab 
Routing tab 
Scenarios tab 
  
The General tab sheet 
  
Treat as "far-field" is checked for line-sink strings that represent far field features. When 
checked no Resistance, Width and Depth parameters can be set and the Routing tab 
sheet is not accessible. 
Important: All line-sink strings in the far field must have the box Treat as "far-field" 
checked and thus should not have a resistance, width or depth defined nor should they 
be used as part of a stream network. 
  
The 5 radial buttons on the left define 5 different applications for line-sink strings. 
Depending on the selection, the data fields on the general tab will change. Consequently, 
these data fields will be discussed as a subtopic for each selection. 
  
The 3 radio buttons on the right define the location of the line-sinks when used to model 
flow into or out of surface waters and control the treatment of the width parameter as 
explained below. 
  
Head-Specified should be selected if the line-sink string is used to represent a stream 
section or lake boundary with a given water table. 
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Starting Head Water level in the stream at the starting point of the line-sink string. 
Ending Head Water level in the stream at the end point of the line-sink string. 
Resistance is the thickness of the resistance layer between the surface water 
feature and the aquifer divided by the average vertical hydraulic conductivity of the 
resistance layer. See Haitjema (1995) section 5.2.3 pages 234 - 239. 
Width is a parameter related to an "effective leakage zone" underneath the 
surface water body in case it has a bottom resistance (Resistance parameter 
larger than zero). This effective leakage zone depends on the bottom resistance 
and the aquifer transmissivity and may be calculated as indicated in the document 
"Dealing with resistance to flow into surface waters.pdf" For a summary of 
calculating the width parameter click here. You must do this calculation by hand if 
you check the radio button "Unkown" for the line-sink location. If you check the 
radio button "Along surface water boundary" or "Along stream center line" the 
Solver will automatically do the calculations. For those cases the width parameter 
on the Linesink String Properties dialog must be set to the actual stream or lake 
width. For PEST applications the option "Unkown" should not be used, since the 
Solver must be allowed to recalculate the effective leakage zone based on the 
changing resistance and transmissivity values. The option "Unkown" is included 
for compatibility with older project files where the width parameter has already 
been set equal to the effective leakage zone or when the resistance parameter is 
not used for surface water bottom resistances, but, for instance, to represent 
resistance to three-dimensional flow, see "Accounting for resistance to 3D 
flow.pdf" 
  
Depth is the distance between the surface water elevation and the bottom of the 
resistance layer (like for river cells in MODFLOW). The Depth parameter is used 
to determine the aquifer thickness underneath the surface water (used in 
calculating the effective leakage zone, see width above). The depth parameter is 
also used to determine when a line-sink represents a percolating surface water 
(unsaturated zone between the stream bottom and the groundwater table). 
  

Note: It is recommended to enter line-sink strings along streams going down-stream (into 
the direction of the stream flow). This is particularly important when querying line-sinks 
that are part of stream networks, as it will assure that the stream flow reported actually 
occurs at the vertex that is highlighted. 
  
  
  
Discharge-Specified should be checked is the extraction rate of the line sinks in the 
string is known. 
  

Starting Sink Density Groundwater inflow rate into the stream at the starting 
point of the line-sink string. 
Ending Sink Density Groundwater inflow rate into the stream at the end point of 
the line-sink string. The line-sinks in the string have a constant inflow rate (sink 
density) which is calculated at line-sink centers by linearly interpolating the sink 
densities along the line-sink string between the Starting Sink Density and Ending 
Sink Density. Note: if the string consists of only one line-sink its sink density will 
be the average of the Starting Sink Density and the Ending Sink Density. 
  

  

Page 19 of 55Menus

4/8/2016file://C:\Documents and Settings\Administrator\Local Settings\Temp\~hhA34F.htm



Drain should be checked to create a line-sink string that will extract groundwater, but will 
not infiltrate water (like the drain cells in MODFLOW). Drain elements can only be Head 
Specified. In the near-field drain elements can be given a Resistance, Width and Depth 
parameter, see the discussion under Head Specified line-sinks above. To make the drain 
element a near-field feature you must uncheck the box Treat as "far-field". 

Starting Head Water level in the stream at the starting point of the line-sink string. 
Ending Head Water level in the stream at the end point of the line-sink string. The 
heads at line-sink centers are obtained by linearly interpolating the heads along 
the line-sink string between the Starting Head and Ending Head. 
Resistance is the thickness of the resistance layer between the surface water 
feature and the aquifer divided by the average vertical hydraulic conductivity of the 
resistance layer. See Haitjema (1995) section 5.2.3 pages 234 - 239. 
Width is a parameter related to an "effective leakage zone" underneath the 
surface water body (e.g. ditch) in case it has a bottom resistance (Resistance 
parameter larger than zero). This effective leakage zone depends on the bottom 
resistance and the aquifer transmissivity and may be calculated as indicated in the 
document "Dealing with resistance to flow into surface waters.pdf" For a summary 
of calculating the width parameter click here. You must do this calculation by hand 
if you check the radio button "Unkown" for the line-sink location. If you check the 
radio button "Along surface water boundary" or "Along stream center line" the 
Solver will automatically do the calculations. For those cases the width parameter 
on the Linesink String Properties dialog must be set to the actual stream or lake 
width. For PEST applications the option "Unkown" should not be used, since the 
Solver must be allowed to recalculate the effective leakage zone based on the 
changing resistance and transmissivity values. The option "Unkown" is included 
for compatibility with older project files where the width parameter has already 
been set equal to the effective leakage zone or when the resistance parameter is 
not used for surface water bottom resistances, but, for instance, to represent 
resistance to three-dimensional flow, see "Accounting for resistance to 3D 
flow.pdf" 
  

  
Gallery should be checked to create a line-sink string with a given total discharge 
(pumping rate) and a constant, but a priory unknown head along the line-sink string.  

Total Discharge is the total "pumping rate" of the gallery. 
Starting Head (Minimum) Lowest possible water level in the gallery at the 
starting point of the line-sink string. 
Ending Head (Minimum) Lowest possible water level in the gallery at the end 
point of the line-sink string. The heads at line-sink centers are obtained by linearly 
interpolating the heads along the line-sink string between the Starting Head and 
Ending Head. 
Resistance is the thickness of the resistance layer between the surface water 
feature and the aquifer divided by the average vertical hydraulic conductivity of the 
resistance layer. See Haitjema (1995) section 5.2.3 pages 234 - 239. 
Width is a parameter related to an "effective leakage zone" underneath the 
surface water body (e.g. horizontal well or gallery) in case it has a bottom 
resistance (Resistance parameter larger than zero). This effective leakage zone 
depends on the bottom resistance and the aquifer transmissivity and may be 
calculated as indicated in the document "Dealing with resistance to flow into 
surface waters.pdf" For a summary of calculating the width parameter click here. 
You must do this calculation by hand if you check the radio button "Unkown" for 
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the line-sink location. If you check the radio button "Along stream center line" the 
Solver will automatically do the calculations. For those cases the width parameter 
on the Linesink String Properties dialog must be set to the actual stream or lake 
width. For PEST applications the option "Unkown" should not be used, since the 
Solver must be allowed to recalculate the effective leakage zone based on the 
changing resistance and transmissivity values. The option "Unkown" is included 
for compatibility with older project files where the width parameter has already 
been set equal to the effective leakage zone or when the resistance parameter is 
not used for surface water bottom resistances, but, for instance, to represent 
resistance to three-dimensional flow, see "Accounting for resistance to 3D 
flow.pdf" 
  

  
Lake should be checked to introduce a lake with an a priory unknown lake stage. The 
lake stage will be determined during the solution procedure requiring water balance. For 
a detailed description of this special lake feature, read the document "Lake-Groundwater 
interactions in GFLOW" accessible on the Help menu via the PDF Help Files link or at 
www.haitjema.com 
IMPORTANT:  When the lake stage is known simply represnet a lake with a string of line-
sinks with the radio button Head-Specified checked.  

Lake Bottom is the lowest lake stage that can be obtained. 
Estimated Level 1 and Estimated Level 2 are two different estimates (a high and 
a low, or vice versa) for the lake stage. 
Resistance is the thickness of the resistance layer between the surface water 
feature and the aquifer divided by the average vertical hydraulic conductivity of the 
resistance layer. See Haitjema (1995) section 5.2.3 pages 234 - 239. 
Width is a parameter related to an "effective leakage zone" underneath the lake in 
case it has a bottom resistance (Resistance parameter larger than zero). This 
effective leakage zone depends on the bottom resistance and the aquifer 
transmissivity and may be calculated as indicated in the document "Dealing with 
resistance to flow into surface waters.pdf" For a summary of calculating the width 
parameter click here. You must do this calculation by hand if you check the radio 
button "Unkown" for the line-sink location.  
If you check the radio button "Along surface water boundary" (recommended) the 
Solver will automatically do the calculations. For those cases the width parameter 
on the Linesink String Properties dialog must be set to the actual lake width. For 
PEST applications the option "Unkown" should not be used, since the Solver must 
be allowed to recalculate the effective leakage zone based on the changing 
resistance and transmissivity values. The option "Unkown" is included for 
compatibility with older project files where the width parameter has already been 
set equal to the effective leakage zone or when the resistance parameter is not 
used for surface water bottom resistances, but, for instance, to represent 
resistance to three-dimensional flow, see "Accounting for resistance to 3D 
flow.pdf" 
Depth is the distance between the surface water elevation and the bottom of the 
resistance layer (like for river cells in MODFLOW). The Depth parameter is used 
to determine when a line-sink represents a percolating surface water feature 
(unsaturated zone between the stream bottom and the groundwater table). 

  
Selecting the line-sink width parameter 
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It is recommended to use the Linesink Location options Along stream centerline or Along 
surface water boundary and enter the actual stream width or lake width as the Width 
parameter. However, when selecting Unknown you must select a Width parameter as 
explained in the document  "Dealing with Resistance to Flow into Surface Waters.pdf", 
which is available from the Help menu in GFLOW (View PDF Files..)or found in the user 
folder Application Data/GFLOW. The rules for determining the proper value for the Width 
parameter, as discussed in that document, are summarized below. 
  
Wide streams with line-sinks along both boundaries: 
In the following rules B is the actual stream width, w is the Width parameter to be entered 
on the General tab of the Linesink Properties dialog and { is defined as: 
                                  
where k [m/day or ft/day] is the hydraulic conductivity and H [m or ft] the saturated aquifer 
thickness below the stream. The parameter c [days] is the Resistance as entered on the 
Linesink Properties dialog and equals the thickness of the resistance layer under the 
stream divided by the vertical conductivity of the resistance layer. 
The width w follows from: 
  

                              

               
                          

  
Streams with a single line-sink string along the center line: 
The same rules apply as above, except that B/2 should be replaced by B. 
  
Line-sinks along a lake boundary: 
The same rules apply as for wide streams, whereby the width B must be interpreted as 
the distance between opposite lake boundaries. 
  

Note: The option Unkown for Linesink Location may also be used to represent 
resistance to three-dimensional flow, see "Accounting for resistance to 3D 
flow.pdf" 

Routing Tab 
  
Use streamflow routing should be checked when the line-sink string is part of a stream 
network. 
  
End Stream should be checked if the line-sink string forms the down stream part of a stream 
network, hence if the last line-sink in the string should not be connected to another line-sink 
string. Important: Each stream network must at least have one string with the End Stream box 
checked! 
  
Inlet Stream should be checked only if the line-sink string is an inlet stream for a "high-k lake", 
see the document "Modeling Lake-Groundwater interactions in GFLOW" available in the install 
CD or on www.haitjema.com  Warning: Do not check this option when the line-sink string forms 
an inlet stream for a line-sink lake (a lake formed by a line-sink string with the "Lake" option 
checked on the General tab). 

  
Outlet Stream should be checked if the line-sink string forms an outlet stream for either 
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a "high-k" lake or a line-sink lake. 
  
Overland Flow represents the total volume of water per unit time that enters the line-sink 
string other than as groundwater inflow. For instance, it may represent seepage out of 
shallow water baring formations above the aquifer represented in the model. The 
Overland Flow will be evenly distributed along the line-sink string. 
  
End Inflow represents a total stream flow rate into the first line-sink in the string. It is 
used to model stream flow in streams which headwaters are not included in the stream 
network (or model for that matter). This data item is only available for Head-Specified 
line-sink strings. 
  
Evapotranspiration represents the evapotranspiration rate for the lake per unit area. 
The total evapotranspiration is this rate times the lake area as defined in the stage table, 
see Filename for "stage table" below. This data item is only available for line-sink strings 
that are Lake features. 
  
Precipitation represents the precipitation rate for the lake per unit area. The total 
precipitation is this rate times the lake area as defined in the stage table, see Filename 
for "stage table" below. This data item is only available for line-sink strings that are Lake 
features. 
  
Filename for "stage table" represents the filename of an ASCII file with extension .stg 
that contains a table of lake stages and associated lake areas (for Lake features) or 
surface water flow from the lake into the outlet stream (for Outlet Stream features). The 
file must be user supplied and has the following format: 
  
H1    A1 
H2    A2 
H3    A3 
H4    A4 
Ö . 
Hn    An 
Quit 
  
The first column contains lake stages (with the same datum as the potentiometric heads 
in the model) and the second column contains lake areas (for lake features) and outflow 
rates (volume per unit time) for outlet streams. This table is used by the solver to 
determine the lake area or outlet flow rate. For lake stages below H1 the area or outflow 
rate is A1. For lake stages above Hn the area or outflow rate is An. The area or outflow 
rate for lake stages between H1 and Hn are obtained through linear interpolation 
between the values in the table. 

Scenarios Tab 
  
By specifying a symbolic name for the Resistance on this tab sheet and checking the Include in 
Scenarios option, the line-sink resistance will be included in  PEST runs, see Tools>PEST. 
These symbolic names may also be used for calibration or sensitivity analyses, see 
Model>Implement Scenarios. 
  
Note: Symbolic names should not be longer than 12 characters and not contain spaces or any 
of the following characters: , - _ 
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Barrier Properties Dialog 
  
Facilitates the introduction of no-flow boundaries or barriers with some resistance to flow, such 
as slurry walls. The barrier may be partially penetrating the aquifer, hence not reach all the way 
down to the aquifer base. 
  
The Label is a user definable label for the domain or barrier, which must be specified. 
  
The General tab sheet 
  
Barrier bounds a closed domain should be checked if a closed domain barrier is to be 
introduced. When entering vertices, right click after the last vertex is entered to close the 
domain. 

  
The Ignore Region option is only relevant for contour plotting. If none of the options is 
checked contours will be plotted both inside and outside the domain. 
Inside Boundary should be checked, if you want no contours plotted inside the domain.  
Outside Boundary should be checked if you want no contours plotted outside the 
domain. 
  
The Barrier Properties have the following meaning: 
  
Conductivity is the hydraulic conductivity of the barrier material. 
  
Thickness is the actual thickness of the barrier. 
  
Porosity is the effective porosity of the barrier. It is important for calculating the 
residence time of a particle that crosses the barrier. 
  
Bottom Elevation is defaulted to the model aquifer bottom setting as entered on 
Model>Settings>Aquifer. If the barrier has a bottom elevation equal or lower than the 
aquifer bottom it is fully penetrating. Warning: The GUI does not keep track of changes in 
bottom elevation resulting from inhomogeneity domains. Make sure that the bottom 
elevation of the barrier is set in accordance with the local bottom elevation in the area of 
the barrier.  
  
Click OK to enter the vertices of the barrier. 

Inhomogeneity Properties Dialog 
  
Facilitates the introduction of recharge areas and areas with differing aquifer properties.  
Label is a user definable label for the domain, which must be specified. 
  
The General tab sheet 
  
There are two different types of inhomogeneity domains: Recharge areas and areas with 
differing aquifer properties. Recharge areas are defined as inhomogeneity domains with 
only an added recharge rate, while the aquifer properties are not changed. Areas of 
differing aquifer properties may have added recharge, but also have one or more aquifer 
properties changed from default.  
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Recharge areas. 
  
Only check the box Change recharge rate from Default. 
Enter the desired recharge rate in the box Added Recharge Rate.  
Note 1: Recharge only inhomogeneities may overlap each other or overlap other type of 
inhomogeneities with an Added Recharge Rate. The recharge rates are cumulative! This 
means that at a point that occurs in more than one inhomogeneity the sum of the 
specified Added Recharge Rates applies. 
Note 2: Recharge only inhomogeneities may cross any other element at any location.  
Note 3: Recharge only inhomogeneities may have arbitrary long line elements (line 
doublets) and be of any shape. 
Note 4: Recharge only inhomogeneities are not adding equations to the solution 
procedure in the GFLOW Solver. 
  
Areas with differing aquifer properties. 
  
Before introducing an inhomogeneity with differing aquifer properties it is advised to 
check the Line-sink Vertices option on the View menu. This will make all line-sink 
vertices visible on the graphics screen, which is important to ensure that a line-sink is 
either entirely inside or outside an inhomogeneity.  
  
Select the desired boxes for:  
Change hydraulic conductivity from default,  
Change recharge rate from default,  
Change porosity from default, and  
Change base elevation from default. 
Note 1: Domains with a differing aquifer properties may not overlap each other (although 
they may be nested or abutted) and should intersect line-sink strings at a vertex (select 
View>Show Vertices>Line-sink Vertices to display these vertices).  
Note 2: Avoid sharp corners in inhomogeneity domains with differing hydraulic 
conductivity or base elevation.  
Note 3: When the hydraulic conductivity inside an inhomogeneity is more than one or two 
orders lower than the surrounding value a rather large number of vertices may be 
needed along the inhomogeneity boundary.  
  
When selecting Change base elevation from default you can optionally provide an 
estimate of the average head along the boundary of the domain to improve the 
convergence of the solution procedure. This option is particularly useful for large models 
(many equations) that contain many resistance line-sinks and stream features 
(conjunctive solutions). Check the box Provide estimate of average head and enter an 
estimate of the average head in the Average Head box.  
Warning: The default value of the Average Head is arbitrarily set equal to the aquifer top, 
which may be a very poor estimate of the average head along the boundary of the 
domain. Make sure to provide a more reasonable estimate.  
Note 1: Make sure the new base elevation does not exceed the anticipated groundwater 
table or the aquifer top! 
Note 2: Make sure that other elements are adjusted to the new base elevation. For 
instance, the elevation of the bottom of well screens and the bottom elevation of 
horizontal barriers must be at or above the newly defined aquifer bottom. 
Note 3: The default value of the Average Head is arbitrarily set equal to the aquifer top, 
which may be a very poor estimate of the average head along the boundary of the 
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domain. Make sure to provide a more reasonable estimate. 
Note 4: When you do not check the option Provide estimate of average head, the Solver 
will start the iterative solution procedure using the average of all specified heads in the 
model domain. 
  
You may provide the inhomogeneity domain boundary with a unique color using the 
Color selection option on the Inhomogeneity dialog box. 
  
Click OK to start entering vertices for the inhomogeneity domain.  
When you entered the last vertex right-click the mouse and the domain will automatically 
be closed. Remember when entering domains where the box Change hydraulic 
conductivity from default or Change base elevation from default is checked that you 
should not overlap with other domains, should intersect line-sink strings only at vertices, 
and should avoid making sharp corners. 
Warning: Do not enter a vertex on top of the starting vertex in the string. In other words, 
when closing the domain do not left-click on the first vertex. Instead, enter the vertex at 
the beginning of the last (closing) line-element and right-click the mouse to close the 
string. 
  
IMPORTANT: When abutting inhomogeneity domains you must make the vertices 
on common boundary segments coincide. This is accomplished by moving the cursor 
to an existing vertex of the inhomogeneity with which a boundary segment is to be 
shared, holding down the CRTL key and left-clicking to enter the vertex. The vertex will 
now be forced to coincide with the existing one. 
  
  
The Scenarios tab sheet 
  
The Scenarios tab sheet facilitates the assignment of a symbolic name to the 
Conductivity of the domain and Added Recharge of the domain. When this option is 
selected these parameters will be included in PEST runs (parameter optimization runs), 
see Tools>PEST. These symbolic names may also be used for calibration or sensitivity 
analyses, see Model>Implement Scenarios. 
  
Note: Symbolic names should not be longer than 12 characters and not contain spaces 
or any of the following characters: , - _ 
  

Model Menu 
  
The Model menu controls the operation of the analytic element solver and provides access to its 
results. The following options are available: 
  
Settings  
Solve  
Continue Solve  
Add Particle  
Add Particle Grid  
Add Test Point  
Add Flux Inspection Line  
Add a Hydrologic Unit Boundary  
Add a FarField Boundary  
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Add a Model Boundary  
Model Size  
View Results Table  
View Calibration Statistics  
View Model Run Files  
Time  
Implement Scenario  
Settings 
  
Aquifer tab  
  
Contouring tab  
  
Tracing tab  
  
Solver tab  
  
Scenarios tab 
  
Aquifer Tab 

  
Aquifer Properties  
Base elevation is the elevation with respect to mean sea level of a horizontal no-flow 
boundary that forms the aquifer base. In case the base varies throughout the flow 
domain areas with a different base elevation can be defined using Inhomogeneities, see 
Element menu. The Base elevation specified on this Aquifer tab is the elevation outside 
these inhomogeneity areas. 
  
Thickness is the total thickness of the aquifer material, whether saturated or not! In case 
the aquifer is unconfined a sufficiently large thickness should be specified to ensure that 
the water table will never reach the aquifer top, which elevation is the Base Elevation 
plus the Thickness. The actual saturated thickness of the unconfined aquifer will depend 
on the groundwater flow solution. Make sure that the aquifer base plus the aquifer 
thickness is more than the highest aquifer bottom elevation set in inhomogeneities! 
  
Hydraulic Conductivity specified here will be used throughout the model domain. In case 
the hydraulic conductivity in reality varies over the aquifer domain areas of different 
hydraulic conductivity can be defined using Inhomogeneities, see Element menu. The 
Hydraulic Conductivity specified on this Aquifer tab is the hydraulic conductivity outside 
these inhomogeneity areas. 
  
Porosity in GFLOW is the effective porosity that is used during particle tracing for the 
calculation of travel times. The (effective) porosity should be entered as a fraction, NOT 
as a percentage! In case the porosity in reality varies over the aquifer domain areas of 
different porosity can be defined using Inhomogeneities, see Element menu. The 
Porosity specified on this Aquifer tab is the porosity outside these inhomogeneity areas. 
  
Interface Flow 
Check Add a Saltwater Interface to implement steady state interface flow in GFLOW. The 
salt water is at rest and the interface elevation is calculated using the Ghyben-Herzberg 
relationship. The Solver uses a discharge potential formulation as proposed by Strack 
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(1989) section 10, pages 96 - 112. 
  
Fresh Water Specific Gravity [dimensionless] is the unit weight of the fresh water in the 
aquifer divided by the unit weight of pure water at 4 degrees Celsius. 
  
Salt Water Specific Gravity [dimensionless] is the unit weight of the salt water in the 
aquifer divided by the unit weight of pure water at 4 degrees Celsius. 
  
Average Sea Level is the local average sea level measured with respect to the same 
datum as the heads in the aquifer are measured, e.g. mean sea level (msl). 
  
Note: There are some limitations to the use of interface flow in GFLOW. Read the PDF 
document "Freshwater and Salt Water Interface Flow in GFLOW," which is found  in 
c:\Program Files\GFLOW\Documents before using this feature. You can access this 
document from the Help menu, you may also access the document at www.haitjema.com 
  

Scenarios 
  

You may define a symbolic name for the regional hydraulic conductivity and the aquifer 
base defined on the Aquifer tab. When this option is selected these parameters will be 
included in  PEST runs, see Tools>PEST. These symbolic names may also be used for 
calibration or sensitivity analyses, see Model>Implement Scenarios. 
  
Note: Symbolic names should not be longer than 12 characters and not contain spaces 
or any of the following characters: , - _ 

Contouring Tab 
  
Contour Type 
Check the Compute Contours box to instruct the solver to generate contours of one of 
the following: Heads, Potentials, Discharge, Interface, Stream Function, or Drawdowns. 
The Contour Type is selected by checking the appropriate radio button.  
  
Heads for a potentiometric contours (will jump across horizontal barriers). 
  
Potentials for equipotentials (discharge potentials) (will jump across inhomogeneity 
domain boundaries and horizontal barriers) 
  
Discharge for contours of equal absolute values of the discharge vector. 
  
Interface for elevation contours of the fresh water - salt water interface. 
  
Stream Function to create stream lines. The stream function is only valid in the absence 
of areal recharge! This feature is most useful in cross-sectional models, see "Modeling 
flow in vertical plane.pdf" in the documents folder. To minimize the thickness of the 
branch cut the grid resolution should be selected at 80 or above, see "Grid Resolution" 
below. 
For further reading on the use of the stream function, see Analytic Element Modeling of 
Groundwater Flow, H.M. Haitjema, Academic Press, 1995 page 40 through 57. You may 
also read the document "Modeling flow in the vertical plane with GFLOW," which can be 
accessed from the Help menu as a PDF file. 
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Drawdowns due to a well, for instance, can be shown as follows. First create a contour 
plot of heads without the well pumping. Next, open the Model Settings Contouring tab 
and select Drawdowns, but make sure not to change the grid resolution and not to 
change the window settings. Add the well and solve again. The current heads will be 
subtracted from the previously generated grid with heads and the difference (the 
drawdowns) will be contoured and plotted. Since two grids with head values will be 
subtracted it is essential that the domain (window setting) and grid resolution are the 
same. 
  
  
Contour Levels 
The Minimum Contour value is the lowest level that will be contoured.  
The Maximum Contour value is the highest level that will be contoured.  
The Contour Interval is the increment between successive contours.  
  
Make sure that the values you enter are within the expected range of contour levels. For 
instance, heads near streams will be close to the water levels in the streams. In between 
streams there may be some mounding (rise in head) due to recharge, while near wells 
there may be some drawdown (lowering) of the heads. 
  
Note: When the Stream Function option is selected the Contour Interval will be replaced 
by the Number of stream lines to be contoured. 
  
Grid Resolution 
The default setting is Course, which means that 40 grid points will be distributed in 
horizontal direction over the domain in the graphics window, while points will be 
distributed in vertical direction at the same spatial distance as in horizontal direction.  The 
Course setting is adequate for inspecting most intermediate modeling results.  
The Detailed setting is double the resolution of the Course setting (80 grid points) and 
useful in the presence of jumps in the head, e.g. across horizontal barriers.  
The Custom setting allows the user to specify the resolution up to a maximum of 200 grid 
points (in horizontal direction). Such a high resolution allows for highly detailed contour 
plots. A very high resolution is desirable to reduce the branch cut thickness when 
contouring the Stream Function. For further reading on the use of the stream function, 
see Analytic Element Modeling of Groundwater Flow, H.M. Haitjema, Academic Press, 
1995 page 40 through 57. You may also read the document "Modeling flow in the vertical 
plane with GFLOW," which can be accessed from the Help menu as a PDF file. 

Tracing Tab 
  

             Check Compute Particle Paths to instruct the solver to generate path lines of particles 
starting at the well or at specified particle locations as specified by Add Particles on the 
Model menu.  
  
The Maximum Travel Time defines the extent of the particle trace up to this travel time. 
For instance, if five-year time of travel capture zones are called for you may set the 
Maximum Travel Time to 1825 days. This will cause the path lines starting at the well to 
stop when the average groundwater travel time toward the well is 5 years. 
  
Check the Use Default Step Size of box for normal operation. In case the particle traces 
seem inaccurate a smaller step size may be entered in the dialog box after Tracing Step 
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Size, by first deselecting the Use Default Step Size of. The step size is the approximate 
distance in feet or meters that is traversed during every step along the particle path line. 
  
Note: you may perform instant path line traces from the cursor location using a Ctrl-Shift 
left-click. To set the properties for an instant trace go to Tools>Instant Inspector Settings. 
Particles cause (new) traces after each new solution or change on the 
Model>Settings>Contour or Model>Settings>Trace tab sheet. Instant traces are not 
repeated (no particle location is being stored). 

Solver Tab 
  
Number of Iterations (inner loop)  
These iterations are necessary to deal with non-linear equations that result from streams 
with resistance under unconfined flow conditions, inhomogeneity domains with changing 
bottom elevation under unconfined flow conditions, partially penetrating horizontal 
barriers under unconfined flow conditions, and stream flow solutions that change the line 
sink configuration between iterations. 
For problems without any of these features a single iteration should suffice, although a 
slightly more accurate solution may result from GFLOW's iterative refinement strategy 
when selecting 2 or 3 iterations. Most non-linear problems will converge in less than 6 
iterations, but conjunctive surface water and groundwater solutions may require 6 to 10 
iterations or more.  
The Advanced button behind the Number of Iterations (inner loop) allows the user to 
specify a convergence criterion for each of the analytic element types supported by 
GFLOW.  If all criteria are met the solution procedure is completed, hence the specified 
number of iterations becomes the maximum number of iterations. This feature is 
particularly useful when performing many batch solver runs, for instance, during 
parameter optimization with PEST. The specification of the convergence criteria is 
realized by editing a file "converge.tab." Simply follow the directions in the comment 
statements of that file.  
Note: The minimum number of iterations setting in "converge.tab" dictates the minimum 
number of inner loop iterations in a single outer loop iteration. 
  
Apply outside loop iterations. Number of iterations: Check if one or more line-sink 
lake features are included in the model and specify the number of times the lake stage is 
to be updated. Each update requires the completion of the number of inner loop 
iterations. Warning: Use only when "line-sink lake" features are present ("lake" option on 
the line-sink dialog). 
  
The Conjunctive Surface Water - Groundwater Solution box must be checked to 
implement conjunctive solutions. It may be unchecked, however, even if one or more 
stream networks are defined. In that case, GFLOW simply does not apply the surface 
water calculations and treats the stream networks as regular strings of line-sinks. 
The Advanced button behind Conjunctive Surface Water - Groundwater Solution allows 
the user to specify an under-relaxation parameter to dampen stream flow variations 
during the iteration process. This may increase solution stability, but also increases the 
number of required iterations. The specification of these under-relaxation factors is 
realized by editing the file "relax.tab." Simply follow the directions in the comment 
statements of that file.  
  
  
Store decomposed matrix on disk for faster solve Check to speed up the solution 
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procedure by storing the decomposed matrix on disk. Under certain circumstances this 
option may lead to unstable (diverging) solutions when the problem includes resistance 
line-sinks and/or resistance barriers and /or inhomogeneity domains with a jump in the 
bottom elevation. The option is also not available when a fresh-salt water interface is 
present ("interface" option on the Aquifer tab of the Model>Settings dialog). The option is 
checked as default. 
  
Suppress reporting for faster solve. Check to avoid error reports on groundwater flow 
boundary conditions and stream flow to speed up the solution process. An error report 
will still be provided after the last iteration. This option will only lead to noticeable 
speedup for large models (> 300 equations) and is specifically useful for batch runs (e.g. 
PEST applications). 
  
View error log file after solve.  If checked the error.log file that contains a solver error 
report will automatically be opened after the solver ends. If the file contains no errors, it 
will not be displayed, regardless of this setting. 
  
View message.log file after solve. If checked the message.log file containing a solver 
report on the solution process will automatically be opened after the solver ends. This file 
contains a listing of the maximum errors detected at collocation points for the various 
analytic elements as well as responses related to the stream flow solution (for 
conjunctive solutions).  
  
Note: If the above two options are unchecked, the files error.log and message.log can 
still be opened from Model>View Model Run Files.. 

Solver Convergence Criteria 
  

In this file "converge.tab" you can set a convergence criterion for each of the analytic 
element types supported by GFLOW.  If all criteria are met the solution procedure is 
completed, hence the specified number of iterations becomes the maximum number of 
iterations.  
This feature is particularly useful when performing many batch solver runs, for instance, 
during parameter optimization with PEST.  
The specification of the convergence criteria is realized by editing a file "converge.tab."  
This file must reside in the working directory where the Solver is also finding the input file 
"basename.dat." 
An example file with default values is shown below: 
  
* test file "converge.tab" 
* 
* Note: all lines below must be present in that order! 
* 
  minimum iterations    50 
  reference point       0.0001 
  linesinks dirichlet   0.0001 
  linesinks resistance  0.1 
  inhomogeneity domains 0.01 
  barriers noflow       0.001 
  barriers resistance   0.01 
  wells 3D              0.01 
  wells 2D              0.0001 
  quit 
* 
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Note, in this example, that line-sinks with a specified resistance are considered 
sufficiently accurate when the Cauchy boundary condition is met within 0.1%, while 
Dirichlet boundaries (head specified) have been given a much stricter convergence 
criterion; they must be met within 0.0001%.  
When performing PEST runs, it is recommended that you perform a few GFLOW runs 
with bounding parameter values (use Model>Implement Scenario option) and observe 
the maximum errors in boundary conditions as reported in the "message.log" file. Use 
these experimental runs to set a maximum number of iterations and appropriate 
convergence criteria for the various analytic element types. 

Surface Water Solution Relaxation Parameter 
  
The file "relax.tab" should be in the working directory for the project. It controls the 
surface water calculations during conjunctive solutions. For relatively simple problems 
the conjunctive surface water and groundwater solution procedure will converge fine with 
no under relaxation for the surface water calculations (relaxation = 1). However, for some 
more complex problems, including extensive stream networks, under relaxation may 
improve solution stability. Under relaxation, however, will increase the number of 
iterations required to obtain convergence. 
  
An example default file "relax.tab" is shown below: 
  
* Format of the file "Relax.tab": 
* 
* * comment statement (* in first column) 
* * iteration #     relaxation factor 
*   1                   0.5 
*   5                   0.8 
*   8                   0.9 
* quit 
* 
*      The effect of this file is as follows: During the first 5 iterations a (under)relaxation factor 
*      of 0.5 is used. During the next 3 iterations a relaxation factor of 0.8 is used, while after 
*      that the relaxation factor is set to 0.9. 
*      NOTE: The relaxation factor should NEVER be set larger than 1.0 
* 
1 1 
quit 
  
  
Note 1: The current setting, as seen at the bottom of the file, is that the relaxation factor 
is set to 1 starting at iteration 1, hence no under relaxation is being used. 
  
Note 2: For some runs it may be necessary to keep sufficient under relaxation for all 
iterations, for instance never raise the relaxation factor above 0.75. 

Solve 
  

Click to start the solution procedure. The Solver (GFLOW1.EXE) will be scheduled and 
runs in the DOS box. The messages that scroll over the screen contain errors at 
boundary conditions and errors in stream network calculations. These messages are 
echoed to the file "message.log", which can be accessed by Model>View Model Run 
Files>Runtime Message File. After a solution has been obtained and after a redraw, you 
should check the Runtime message File to verify the accuracy of the solution. 
In case a valid solution already exists (which means you did not alter critial data in the 
model), you are asked to Resolve or to use the current solution for new contours, 
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pathlines, or flux inspector results.  These options do not require a resolve.   
Continue Solve 

  
Number of additional iterations (inner loop): defines the number of surface water (if 
conjunctive solutions are defined on Model>Settings>Solver tab) and groundwater flow 
solutions. 
  
Apply outside loop iterations. Number of iterations: Check if one or more line-sink lake 
features are included in the model and specify the number of times the lake stage is to 
be updated. Each update requires the completion of the number of inner loop iterations. 
  
Suppress reporting for faster solve Check to avoid error reports on groundwater flow 
boundary conditions and stream flow to speed up the solution process. An error report 
will be provided after the last iteration. This will only lead to noticeable speedup for large 
models (> 300 equations). 
  
Store decomposed matrix on disk for faster solve Check to speed up the solution 
procedure by storing the decomposed matrix on disk. Under certain circumstances this 
option may lead to unstable (diverging) solutions when the problem includes resistance 
line-sinks and/or resistance barriers and /or inhomogeneity domains with a jump in the 
bottom elevation.  
  
View error log file after solve.  If checked the error.log file that contains a solver error 
report will automatically be opened after the solver ends. 
  
View message.log file after solve.  If checked the message.log file containing solver 
output on the solution process will automatically be opened after the solver ends. This file 
contains a listing of the maximum errors detected at collocation points for the various 
analytic elements as well as responses related to the stream flow solution (for 
conjunctive solutions).  

Particle Properties Dialog 
  
This box will appear after having defined a particle location using the "Add Particle" 
option on the Model menu. The particles will form the starting point of path lines.  After 
that select Forward in time or Backward in time as tracing options. Backward in time will 
cause the particle to be traced in a direction opposite the groundwater flow direction. 
The Starting Elevation of the particle may be set at the water table or aquifer top by 
checking the box in front of "Start at top of saturated thickness." Unchecking that box 
allows the specification of a particle starting elevation.  
Note 1: The starting elevation must be inside the aquifer (between the local aquifer 
bottom and aquifer top). In case the particle elevation is inside the aquifer, but above the 
water table, the Solver will drop the particle to the water table and start the trace. 
  
Note 2: If the starting elevation is at the water table and the option Backward in time is 
selected, no path line may appear. This is due to the fact that the particle moves opposite 
the direction of flow and thus immediately leaves the aquifer (if recharge is present). 
  
Note 3: You may perform instant path line traces from the cursor location using a Ctrl-
Shift left-click. To set the properties for an instant trace go to Tools>Instant Inspector 
Settings. Particles cause (new) traces after each new solution or change on the 
Model>Settings>Contour or Model>Settings>Trace tab sheet. Instant traces are not 
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repeated (no particle location is being stored). 
  

Particle Properties Dialog 
  

This box will appear after having defined a window in which particles are to be distributed 
using the Add Particle Grid.. option on the Model menu. The particles will form the 
starting point of path lines. Specify the Number of Particles you want distributed in the 
window. After that select Forward in time or Backward in time as tracing options. 
Backward in time will cause the particle to be traced in a direction opposite the 
groundwater flow direction. 
The Starting Elevation of the particle may be set at the water table or aquifer top by 
checking the box in front of "Start at top of saturated thickness." Unchecking that box 
allows the specification of a particle starting elevation.  
Note 1: The starting elevation must be inside the aquifer (between the local aquifer 
bottom and aquifer top). In case the particle elevation is inside the aquifer, but above the 
water table, the Solver will drop the particle to the water table and start the trace. 
  
Note 2: If the starting elevation is at the water table and the option Backward in time is 
selected, no path line may appear. This is due to the fact that the particle moves opposite 
the direction of flow and thus immediately leaves the aquifer (if recharge is present). 
  
Note 3: You may perform instant path line traces from the cursor location using a Ctrl-
Shift left-click. To set the properties for an instant trace go to Tools>Instant Inspector 
Settings. Particles cause (new) traces after each new solution or change on the 
Model>Settings>Contour or Model>Settings>Trace tab sheet. Instant traces are not 
repeated (no particle location is being stored). 
  
  
  

  
Test Point Properties Dialog 

  
Facilitates the definition of locations where the groundwater elevation or potentiometric 
head is known (piezometers) or where the stream flow in a stream is known (gages), or 
where a lake stage is known (Lake Stage). These test points are used during model 
calibration. They are also used as calibration targets during parameter optimization with 
PEST, see Tools>PEST. 
Select the radio button for Piezometer, Gage, or Lake Stage to enter a test point with an 
observed head, observed stream flow, or observed lake stage, respectively. 
  
When adding a Piezometer place it at the location of a well with a reported static water 
level or a gravel pit, etc. 
  
When adding a Gage, place it next to the end vertex of the line-sink for which you want to 
specify an observed stream flow. Note: that line-sink must be part of a stream network 
and you must have specified a "conjunctive surface water - groundwater solution" on the 
Model>Settings>Solver tab to get a meaningful test point response. 
  
When adding a Lake Stage place it near one of the line-sinks of a line-sink lake feature, 
see Lake option on the Linesink String Properties dialog. Note: Make sure that outer loop 
iterations are specified, see Model>Settings>Solver tab in order to get a meaningful test 
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point response.. 
  
A Label may be specified to identify the test point on the map. The label will not be 
posted on the map, but can be requested by clicking on the test point marker and clicking 
on properties on the edit menu. 
Note: The label should be limited to 20 characters and not contain any spaces 
  
For Piezometer the known potentiometric head at the test point is entered in the box after 
Observed head. 
  
For Gage the known stream flow in the stream section near the test point is entered in 
the box after Observed Streamflow. 
  
For Lake Stage the known lake stage elevation for the lake in which the test point is 
placed is entered in the box after Observed Stage. 
  

Flux Inspection Line Properties 
  
Facilitates the definition of lines across which the groundwater flux will be calculated. The 
"flux" is calculated as the total flow (ft3/day or m3/day) over the aquifer height and along 
the poly- line. 
The flux inspection poly-lines are plotted on the base map as a purple dashed line or 
poly-line. 
  
Flux inspection lines have an orientation: the first point entered is the starting point, 
marked with a small diamond. A positive flux implies water flowing from left to right 
across the line, when viewed from the starting point! 
  
The Name is a user definable label to identify the flux inspection line.  

Hydrologic Unit Domains 
  
Hydologic Unit domains are often referred to as HUCs (HUC: Hydrologic Unit Code). 
These domains are sub-watersheds that typically have only one inlet stream and one 
outlet stream, although this is not required for the implementation in GFLOW. A large 
model domain may be subdivided into HUCs and a subset of these HUCs may be read 
into GFLOW for a local model (see Tools>Import>Hydologic Unit). At least one HUC is 
read in as a "nearfield" domain, while the surrounding HUCs must be read in as "farfield" 
domains. Inhomogeneities that redefine aquifer properties and recharge rates are also 
read in from separate files. The HUCs reside on disk in ASCI format files. 
  
Before using this feature the user should read the document "Managing HUCs in 
GFLOW" stored as Managing HUCs.pdf in the document folder C:\Program 
Files\GFLOW\Documents. 
  
HUCs are defined in GFLOW by entering polygons as follows: 
  
Add Hydrologic Unit Boundary.. Allows the user to enter a name (e.g. the Hydrologic Unit 
Code) and select a color for the boundary. Click OK and enter a polygon around the 
stream and its tributaries that define the sub-watershed that is the hydrologic unit. 
  
Add FarField Boundary.. This option will only become available if a HUC boundary exists 
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and is selected (highlighted). The label for the FarField boundary is predefined based on 
the label for the HUC boundary and cannot be altered. You can select a color. Enter a 
polygon outside the HUC boundary that includes all stream sections that you want 
treated as nearfield when modeling the current HUC as nearfield. Note: only the starting 
vertex of a stream reach has to be inside the FarField boundary for the entire stream 
reach to be treated as nearfield. All stream reaches that occur outside the HUC 
boundary, but inside the FarField boundary will be defined as "End Streams," which 
means that, in case they are loosing water, they may fall dry in the absence of stream 
flow. However they are not networked (do not contribute water to the stream reaches to 
which they connect).  
  
Add Model Boundary.. This option will only become available if a HUC boundary exists 
and is selected (highlighted). The label for the Model boundary is predefined based on 
the label for the HUC boundary and cannot be altered. You can select a color. Enter a 
polygon outside the HUC boundary and outside the FarField boundary that includes all 
stream reaches that you want to keep in the model when the current HUC is modeled as 
a nearfield feature. This boundary is optional and intended to limit the model size 
(number of farfield line-sinks in the model) to increase computational efficiency. 
  
For further reading refer to the document "Managing HUCs.pdf" in the document folder 
C:\Program Files\GFLOW\Documents. 

Model Size 
  

The total number of wells, line-sink strings, line-sinks, inhomogeneities, inhomogeneity 
elements, barriers, and barrier elements are reported. Each line-sink adds one equation, 
each barrier element adds two equations, and each inhomogeneity element adds two or 
three equations to the model. For fast interactive model response the number of equations 
should be limited to a few hundred or no more than a thousand. Models with more than a 
thousand elements are considered very large. A beginners mistake is to use too detailed a 
line-sink representation of streams, particularly in the far field. Only in the immediate area of 
interest is a more detailed representation warranted. It is best to start with relatively few 
detail (a few hundred equations) and add detail as needed.  

  
View Results Table 

  
Provide access to the some relevant data from both the GUI and the Solver, including 
computational results. 
  
View 
Well  
Displays data for all wells. GFLOWlabel is the GUI generated label used by the Solver and 
reported as part of error messages from the Solver. 
  
Line-sinks 
Displays data for all line-sinks. GFLOWlabel is the GUI generated label used by the Solver and 
reported as part of error messages from the Solver. 
  
Test Points 
Displays data for all test points (piezometers). VID is the GUI vertex identification number, which 
may be ignored. 
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Flux Inspection Lines 
Displays data for all flux inspection lines. PID is the GUI polyline identification number, which 
may be ignored. TotalFlux is the total flow (cubic meters per day or cubic feet per day) across the 
flux inspection line. 
            
            Inhomogeneities 
            Displays data for all inhomogeneity domains. Many of the data items are of little interest 
to the user, except for the total domain area in the 7th column. 
  
Edit 
Copy  
Will copy all columns to the clipboard for pasting in a spreadsheet, for instance, in Microsoft 
Excel. 
  

View Calibration Statistics 
  

The View Calibration Statistics option on the Model menu provides access to some statistics 
on the comparison between: 
  

modeled and observed heads (piezometers) 
modeled and observed stream flow (gages) 
modeled and observed lake stages (lakestages) 

  
These statistics are provided on three different tab sheets and based on the three different 
Test Point types: piezometers, gages, and lake stages. 
  
Caution is to be used in interpreting these results when only few Test Points are available, 
see Number of Observations box. For meaningful statistics it may be advisable to only use 
Test Points in the near field. These statistics are best used in conjunction with the graphical 
display of head differences, stream flow differences, and lake stage differences at Test 
Points to identify trends and to distinguish between areas of better and lesser fits between 
observed and measured values. See the Test Points option on the View menu. 
  
The calibration results can be copied to the clipboard using the Edit>Copy Chart option. To 
view the numerical data simply Paste the clipboard contents to Word or Excel. To view the 
graph, you must use the option Edit>Paste Special in Word or Excel. 

  
View Model Run Files 

  
The following files can be accessed: 
  

Input File:       ASCII script file with instructions and data produced by the GUI and read by 
the solver. Filename: basename.dat 
  
Error Log File:       ASCII response file from the solver with error messages. The file will 
contain only an * on the first line if no errors were found. Filename: error.log 
  
Contour File:   ASCII file with vertices of contour lines produced by the solver and used by 
the GUI. Filename: basename.ctr 
  
Trace File:      ASCII file with vertices of path line traces produced by the solver and used by 
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the GUI. Filename: basename.pth 
  
Inquiry File:     ASCII file with solver results requested by the GUI. Filename: basename.xtr 
  
Runtime Message File: ASCII file with the responses from the solver that scroll over the 
screen during a solve operation. This file documents, among others, the progress of the 
solution during successive iterations. For further details see Runtime Message File  
Filename: message.log 
  
Command Echo File: ASCII file with a copy of all the command that were received by the 
solver. Filename: echo.log 
  
Note: As a rule the user does only have to access the Runtime Message File. 

Runtime Message File 
  
The file is an echo of Solver messages generated during the solution process. For each 
iteration a solution progress report is given and errors at boundary conditions are 
provided. The errors are relative errors in % of the head or flow or other relevant 
property. The % errors have the following meaning: 
  
Head specified line-sinks--- difference between the calculated and specified head as a 
percentage of the specified head measured with respect to the aquifer base. 
Resistance specified line-sinks---- difference between the inflow into the line-sink 
calculated by Darcy's law in the vertical direction (flux across the resistance layer) and 
the actual sink density of the line-sink as a percentage of the average of the two. 
Line doublets in inhomogeneity domains---- difference between the heads on either side 
of the line-doublet as a percentage of the head. This difference should be zero (no jump 
in the head). 
Line doublets in horizontal leaky barriers---- difference between the actual flow across a 
barrier segment (approx. line doublet length) and the flow calculated from the line doublet 
strength as a percentage of the actual flow. 
Line doublets in horizontal no-flow barriers---- total flow across a barrier segment 
(approx. line doublet length). 
  
The errors reported are the largest found for the group of elements. 
  

In addition to these summary error reports, you may inspect the data (and errors) 
of individual elements. To do so, click the View Results Table on the Model menu. 
Select Wells, Line-sinks, or Inhomogeneities and pertinent data will be listed in a 
table. You may also right-click on a selected element to open a data box that 
includes the error. Finally, errors can be visualized using the View>Results 
Overlay option and selecting to plot line thicknesses proportional to the % errors. 
  

  
For conjunctive surface water and groundwater flow solutions the stream flow solution 
also produces error messages, these are: 
  
Negative streamflow in line-sink Ö  the line-sink is part of a stream network and is found 
to infiltrate more water than the available stream flow. The infiltration rate is limited to the 
amount of available streamflow and a new solution is required. 
Underinfiltration in line-sink Ö .the line-sink is part of a stream network and does not 
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infiltrate enough water based on Darcy's law in vertical direction. The line-sink was 
probably discharge specified in the previous iteration, but the groundwater table has 
dropped and the line-sink should become head specified again. A new iteration is 
needed.  
Overinfiltration in line-sinkÖ . the line-sink is part of a stream network and is found to 
infiltrate more water than it should based on Darcy's law in vertical direction. The line-
sink was probably discharge specified (limited in infiltration) in the previous iteration, but 
the new groundwater table is higher and the line-sink should become head specified 
again. A new iteration is needed. 
  
For models with one or more line-sink lake features a water balance report for the lake is 
included in the Runtime Message File, for each inner loop. 
  
In case the option Suppress error reports for faster iterations is checked on 
Model>Settings>Solver or Model>Continue Solve, the error reports will only occur at the 
end of the last iterations. 

Time 
  
  
The Time option allows the specification of a time for which a contour plot is to be 
generated in case transient wells are specified (use of Theis' solution), see the Well 
dialog box. If no transient wells are specified, the time setting is ignored. 

Inplement Scenario 
  
Facilitates the implementation of scenarios.  This feature facilitates trial and error 
calibration procedures or sensitivity testing by temporarily modifying sets of related 
parameters as defined by symbolic names on the Scenario tab sheets.  
  
Different scenarios of property values can be run by selecting alternative Current values. 
The Default values are retained. At the end of one or more scenario runs you may 
selectively replace Default values with Current values, replace all Default values with 
Current values, or return back to the initial values by replacing all Current values by the 
Default values.  
  
  
All symbolic names for global aquifer properties, inhomogeneity properties, and line-sink 
resistances are listed together with their Current values and the associated Default 
values. The Default values are the values entered on the various Properties forms. The 
Current values are set equal to these defaults, but can be modified in the tables on this 
Implement Scenario dialog. When clicking on Apply, these Current values replace the 
values entered on the various Properties dialogs, however, the original values (Defaults) 
are retained for later use. A subsequent model run will use these new Current values and 
they will appear on the Properties dialogs.  
  
When using this option for purposes of sensitivity testing, the Current values must be 
reset to the original Default values at the end of the sensitivity testing process. This may 
be done by clicking Replace all Current values by Default values on the Implement 
Scenario dialog. 
  
When using this option for calibration purposes, you may want to make the entire set of 
Current values the new Default values after the calibration process is completed. This 
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may be done by clicking Replace all Default values by Current values on the Implement 
Scenario dialog. 
  
Note 1: Changes made on the Implement Scenario tables are only saved to the 
database (thus in effect) after clicking the Apply button.  
  
Note 2: You may replace all Current values by the results of a PEST parameter 
optimization run using the Import Optimized Parameters button on the Tools>PEST 
control panel. You may then decide to make these parameters Defaults or not. 
  
Note 3: Symbolic names should not be longer than 12 characters and not contain spaces 
or any of the following characters: , - _ 
  
  
  

Grid Menu 
  
The Grid menu facilitates the extraction of a MODFLOW model from the GFLOW model domain 
or the creation of a hybrid GFLOW - MODFLOW model by adding a grid of leakage values 
obtained from a multi-layer MODFLOW model at the bottom of the GFLOW model. These two 
options are accessed by the following submenus of the Grid menu, respectively.  
MODFLOW Extract 
Leakage from MODFLOW  
MODFLOW Extract 
  
Facilitates the extraction of a MODFLOW model by designing a MODFLOW grid covering part 
of the GFLOW model area. The grid may be scaled, rotated and shifted over the model domain. 
Gridlines may be shifted for local grid refinement. Aquifer properties and boundary conditions 
are assigned to the grid cells based on the existing GFLOW solution. 
To create a grid, click on Grid on the menu bar and click on MODFLOW Extract>Show Grid 
Dialog. The Finite Difference Grid dialog contains four menus: File, Edit, View and Processing. 
To create a new grid the New Grid option on the File menu must be selected. A dialog box will 
open that allows you to select the grid geometry. After clicking on the Create Grid button the 
grid can be oriented on the map. Using the Processing menu the boundary conditions and 
aquifer properties are assigned and MODFLOW files are written. 

  
There are four menu options on the Finite Difference Grid dialog of MODFLOW Extract: 
  
File   
  
Edit   
  
View   
  
Processing   
  

File 
  
Click on New Grid when you want to create a new grid rather than edit an existing grid. 
The New Grid option will open the MODFLOW Extract dialog box to select grid geometry 
properties. The MODFLOW Extract dialog box has three tabs: Grid, Layers and 
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Tracking.  
Start with the Grid tab. 
The lower left corner of the grid defaults at the origin of a local coordinate system. You 
do not have to modify the Lower Left X and Lower left Y boxes, which values will be 
automatically assigned when locating the grid on the map. Grid dimensions and 
resolution are determined by selecting Row Spacing and Column Spacing and the 
number of Rows and Columns in the grid. Rotation is the orientation of the rows 
measured with respect to a horizontal line. For instance, a 30 degree rotation tilts the grid 
in counter clockwise direction over 30 degrees. Select the number of layers in the grid. 
Layer Thickness refers to the default thickness of a model layer. The anisotropy is the 
horizontal hydraulic conductivity (Kh) over the vertical hydraulic conductivity (Kv). The 
grid Perimeter may be either Head Specified or Flux Specified, using data obtained from 
the GFLOW solution. When selecting a Flux Specified condition the heads at the grid 
perimeter in MODFLOW must match those in GFLOW. If not, the MODFLOW grid may 
be too small to let differences in the near-field disappear at the grid boundaries. 
Alternatively, modifications in MODFLOW may have altered the far-field conditions and a 
new GFLOW solution may be necessary to adapt the grid perimeter conditions to these 
modifications. The grid location is determined graphically, after the Create Grid button is 
clicked, by shifting a grid outline on the basemap. 
  
Select the Layers tab to change the top and bottom of each grid layer from its default. 
Remember that MODFLOW numbers layers from top to bottom. Note: Later, when 
Applying GFLOW Results, (see Processing menu.) the GFLOW aquifer bottom elevations 
are assigned to each grid layer, provided the elevation is larger than the bottom elevation 
specified on the Layers tab. To correctly implement all GFLOW bottom elevations, make 
sure that the bottom of the lowest layer is set at or below the lowest bottom elevation in 
GFLOW. Applying GFLOW Results can force bottom elevations above the top of a layer. 
This situation should be avoided by proper choices of top elevations on the Layers tab or 
it should be corrected in the MODFLOW graphical user interface (e.g. Groundwater 
Vistas), for instance by changing such cells into "inactive cells". 
  
Select the Tracking tab to monitor the world and grid coordinates when rolling the mouse 
over the grid. The aquifer properties on the tracking tab will display not available at this 
time, because no GFLOW data has been applied to the grid yet, see the Processing menu. 
   
Click on Open Grid when you want to edit an existing grid. 
Click on Save Grid to save the currently selected grid to its existing name (overwrite with 
changes). 
Click on Save Grid As if you want to save the currently selected grid under a new name 
(make a copy with or without changes). 
Click on Close Grid if you want to start over creating or opening a grid. 
Click on Exit Grid Dialog if you are done creating or editing a grid. 

Edit 
  
Click on Cell Spacing to redefine the grid properties. Move the cursor to a cell and click 
to change the row and column spacing for all cells that share the row and column with 
the selected cell. Note: this will shift all grid lines and thus change the overall grid 
dimensions. It is important to first refine the grid and then select the Processing menu to 
apply the GFLOW boundary conditions and GFLOW aquifer properties. If Cell Spacing is 
changed after processing the GFLOW data the latter procedure must be repeated, by 
again selecting the Processing menu. This is necessary to avoid shifting boundaries when 
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changing grid configurations. 
  
Check MODFLOW Elements to facilitate the inspection of boundary conditions in the 
MODFLOW grid, which is only meaningful after the Processing of GFLOW data has been 
completed. By clicking on a constant head cell, river cell, etc. the type of cell and the data 
applied to the cell are displayed in a message box.  

View 
  
You may select which type of cells should be visible:  
  
Constant Head Cells, when checked, will be blue. 
Well Cells, when checked, will be red. 
River Cells, when checked, will be green. 
Drains, when checked, will be yellow. 

  
Processing 

  
Select the Processing menu to extract data from the GFLOW model and apply it to the 
MODFLOW grid. You should be done editing (refining) the grid before using this menu. 
Also, before executing Apply Analytic Elements you should make sure that line-sinks are 
either entirely inside the grid or entirely outside the grid, see the "Important" note below. 
  
Click Apply Analytic Elements to transfer the boundary conditions in GFLOW to the 
MODFLOW grid. Cells that coincide with line-sinks will be assigned the proper head and 
surface water properties (resistance, width, depth, etc.). In the MODFLOW grid the 
resistance of the line-sink will be converted into a cell conductance. Depending on the 
function of the line-sinks in GFLOW the cells in MODFLOW will become constant head 
cells, river cells or drains. A well will transform the nearest cell into a well cell. 
Inhomogeneities will alter the aquifer properties of the cells that coincide with them. 
Important: Line-sinks should not cross the grid perimeter. Before executing this step you 
should move the nearest vertex in a line-sink string that intersects the grid perimeter to 
that perimeter. This way a line-sink is either entirely inside the grid or entirely outside the 
grid. 
  
Click Extract GFLOW Results to assign heads to the interior MODFLOW grid cells and 
heads or fluxes to the perimeter cells, depending on what was selected on the Grid tab. 
These heads and fluxes, as computed by GFLOW, define the perimeter boundary 
conditions and precondition the MODFLOW model for fast convergence. 
After these choices the aquifer properties on the Tracking tab of the Finite Difference 
Grid dialog box will show the cell by cell properties when rolling the mouse over the grid. 
Important: While the Tracking feature shows a porosity value inside the grid, 
MODFLOW, because of its design, will not read porosity data. Consequently, when using 
MODPATH default porosity values of the MODFLOW/MODPATH graphical user interface 
will be used. The user may have to replace these default values in the 
MODFLOW/MODPATH graphical user interface in order to obtain correct time of travel 
particle traces in MODPATH. 
Note: The grid layer(s) must be given a bottom and a top elevation on the Layers tab. 
Bottom elevations obtained from GFLOW will be implemented in these layers, except 
that the bottom of a layer will not be set lower than the elevation specified on the Layers 
tab. It is important, therefore, to specify the bottom of the lowest layer below or at the 
lowest GFLOW bottom elevation and let GFLOW set the actual elevations. When more 
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than one layer is defined, however, it is possible that the bottom elevation in a layer is set 
above the top elevation of that layer. This may be avoided by a proper selection of Top 
Elevation on the Layers tab or may be corrected in the MODFLOW graphical user 
interface (e.g. Groundwater Vistas) by changing cells with zero thickness into "inactive 
cells". 
  
Complete the procedure by clicking on Make MODFLOW Files on the Processing menu 
of the MODFLOW Extract dialog box. Make sure to select the proper folder and desired 
filename for the set of MODFLOW input files. 
  
You may save the completed grid using the Save option on the File menu of the 
MODFLOW Extract dialog box. 

Leakage from MODFLOW 
  

The Leakage from MODFLOW option allows the creation of a Hybrid GFLOW - MODFLOW 
model whereby leakage rates from an existing MODFLOW model are applied at the bottom 
of the GFLOW model. The idea is to conceptually replace the upper MODFLOW layer or 
layer(s) that are in direct contact with surface water features (streams, lakes, etc.) by a 
single layer GFLOW model. The leakages from the underlying MODFLOW model layers are 
then applied to the bottom of the GFLOW model by defining a MODFLOW grid of leakage 
elements and importing an array of leakage values from the MODFLOW model.  Also 
imported are an array of recharge values that are defined at the top of the upper MODFLOW 
layer and will now be applied to the top of the GFLOW aquifer. To ensure that the recharge 
in the GFLOW model is fully compatible with the recharge of the original MODFLOW model 
no other recharge should be defined in GFLOW by use of its Inhomogeneity domains. 
Details on the use of this feature are found in Help>PDF Help Files>Hybrid GFLOW - 
MODFLOW model.pdf.  
  
To create a leakage grid in GFLOW for the Hybrid GFLOW - MODFLOW feature click on 
Grid on the menu bar and then click on Leakage from MODFLOW>Show Grid Dialog. There 
are two tabs on the Leakage from MODFLOW dialog: 
General 
Tracking 

General Tab 
  
First go to the File menu on the Leakage from MODFLOW dialog and click on Open Grid. If you 
created a basename.del file that defines the grid it will show in the Open MODFLOW Grid 
dialog window. The "basename" is the Base Filename (DOS) defined on the Project>Project 
Settings dialog. The proper format for the basename.del file is illustrated below: 

7         <number of rows> 
5714   <height of row 1> 
5714   <height of row 2> 
5714 
5714 
5714 
5714 
5714 
8        <number of columns> 
5000  <width of column 1> 
5000  <width of column 2> 
5000 
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5000 
5000 
5000 
5000 
5000 
2203883    <lower left x-world coordinate of grid> 
15584505  <lower left y-world coordinate of grid> 
  
The last two lines in the example basename.del file are optional, but when provided must be 
in the same coordinate system as used in the GFLOW model. If these lines are not present 
the grid must be georeferenced on the General tab by typing in the coordinates in the two 
data boxes and then click Update or by clicking select and the placing the + sign at the 
location where the lower-left corner of the grid must be and left-click. The latter procedure is 
OK for testing or demonstrations, but will not lead to an accurate correspondence between 
the grid locations in the MODFLOW and GFLOW models, of course. 
When the basename.del file is being read by the GUI the leakage file basename.vlk will also 
be read. This is an ASCII file with rows of (real) numbers corresponding to the rows of 
MODFLOW cells representing the leakage values in these cells. Also present must be the 
recharge file basename.rta with cell-by-cell recharge values at the top of the aquifer.  This 
file will not be read by the GUI, but will later be read by the Solver when creating a solution.  

Tracking Tab 
  
The Tracking tab allows the inspection of data related to the imported MODFLOW grid. In 
addition to the world coordinates of the position of the cursor its grid coordinates (relative to the 
lower-left corner of the grid) are also given. The cell-by-cell leakage values are given at the 
bottom of the table on the Tracking tab. Note that the recharge rate is not given. The recharge 
values are imported only into the Solver and will be available on the Model Results data box 
after a solution has been obtained. To see these data, place the cursor at the point in the model 
domain where you seek information and perform a Shift Left-Click.    
Tools Menu 
  
GUI Options  
Import  
Export  
GFLOW Database Viewer  
Instant Inspector Settings..  
Search  
Solver Integrity Check  
PEST  
  
The Tools menu provides access to GUI options, a utility program to convert various map files 
to base map (.bbm) files,  import functions for text labels, wells and test points, export functions 
to DXF, SURFER format files and GFLOW input files, a viewer for the GFLOW database,  the 
base map browser, and settings for the instant inspector feature. The Solver Integrity Check 
offers a check on the computational integrity of the solver, but this is not necessary as a routine 
procedure. 
Finally, the PEST option brings up a control panel from which to setup and run parameter 
estimation runs. 
GUI Options 

  
This menu allows the user to change default GUI settings regarding the line type and 
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color of  contour lines and Path lines. 
Note: The line type option is only available for the smallest line width (1) due to a 
limitation of the graphics library used in VB6. For line width values larger than 1 the line 
type will default to a solid line. 
  
The user may add a shadow to line-sinks. This may make line-sinks more easily visible 
when plotted on a raster graphics base map. The proper setting for the Linesink Shadow 
Width (number larger than 0) is depends on the base map and is best found through trial 
and error. 
  
The user can also set the Base Map Haze Level for the base map hazing feature (see 
View menu). The proper setting depeds on the base map used and is best found though 
trial and error. 
  
The option to Suppress Coordinate Translation is useful when performing conceptual 
modeling in a local coordinate system. When checked, the GUI and Solver use the exact 
same origin, hence the Solver reports the same coordinates as the GUI. Note: For 
regular modesl with base maps in UTM or State Plane coordinates this option leads to 
inaccurate spatial calculations in the Solver, because small distances in the field are 
obtained by subtracting very large numbers in the world coordinate system. This is why 
GFLOW uses a local coordinate system in the Solver with its origin at the lower left 
corner of the window in the GUI at the time of clicking the calculator icon or selecting 
Solve from the Model menu.  

Import 
  
To import a file containing text labels select Import.. from the Tools menu and then Text Label 
File...  The file must be an ASCII text file (filename.TX) in which each line has the following 
format: 
                      x,   y,   h,   label 
where x and y are the (basemap) coordinates of the lower left corner of the text, where h=1 for 
hydrography labels (water levels in surface waters) and h=0 for any other text label. The label 
is the water level or text to be printed on the map. The text labels will be added to the current 
project database file. 
  
  
To import a file containing discharge specified wells select Import.. from the Tools menu and 
then Discharge Specified Wells FileÖ  The file must be an ASCII text file (filename.WL) in which 
each line has the format: 
                      x,   y,   Q,   r,   label, top, bottom 
where x and y are the (base map) coordinates of the well, Q its pumping rate, r its radius, label 
a well identifier (combination of numbers and letters), top the elevation of the top of the well 
screen, and bottom the elevataion of the bottom of the well screen. These last two items (top 
and bottom) are optional. If not present the screen will be set from the local aquifer bottom to 
the aquifer top. Make sure that the label does not contain spaces or commas or unpredictable 
results will occur upon import of the file.  Note: The screen top and bottom elevations are only 
relevant if a 3D well function is used (default is 2D) or if the wells are exported as part of the 
MODFLOW extract feature. In the latter case the screen setting will determine in which 
MODFLOW layer or layers the well will occur. 
The wells will be added to the current project database file. 
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To import a file containing head specified wells select Import.. from the Tools menu and then 
Head Specified Wells FileÖ  The file must be an ASCII text file (filename.WL) in which each line 
has the format: 
                      x,   y,   h,   r,   label, top, bottom 
where x and y are the (base map) coordinates of the well, h is the specified head in the well 
bore, r its radius, label a well identifier (combination of numbers and letters), top the elevation 
of the top of the well screen, and bottom the elevataion of the bottom of the well screen. These 
last two items (top and bottom) are optional. If not present the screen will be set from the local 
aquifer bottom to the aquifer top. Make sure that the label does not contain spaces or commas 
or unpredictable results will occur upon import of the file.  Note: The screen top and bottom 
elevations are only relevant if a 3D well function is used (default is 2D) or if the wells are 
exported as part of the MODFLOW extract feature. In the latter case the screen setting will 
determine in which MODFLOW layer or layers the well will occur. 
The wells will be added to the current project database file. 
  
  
To import a file containing test points select Import.. from the Tools menu and then Test Point 
FileÖ  The file must be an ASCII text file (filename.TP) in which each line has the format: 
                        x,  y,  h, Q,  type, label  
where x and y are the (base map) coordinates of the test point, h the head, Q the stream flow, 
type is piezometer,  gage or Lake stage, and label a test point identifier (combination of 
numbers and letters). Labels should not contain spaces or commas, because they are 
delimeters in this and other files. The test points will be added to the current project database 
file. A brief example file follows: 

4.521700E+05 ,4.280888E+06 ,4.02E+02 ,0.0E+00 ,Piezometer , MW47 
4.516220E+05 ,4.280488E+06 ,4.01E+02 ,0.0E+00 ,Piezometer , MW48 
4.522530E+05 ,4.280245E+06 ,4.01E+02 ,0.0E+00 ,Piezometer , MW49 
4.525650E+05 ,4.280350E+06 ,4.01E+02 ,0.0E+00 ,Piezometer , MW50 
4.523140E+05 ,4.280059E+06 ,4.02E+02 ,0.0E+00 ,Piezometer , MW51 
4.532790E+05 ,4.280306E+06 ,4.00E+02 ,0.0E+00 ,Lakestage , lake_1 
4.466018E+05 ,4.271959E+06 ,0.00E+00 ,5.0000E+04 ,Gage , city_ditch 

  
  
To import a GFLOW input file created for the previous DOS version of GFLOW select 
Tools>Import>GFLOW for DOS fileÖ  The filename.dat file, however, must have been created 
by the GAEP program or by the DATA command in the DOS version of GFLOW in order to 
ensure error free data transfer.  
    Note 1: Before importing a .DAT file created by the DOS version of GFLOW you must set up 
a new project. To do so, close any current project, click on New Database, specify a new 
project filename and click Open. On the next dialog box enter a project description and select 
the proper units. This is an important step! If the basemaps you will be using are in UTM 
coordinates, select meters for Distance units in Basemap Files. Hence, it is not important if the 
units in the GFLOW .dat file to be imported are feet or meters; the Distance units in Basemap 
Files depend only on the units associated with the basemaps that you import! Next, make sure 
that the Units for Computations are set to the units used in the .DAT file you will import. Click 
OK and add the appropriate basemaps to the project file (next dialog box). After the basemaps 
are displayed on the screen you are ready to go to the Tools menu to import the .DAT file from 
the old GFLOW for DOS version. 
   Note 2: GFLOW does not support 2-D or 3-D sink discs. Consequently, these features in the 
old .dat file will be ignored during the import procedure. However, you will get a warning for 
each sink disc it finds (and skips). You are responsible for replacing these features by line-sink 
strings when they represented lakes and by recharge inhomogeneities when they represent 
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recharge elements. Refer to your original model (graphics) printout and data to make these 
modifications in GFLOW after the .dat file has been imported. 
  
To import a previously created solution select Tools>Import>Previous Solution FileÖ  Select 
the filename.sol file that belongs to the current project file. This means that the filename must 
be the same as the Base Filename specified on the Project Settings.. dialog (see 
Project>Project Settings). This action is often useful when opening an existing project file for 
which a solution has been generated previously. 
   Important: To be sure that you import the proper solution it is important that you select a 
unique Base Filename on the Project Settings.. dialog for each project file that you create (or 
duplicate). The GUI will create such a unique name by default, but it is non-descriptive. 
  
  
To import a HUC file select Tools>Import>Hydrologic Unit. HUC files have the extension .huc 
and contain a list of nearfield HUCs, farfield HUCs and Inhomogeneities that form a model for a 
sub-domain of a larger model area. Refer to "Managing HUCs in GFLOW" stored as Managing 
HUCs.pdf in the document folder. You can access this document from the Help menu. 
  
  
To import a Line-sink string file select Tools>Import>Line-sink Strings. Line-sink string files 
have the extension .lss.xml and contain line-sink string data to be imported in an existing project 
file. These data files may have been created by using the Tools>Export>Line-sink String option 
or by any other code designed to produce line-sink strings for import in GFLOW. The format of 
the *.lss.xml files is documented in the "import-export.lss.xml.pdf" file in the "import-export" 
subfolder of the folder "GFLOW projects" on the C-drive. It may also be accessed via Help>PDF 
Help Files. This file is an annotated version of "import-export.lss.xml" that is produced by 
executing a Tools>Export>Line-sink Strings command from the project "sampling.gfl." 
  
  
To import an Inhomogeneities file select Tools>Import>Inhomogeneities. Inhomogeneities 
files have the extension .inh.xml and contain inhomogeneities data to be imported in an existing 
project file. These data files may have been created by using the 
Tools>Export>Inhomogeneities option or by any other code designed to produce 
Inhomogeneities for import in GFLOW. The format of the *.inh.xml files is documented in the 
"import-export.inh.xml.pdf" file in the "import-export" subfolder of the folder "GFLOW projects" 
on the C-drive. It may also be accessed via Help>PDF Help Files. This file is an annotated 
version of "import-export.inh.xml" that is produced by executing a 
Tools>Export>Inhomogeneities command from the project "sampling.gfl." 
  
  
To import a Horizontal Barriers file select Tools>Import>Horizontal Barriers. Horizontal 
Barriers files have the extension .brr.xml and contain Horizontal Barriers data to be imported in 
an existing project file. These data files may have been created by using the 
Tools>Export>Horizontal Barriers option or by any other code designed to produce Horizontal 
Barriers for import in GFLOW. The format of the *.brr.xml files is documented in the "import-
export.brr.xml.pdf" file in the "import-export" subfolder of the folder "GFLOW projects" on the C-
drive. It may also be accessed via Help>PDF Help Files. This file is an annotated version of 
"import-export.brr.xml" that is produced by executing a Tools>Export>Horizontal Barrier 
command from the project "sampling.gfl." 
  
Export 
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To export model data to DXF files point to Export on the Tools menu and click on DXF... Select 
Contour lines, Particle paths, Wellhead Protection Areas or Elements to be exported.  For DXF 
export, a layer name must be provided; either use the default name or type in the name you 
wish to use (e.g. 2YR-TOT for 2-year time-of-travel path lines).  Once written, the DXF file may 
be imported into Autocadô  or any other DXF-compatible program. The coordinates in the DXF 
file will be the same as the base map coordinates in your model 
  
To export model data to BLN files (for SURFER) point to Export on the Tools menu and click on 
SURFERBLN... Select Contour lines, Particle paths, Wellhead Protection Areas or Elements to 
be exported.  The resulting files may be used as XYLine entries in the SURFER contouring 
program or any other program that uses BLN files. The coordinates in the BLN file will be the 
same as the base map coordinates in your model.  
  
To export gridded data to .GRD files (for SURFER) point to Export and click on SURFERGrid... 
Select Head, Velocity in X direction, Velocity in Y direction, or Total Discharge as data for the 
grid.  The output file will be a SURFER-compatible ASCII GRD file, appropriate for importation 
into many other contouring programs. The coordinates in the GRD file will be the same as the 
base map coordinates in your model. Warning: The solver also produces GRD files, which are 
in local model coordinates used by the solver. These files have the Base Filename as set on the 
Project Settings dialog box (see File menu) and the extension GRD. These files are to be used 
by the GUI only, specify different filenames (or use a different folder) for the GRD files to be 
used in SURFER. 
  
To export model data to Shape files point to Export and click on Shapefile. Select the entity to 
be exported (e.g. contours) and specify a filename on the file dialog menu. 
  
To export Hydrologic Unit domains first select a HUC domain boundary, next point to 
Tools>Export and click on Hydrologic Unit. Specify a filename and save. HUC domains are 
exported for future modeling use, see Managing HUCs.pdf in the document folder. 
  
To export an Inhomogeneity domain first select the inhomogeneity, next point to Tools>Export 
and click on Inhomogeneity. Specify a filename and save. Inhomogeneity domains are exported 
for future modeling use, see Managing HUCs.pdf in the document folder. 
  
To export a file with all Discharge Specified Wells  that can be imported in another GFLOW 
model point to Export and click on Discharge Specified Wells... The coordinates, radii, pumping 
rates, labels, and screen settings of all discharge specified wells in the model will be written to a 
FILENAME.WL file in a format as explained under the Import option. 
  
To export a file with all Head Specified Wells  that can be imported in another GFLOW model 
point to Export and click on Head Specified Wells... The coordinates, radii, specified heads, 
labels, and screen settings of all head specified wells in the model will be written to a 
FILENAME.WL file in a format as explained under the Import option. 
  
To export a file with Test Point data that can be imported in another GFLOW model point to 
Export and click on Test Points... The coordinates, heads, stream flows, and labels of all Test 
Points in the model will be written to a FILENAME.TP file in a format as explained under the 
Import option. 
  
To export a file with Hydrography Labels that can be imported in another GFLOW model point 
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to Export and click on Labels.. The coordinates, a hydrography label code (=1) and the head 
will be written to a FILENAME.TX file in a format as explained under the Import option. 
  
To export a Line-sink string file select Tools>Export>Line-sink Strings. Line-sink string files 
have the extension .lss.xml and contain line-sink string data to be imported in an existing project 
file. See "To import a line-sink string file" under Tools>Import for more details.  
To export a Inhomogeneities file select Tools>Export>Inhomogeneities. Inhomogeneities files 
have the extension .inh.xml and contain Inhomogeneities data to be imported in an existing 
project file. See "To import a Inhomogeneities file" under Tools>Import for more details.  
To export a Horizontal Barriers file select Tools>Export>Horizontal Barriers. Horizontal Barriers 
files have the extension .brr.xml and contain Horizontal Barriers data to be imported in an 
existing project file. See "To import a Horizontal Barriers file" under Tools>Import for more 
details.   
GFLOW Database Viewer 

  
The GFLOW Database Viewer on the Tools menu provides access to the database used by the 
GFLOW graphical user interface.  
Modifications of database fields are possible after selecting Options>Allow Modifications. This 
feature is for advanced users only!  
  
For routine access to details on the GFLOW model the user is referred to the GFLOW Results 
Table on the Model menu. 
Search 
  
With the Search feature you can find elements in the model based on search criteria, which are 
then highlighted on the graphics screen. 
  

 
  
The Search From field defines a group of elements from which you want to select elements with 
a specific property.  
  
The Search For field defines the property that forms the search criterion.  
  
The next fields allow you to select particular values for the search criterion. 
For instance, in the example shown above, the element group is all linesink strings with the 
search criterion set to "Starting Head" with values between 401 and 438. 
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Once you have specified your search parameters as described above, press the "Search" 
button to let GFLOW find all matches corresponding to your query. The label of each element 
that is found will be displayed in the bottom left data box, along with the number of matches.  
  
By default the search feature will highlight on screen all elements that match your search. You 
may uncheck the "Highlight All Matches" checkbox to prevent this. You may also click on each 
match in the list box to highlight or unhighlight elements individually. 
  
The "Refresh and Clear Highlighting" button will clear all the elements highlighted by the search 
feature and refresh the screen. If you run a new search, the highlighting from the previous 
search will also be cleared.  
  
Note 1: The various Linesink Strings fields in the "Search From" box are different from the 
Linesinks field. The Linesinks field refers to individual linesinks with properties that are only 
available when a solution is present. The Linesink Strings fields refer to whole linesink strings 
with properties that are mostly available without a solution present. Therefore Linesinks is only 
available as an option when a solution is present while Linesink Strings is always an available 
option. 
  
Note 2:  When performing a search with a text string in the "Search For" box, for instance, a 
label or GFLOW label, the search will automatically use wildcard characters to find all strings 
that include the string you specified. You may also insert your own wildcard characters by 
adding a ? for a single wildcard character or a * for multiple wildcard characters. 
Instant Inspector Settings 
  
The GFLOW graphical user interface offers instant inspection of input and output data at any 
point in the model domain. To use this feature simply point with the cursor at the desired 
location, hold down the Shift key and left-click the mouse. Within seconds a dialog box appears 
with both input and output data pertaining to that point, e.g. hydraulic conductivity, bottom 
elevation, recharge, head, velocity, etc. The elevation for which these data are provided is 
defined under the Instant Inspector SettingsÖ  option on the Tools menu. To obtain data at the 
top of the saturated aquifer thickness, select the box "Inspect at top of saturated thickness". 
This would be the water table in an unconfined aquifer and the aquifer top in a confined aquifer. 
To select a different elevation, deselect that box and specify the elevation in the input box 
labeled "Inspection Elevation". 
The GFLOW graphical user interface also supports an instant path line trace option. Instead of 
defining a new particle and recreating a contour plot and retracing all existing path lines, you 
may point at the desired starting point of a new trace, hold down Ctrl-Shift and left-click the 
mouse. Within seconds a trace appears. The starting elevation of the trace is set via the  Instant 
Inspector Settings..  option on the Tools menu and the direction of the trace is set under that 
same option. The default is forward in time, but by checking the box in front of Trace Backward 
in time on the Instant Inspector Settings.. dialog box, the trace occurs backward in time. 
Solver Integrity Check 

  
Check this option to bring the Instant Inspector feature in the "solver integrity checking mode". 
Bring the cursor to the desired location on the base map and do a shift-click. In addition to the 
normal Model Results data panel with computational results, a second panel is displayed as 
shown below. 
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 The divergence of the specific discharge vector in a Dupuit-Forchheimer model 

The 
value 
of 
the 
average 
groundwater 
velocity 
vector 
components 
as 
produced 
by 
the 
analytic 
functions 
in 
GFLOW 
are 
compared 
to 
a 
finite 
difference 
approximation. 
The 
spatial 
step 
size 
for 
these 
numerical 
calculations 
are 
set 
on 
the 
Tools>Instant 
Inspector 
Settings 
dialog. 
The 
default 
value 
is 
one 
unit, 
which 
may 
be 
1 
foot 
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 The divergence of the specific discharge vector in a Dupuit-Forchheimer model 
is always zero. The numerical value, calculated from a finite difference approximation of the 
analytic specific discharge in GFLOW should be very small. 
The divergence of the discharge vector (specific discharge integrated over the saturated aquifer 
thickness) should be equal to the local recharge rate. The analytical value is the local recharge 
rate and the numerical value, obtained from a finite difference approximation, should be very 
close. The values shown in the figure above are considered satisfactory. 
  
Uncheck Tools>Solver Integrity Check to leave this mode. 
PEST 
  
Set up and execute a PEST parameter optimization session.  
  
Make sure that the current GFLOW model has the appropriate symbolic names defined for the 
parameters that are to be included in the optimization. These symbolic names are entered on 
the Scenarios tab sheets of the Properties dialogs for line-sinks (see also note 2 below) and 
inhomogeneities and the Model>Settings dialog.  
Note: Symbolic names should not be longer than 12 characters and not contain spaces or any 
of the following characters: , - _ 
  
  
Also ensure that the proper Test Points have been defined to be used as calibration targets. 
There are three Test Point groups: Piezometers, Gages, and Lakestages. Piezometers define 
observed heads in the model domain. Stream gages define observed stream flows in the 
nearest line-sink. That line-sink must be part of a stream network, and the Solver option 
Conjunctive Surface Water - Groundwater Solution must be checked (see 
Model>Settings>Solver tab). Lake stages must be placed close to a line-sink that is part of a 
boundary of a lake (the Lake option must be checked on the Linesink String Properties dialog). 
Lake stages define the observed lake stage of a lake feature for which the lake stage is being 
solved for.  
Note: Symbolic names should not be longer than 12 characters and not contain spaces or any 
of the following characters: , - _ 
  
To conduct a parameter optimization session proceed as follows: 
  

If PEST input and output files exist from a previous run make sure to back them up if they 
need to be referred to again. Next, click Delete all PEST Related Files. 

or 
1 
meter, 
depending 
on 
the 
computational 
units 
set 
on 
the 
Project>Project 
Settings 
dialog. 
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Click Assign Weights to modify the default weights for the individual observations (Test 
Points in GFLOW). These weights will be written to the relevant PEST input file. 

Click Write PEST Input Files. These files are written by the GFLOW GUI based on the 
Symbolic names and Test Points defined for the project. 

Edit the "basename.pst" file to set up the desired PEST simulation. Note: the file written by 
the GUI has default settings that may need to be changed. For information on necessary 
and proper parameter settings in the "basename.pst" file consult the PEST manual by 
clicking on the View Pest Manual button. 

Click Run PESTCHEK to check for errors in the View window. Correct any errors. 
Click Run PEST. The PEST executable will be scheduled by the GFLOW GUI and run in a 

DOS box. Upon completion of the run you will see a number of PEST output files listed in 
the PEST Output Files window. You can double click on any of these files to view them. 

When clicking the Import Optimized Parameters button, the optimized parameters reported 
in the basename.par file will be read by the GUI and assigned to the Current values on 
the Model>Implement Scenarios dialog. From the Model>Implement Scenario dialog you 
can perform a test run, using these optimized parameters, and/or make them the default 
parameters for the project.  
  

Note 1: GFLOW writes all PEST input files with the "basename" set on the Project>Project 
Settings dialog as the Base Filename (DOS) and writes these files in the current working 
directory. It is recommended that you keep these filenames.  
  
Note 2:  Line-sink strings for which symbolic names are used to redefine the resistance during 
PEST runs must have either the radio button for "Along surface water boundary" or for "Along 
stream center line" selected on the Linesink String Properties dialog. The option "Unkown" 
should not be used! This will allow the Solver to recalculate the "effective leakage zones" under 
changing resistance and transmissivity scenarios. 
Window 
  
The Window menu facilitates the selection of the model area to be displayed in the graphics 
box.  
  
Each click on Zoom In enlarges the map by 30% keeping the center of the map in the center of 
the graphics box.  
  
Each click on Zoom Out reduces the map by 30% keeping the center of the map in the center of 
the graphics box. 
  
To display the full map in the graphics box click on Zoom Extents. 
  
To display a particular section of the map, click on Zoom to Window. Move the cursor to the 
upper left corner of the domain to be plotted, keep the left mouse button depressed and move 
the cursor to the lower right corner of the domain to be plotted. A box will appear to show the 
area selected for plotting. When releasing the mouse button the selected area will be plotted in 
the graphics box. 
  
Click on Refresh to redraw the map. This may be desirable, for instance, after editing has left 
openings in the base map. 
  
Click on Save Current Window to store the current window coordinates in the database under a 
user specified name. You will be prompted for the name when selecting this option. 
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Click on Saved Windows to retrieve a previously stored window. You may browse through the 
saved windows and their coordinates and select the one you want implemented. You may also 
change the coordinates of the lower left and upper right hand corner of the window.  
Help 
  
There are three groups of links on the Help menu: 
  
The first group contains three links to access the GFLOW Help system (manual): 

GFLOW Manual opens the Table of Contents 
Modleing with GFLOW offers a quick start for setting up a GFLOW project. 
GFLOW Tutorial offers a step-by-step guide to modeling with GFLOW.  
  
PDF Help Files provides access to a collection of monographs aoffering background 
information on various topics relevant to modeling with GFLOW 

  
The second group contains some background information on GFLOW's history: 

GFLOW Release Notes  offers some details related to installation and specifics related to 
this vesrion of GFLOW.  
About GFLOW...   is the opening splash screen with bersion information and authors of 
GFLOW. 
  

The last item if the Register GFLOW option, which will be greyed out once the program is 
registered as a professional version. Note: Once you register the program with a username and 
unlock key (obtained after purchasing GFLOW online at www.haitjema.com each successive 
upgrade will remain registered. 

  
Finally, when hoevring the cursor over an icon on the Tool bar a brief explanation of that icon 
will appear momentarily. When inside a menu, you may press F1 to obtain context sensitive 
help. For more detailed explanations, click on Help and refer to the table of Contents or Index 
after clicking on GFLOW Manual..  
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