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Overview of main GFLOW features 
 
The GFLOW GUI contains many tools to efficiently design and manage a groundwater 
flow model. The most prominent are listed below. Note: The documents referenced are in 
the folder Documents and Setting/<user>/Application Data/GFLOW and accessible from 
the Help>PDF Help Files menu in GFLOW. These documents may also be accessed on 
the website http://www.haitjema.com 
 

1. Background maps (base maps) include several different vector and raster graphics 
file formats (in addition to the EPA supplied BBM format). 

2. The solution process is optimized for speed and stability and provided with 
convergence criteria. Details are found in “Fast solution method in GFLOW.pdf” 
and “Solution strategies in GFLOW.pdf.” 

3. An effective line-sink width parameter is automatically calculated by the Solver 
to accurately represent the bottom resistance to flow into or out of the streams and 
lakes. 

4. Several model calibration tools are available. These include three types of Test 
Points (piezometers, stream gages, and lake stages), a Scenario feature to perform 
calibration and sensitivity runs, and integration of automatic parameter 
optimization using PEST or UCODE. Details on PEST and UCODE are found in 
“Manual for PEST.pdf” and “Manual for UCODE.pdf.” 

5. Inhomogeneity domains, redefining hydraulic conductivity, porosity, aquifer 
bottom, and recharge. These domains can have shared boundary sections. Details 
are found in “Theory of modeling inhomogeneity domains in GFLOW.pdf.” 

6. Horizontal Barriers are open or closed boundaries that offer resistance to flow or 
completely block flow. Details are found in “Horizontal Barriers in GFLOW.pdf” 
and “Using the stream function for Poisson flow.pdf.” 

7. Large models may be broken up in several smaller models based on USGS 
defined Hydrologic Units. These models are efficiently managed from the GUI. 
Details are found in “Managing Hydrologic Units in GFLOW.pdf.” 

8. A right-click on a selected analytic element will provide element specific 
modeling results. 

9. There is a database search feature that lets you quickly locate a specific analytic 
element or a group of analytic elements with a shared attribute. 

10. The contouring option includes contours of heads, potentials, stream function, 
absolute value of the discharge, and drawdowns. 

11. There is a GUI options dialog to customize certain GUI defaults. 
12. Particle tracking (forward and backward in time) can be done from individual 

points, a ring of points around a well at a given elevation (backtracking only), and 
from grids of particles. 

13. A special lake feature facilitates solving for the lake stage based on lake water 
balance, rather then setting the lake stage based on observations. Details are found 
in “Lake – Groundwater interactions in GFLOW.pdf.” 



14. GFLOW facilitates the modeling of (sharp) interface flow between, e.g. fresh and 
salt water in coastal aquifers. Details are found in “Freshwater and salt water 
interface flow in GFLOW.pdf.” 

15. GFLOW supports the modeling of local fully three-dimensional flow near 
partially penetrating wells.  

16. GFLOW supports the modeling of transient flow near wells, including cyclic 
pumping. 

17. GFLOW may be used to model the production and regional drawdowns of 
horizontal wells. Details are found in “Horizontal wells in GFLOW.pdf.” 

18. GFLOW may be used to model 2D flow in the vertical plane. Details are found in 
“Modeling flow in the vertical plane with GFLOW.pdf” and “Truncating cross-
sectional models under wetlands.pdf.” 

19. A MODFLOW Extract feature allows for a MODFLOW model to be be extracted 
from a GFLOW model to perform modeling activities not supported in GFLOW, 
such as multi-layer flow and transient flow. In fact, GFLOW may be used as an 
efficient MODFLOW preprocessor by serving as a screening model from which 
then a final MODFLOW model is obtained. 

 
What is new in version 2.2.2? 

 
1. Support for Hybrid GFLOW-MODFLOW modeling. The upper layer(s) in a 

regional MODFLOW model may be duplicated in GFLOW for high-
resolution well-stream interactions that are not possible in the (coarse) 
MODFLOW model. Details are found in “Hybrid GFLOW-MODFLOW 
Modeling.pdf.” Further reading: “Hybrid FD-AE model.pdf” and “Field test 
hybrid GFLOW-MODFLOW model.pdf.” 

2. Import and Export of analytic elements. Line-sink strings, inhomogeneity 
domains, and horizontal barriers may be exported and imported in “xml” 
format. This feature allows these analytic elements to be created in a GIS 
system and then imported into GFLOW. Alternatively, this feature allows 
analytic elements to be transferred between GFLOW models. 

3. A new HTML Help system. The old Windows Help system is no longer 
supported on Windows 8 and above. The new system is fully context sensitive 
and an improved version of the older Window Help. 

 
Possible message when opening an example project file 
When loading a project file from one of the /Users/<username>/my documents/GFLOW 
projects subfolders provided with the program you may encounter the following 
message: 

 



Simply click Yes to correct this misalignment of file paths.  This message is the result of 
the project files in these folders having been opened on another drive (during testing). 
 
 
A more detailed description of the features listed above follows. 
 

Background maps 

 
Figure 1. Various types of vector and raster graphics files are supported. 
 
In addition to the EPA supplied BBM vector file format (which contain USGS DLG 
maps) GFLOW supports several different vector and raster graphics files. In Fig. 1. one 
BBM file, two Shapefiles, two DXF files, and one TIF file are shown. Several more file 
formats are supported, as seen by clicking on All Supported Types on the Select Basemap 
File dialog (which opens when clicking Add Map on the Project Settings dialog, see Fig. 
1.) Note: The list of types is cut off in Fig. 2 after the first two entries. 



 
Figure 2. Click on All Supported Types to get a complete list of files that can be used as 
base maps in GFLOW. Note: list in the figure is cut off after the first two entries. 
 
Vector and raster graphics maps added to the Project Settings may be selected for display 
on the View menu (View>Base Map), see Fig. 3. There are three base map management 
options: Vector Graphics, Raster Graphics and Select BBM Group. The first two options 
open a file window in which individual maps (files) can be selected or deselected for 
display. The Vector Graphics window also offers an editing option for Shapefiles, as they 
contain non-standard attributes. The editing option allows the Shapefile maps to be 
colored (in case color information is not in the Shapefile) and attributes displayed as text 
labels. The Select BBM Group overlays the graphics screen with boxes each of which 
contains a group of BBM files (each file is an overlay of roads, hydrography, etc. inside 
that box). You can click in a box and select or deselect some or all of the files for display. 
 
 
 



 
Figure 3. Base map management tools on the View menu. 



 

Solution process 
There are several options for the solution process, the most important ones are described 
below. 
 

 
Fig. 4. The Solver tab of Model>Settings 
 
Solution control files 
The Solver will attempt to read two solution control files in addition to the instructions 
provided in the main input file “basename.dat”. These files are: converge.tab and 
relax.tab. If these files are not found, default values will be used. 
 



 
Fig.5. The editing window for the file converge.tab, which opens upon clicking 
Advanced behind Number of iterations (inner loop). 
 
The first file, converge.tab, contains a table with solution convergence criteria, one for 
each analytic element type. The default (no file in working directory) is that the specified 
number of iterations is used. The file can be created (edited from a default file) by 
clicking the Advanced button after the number of iterations option on the 
Model>Settings>Solver tab (see Fig. 4) and saved to disk using the Save button. I 
recommend that you use this option. When defining these convergence criteria, the 
meaning of the number of iterations on the Model>Settings>Solver becomes that of the 
maximum number of iterations. The “minimum iterations 4” line in the example file (Fig. 
5) stipulates that, even if the convergence criteria are met, the inner loop must contain at 
least 4 groundwater flow solutions.  In general, when using proper convergence criteria, 
the solution process will be faster and the solution will be more reliable.  
Warning: These criteria only apply to the groundwater flow solution, the surface water 
solution is not being monitored. In most cases, however, the groundwater flow solution 
will only converge if the surface water solution has already converged to a reasonable 
degree.  
Note: The use of these convergence criteria is of particular importance when conducting 
parameter optimization with UCODE or PEST. 
 
 



 
Fig. 6. The editing window for the file relax.tab, which opens upon clicking Advanced 
behind Conjunctive Surface Water – Groundwater Solution on the Solver tab. 
 
The second file, relax.tab, contains a table with under-relaxation factors for the surface 
water solution process. The default (no file in working directory) is that the relaxation 
factor is 1 (no under-relaxation) for all iterations. An under-relaxation factor as low as 0.5 
may be needed to obtain convergence on large complex stream networks. You may start 
with a low value, say 0.5, and after 5 or more iterations increase the factor to, for 
instance, 0.75. For many difficult to solve stream networks, the relaxation factor should 
be kept well below 1 (e.g. 0.75) for all iterations. The use of an under-relaxation factor 
will increase the number of iterations required for convergence. It will also leave small 
residual errors in the stream flow solution, but they tend to become insignificant (small 
compared to the average stream flow).  
Note: Always try a factor 1 first for all iterations. Only if you observe that the surface 
water solution does not converge (cyclic patterns of smaller errors followed by larger 
errors, etc.) should you experiment with under-relaxation. 
 
Outer loop for lake stage calculations   
The option Apply outside loop iterations. Number of iterations on the Solver tab (Fig. 4) 
should be selected only when line-sink lake features are present, see the document “Lake 
– groundwater interactions in GFLOW.pdf” accessible from the GFLOW>Help>PDF 
Help Files menu. 
Briefly, the lake stage for these lakes is calculated iteratively by use of a lake water 
balance. This requires conjunctive surface water – groundwater solutions to be calculated 
for different lake stages, thus the “outside loop” iterations. As a minimum I recommend 5 
outside loops, but it is best to specify a lake water balance criterion on the converge.tab 
file (last criterion in Fig. 5) and specify a large number of outside loop iterations on the 
Solver tab (Figure 4), say 20.  



Note: Line-sink type lake features are defined by use of the Lake radio button on the 
Linesink String Properties dialog, see Fig. 7. 
 
Speeding up groundwater solutions  (professional version only) 
The option Store decomposed matrix on disk for faster solve on the Solver tab (Fig. 4) 
may be checked to implement a numerical “trick” that speeds up the groundwater flow 
solution, see Using the Sherman-Morrison Formula section in the document “Solution 
strategies in GFLOW.pdf”. In some cases of a difficult to solve problem, the groundwater 
solution may not converge when this option is selected. I recommend that you always try 
this option, but if you have persistent convergence problems, try a run with that option 
deselected. 
 
 
 

Line-sink width parameter 

 
Figure 7. Linesink String Properties dialog 
 
The paradigm of the Resistance, Width, and Depth parameters are described in the 
document “Dealing with resistance to flow into surface waters.pdf.” Briefly, the Width 
parameter must be set equal to some effective inflow zone in order for the correct amount 



of flow into or out of the surface water feature (stream or lake) to be calculated by the 
Solver. The Solver can automatically calculate the effective Width parameter. 
To invoke this feature, you must select the proper line-sink configuration in the box 
Linesink Location (see Fig. 7). When set to Unknown, the user must provide the correct 
Width parameter. When set to Along stream centerline (line-sink string along centerline 
of relatively small stream), or Along surface water boundary (double line-sink string, one 
on each side of a wide stream, or line-sink string along a lake boundary), the actual 
surface water width must be entered as the Width parameter (the parameter B in the above 
mentioned document). The Solver will automatically calculate the correct effective Width 
parameter, which will be reported back to the GUI as the width of the line-sink in the 
Model Results table (on Model menu). The Width parameter on the Linesink String 
Properties dialog will remain set to the actual surface water width. 
 
Note: When using parameter optimization with PEST, you must use the automatically 
calculated Width parameter to obtain valid results. Hence, you should not select the Line-
sink Location as Unknown. 
 
 

Model calibration tools 
 
The GFLOW graphical user interface (GUI) supports either manual or automatic 
calibration. To this end GFLOW supports three types of Test Points (calibration targets), 
the use of symbolic names for model parameters, a scenario implementation feature, 
detailed calibration statistics, and a management facility for running the PEST and 
UCODE parameter optimization codes. In fact, both PEST and UCODE executables and 
manuals are supplied with GFLOW and the parameterization of these codes is managed 
from within the GUI. 
 
 Test points 

 
Figure 8. Three different types of Test Points.  
 
GFLOW supports three different types of Test Points: Piezometer, Gage, and Lake Stage. 
Piezometers are Test Points where observed heads are compared to modeled heads, e.g. 



in non-pumping wells (piezometers), gravel pits, etc. Gages are Test Points that are 
placed near a line-sink of a stream network to compare the observed stream flow with the 
modeled stream flow. Lake stages are Test Points that are placed near line-sinks that 
define a lake feature for which a lake stage is calculated, thus the radio button Lake is 
selected for that line-sink string (Fig. 7) and outside loop iterations are applied (Fig. 5).  
Each lake needs only one Lake Stage Test Point, of course. Each of these Test Point types 
has its own calibration statistics tab sheet, see Model>View Calibration Statistics. Each 
of these Test Point types forms also a separate calibration target group in the PEST 
simulations. Make sure not to use Gages and Lake Stages (at least do not make use of 
their results) unless performing conjunctive solutions and lake stage simulations, 
respectively.  
 
Note: When using Tools>Export or Tools>Import to export or import Test Points using 
*.tpl files, make sure to include the Test Point type. 
 
 
Implement Scenarios  (professional version only) 

 



Figure 9. Dialog opens from Model>Implement Scenario. Symbolic names for model 
parameters are used to run different calibration or sensitivity scenarios. 
 
The Model>Settings dialog, the Linesink String Properties dialog, and the Inhomogeneity 
Properties dialog each have a Scenario tab sheet where a symbolic name may be 
specified for some of the model parameters. These include symbolic names for the 
hydraulic conductivity and aquifer base on the Aquifer tab (not present in Fig. 9), for the 
resistance of one or more line-sink strings, and for the hydraulic conductivity and Added 
recharge rate of inhomogeneities, see the tables in Fig.9. Initially, the Model>Implement 
Scenarios dialog will show the same Current values and Default values. The Current 
values can be modified in this table for calibration purposes or for a sensitivity analysis. 
When clicking Update Database, the Current values are applied to the respective features 
(will show up on their Properties dialogs), but the Default values are retained for possible 
future use. If the calibration procedure has been completed you can overwrite the Default 
values by the Current values by clicking Replace all Default values with Current. If a 
sensitivity analysis is completed, you can restore all Current values to their defaults by 
clicking Replace all Current values with Default. 
After completion of a PEST optimization run you can import the optimized parameters 
into the GUI. They will be stored as Current values. You can test these optimized 
parameters by running the Solver. If satisfied with the results, you can make these 
optimized parameters the new defaults by clicking Replace all Default values with 
Current. 
 
PEST (professional version only) 
Parameter optimization (also referred to as automatic calibration) has become rather 
routine practice for most comprehensive modeling projects.  
 



 
Figure 10. PEST control panel from which to set up and run a PEST session. Optimized 
parameters can be imported directly into GFLOW. 
 
GFLOW has fully integrated parameter optimization facilities using PEST. In Fig. 10 the 
PEST control panel is shown as accessed from Tools>PEST. In order to run a PEST 
session, you must have defined symbolic names on the Scenario tabs of the 
Model>Settings dialog, Linesink String Properties dialog, and/or Inhomogeneity 
Properties dialog. You must also have defined a set of relevant Test Points (piezometers, 
stream gages, and/or lake stages) that will serve as calibration targets. Finally, you must 
have set up the proper solution parameters and convergence criteria on the 
Model>Settings>Solver tab. A PEST parameter optimization session is implemented as 
follows: 

1. Delete any previous input and output files using the Delete All PEST Related 
Files button. 

2. Click on Assign Weights to modify any default weights for individual 
observations (Test Points in GFLOW) as desired. These weights are stored in the 
project database and written to the relevant PEST input file. 

3. Click on the Write PEST Input Files button to write default input files. 



4. Edit the file “basename.pst” (example.pst in Fig. 10) to set up the desired PEST 
run. 

5. Click on Run PESTCHEK and review the program response in the View window 
on the control panel. Correct any errors that are reported by PESTCHEK. 

6. Click on the Run PEST button to execute the PEST simulation. 
7. You can view any or all PEST output files in the View window by double 

clicking them. 
8. After having performed a parameter optimization run, you may import the 

optimized parameters in GFLOW by clicking on the Import Optimized 
Parameters button. The optimized parameters will become the current values as 
shown on the Model>Implement>Scenario dialog, see Model>Implement 
Scenario. You can test them out by performing a model run and make them the 
default parameters, see Fig. 9. 

You may at any time consult the PEST manual by clicking on the View PEST Manual 
button. All PEST components are installed together with the GFLOW software. 
 
An example view of the PEST optimization results as they are transferred from PEST 
to GFLOW is shown in Figure 11. 
 
 



 
Figure 11. PEST optimized parameters can be automatically imported in GFLOW as 
shown by the import log file “PEST2GFLOW.log” 
 

 
Note: The PEST manual is found in “PEST manual.pdf” accessible from the 
GFLOW>Help>PDF Help Files menu. 

 
 
 
 
 
 
 
 
 
 
 



Inhomogeneity domains 
 

 
Figure 12. The Inhomogeneity Properties dialog. 
 
The Inhomogeneity Properties dialog has been organized to clearly distinguish between 
different functionalities of the inhomogeneity domains. As may be seen in Fig. 12, there 
are four (4) different functionalities: the inhomogeneity domain redefines the hydraulic 
conductivity, porosity, aquifer base elevation, or added recharge (subtracted if negative). 
If the only option that is checked is Change recharge rate from default, the polygon that 
defines the domain can have large sides and the domain can overlap other domains. In all 
other cases, the domains cannot overlap!  In case one or both of the options Change 
hydraulic conductivity from default or Change base elevation from default is checked, the 
polygon that defines the domain must have relatively small line elements. In unconfined 
aquifers it is recommended to check Provide estimate of average head and provide as 
good an estimate of the average head along the domain boundary as possible. This will 
improve the convergence of the solution process by using a reasonable estimate of the 
saturated thickness at the start of the iterative solution process. 
 
 
 
 



Common domain boundaries 
 

 
Figure 13. Yellow and red inhomogeneity boundaries exhibit shared vertices that show 
up with a gray border around the vertex marker. 
 
Inhomogeneity domains can have common domain boundaries. In order to make a 
boundary section of a new inhomogeneity coincide with a boundary section of an existing 
inhomogeneity you must hold down the CTRL-key when clicking to enter a vertex on top 
of an existing vertex. Coinciding vertices will be marked by a gray border around the 
vertex marker, see Figure 13. You can also move a vertex onto an existing vertex by 
highlighting the vertex using a CTRL-M keystroke, placing the cursor over the other 
vertex, and perform a CTRL-left click.  
 
Note: when moving coinciding vertices (CTRL-M and left-click on new position), both 
will be moved. 
 
Warning: Always check to make sure that common boundaries have truly coinciding 
vertices (gray border around vertex marker), not just vertices that are close. In the latter 
case a nonsensical solution may result. You can check this by selecting View>Show 
Vertices>Inhomogeneity Vertices. 
 



Details on the implementation of inhomogeneity domains in GFLOW are found in 
“Theory of modeling inhomogeneity domains in GFLOW.pdf” accessible from the 
GFLOW>Help>PDF Help Files menu. 
 
Horizontal Barriers 
These barriers to horizontal flow in GFLOW may be open or closed, fully or partially 
penetrating, and impermeable or leaky. In Fig. 13a a GFLOW screen shot is shown with a 
closed leaky barrier and an open impermeable barrier. The Barrier properties dialog is for 
the closed semi-permeable (leaky) barrier just below it. Note that there is a jump in the 
head across each barrier, which manifests it self as bundled up potentiometric head 
contours. The blocky pattern is due to the grid used for contouring. A finer grid (set on 
the contouring tab of the Model>Settings dialog) will reduce this blocky pattern.  
 

 
Figure 13a.  A closed semi-permeable barrier and a open impermeable barrier. 
  
Details are found in “Horizontal Barriers in GFLOW.pdf” accessible from the 
GFLOW>Help>PDF Help Files menu.  

Managing hydrological units (HUCs) (professional version 
only) 
Large model domains may lead to large models in terms of the number of line-sinks, 
inhomogeneity domains, etc. Such large models lead to large numbers of equations that 
slow down the modeling process or cannot be solved at all (too big for the computer 
memory). In many cases, such large model areas may be subdivided into several smaller 
watersheds. Watersheds that are remote from each other, will not impact each others 



groundwater flow regime, at least not directly. Here in lies an opportunity to improve 
modeling efficiency. Instead of solving one big model at once, a set of smaller local 
models may be solved that, when taken together, provide the same representation of the 
groundwater hydrology in the larger domain. 
 
GFLOW has some management tools to perform the combined modeling of several sub-
domains. These utilities have been developed for the North Carolina Department of 
Environmental and Natural Resources (NCDENR) and the sub-domains used were based 
on the USGS hierarchical watershed categories called HUCs (Hydrological Unit Codes). 
The abbreviation actually refers to the digital coding of these sub-watersheds. I 
recommend that the smallest sub-watersheds be used, which are the 12-digit HUCs. 
 
The implementation of sub-models, based on HUCs, is described in the document   
“Managing Hydrologic Units in GFLOW.pdf” accessible from the GFLOW>Help>PDF 
Help Files menu. 
Briefly, HUC domains are defined on the Model menu, see Fig. 14. Each Hydrological 
Unit has a Hydrologic Unit Boundary, an associated Farfield Boundary, and a Model 
Boundary. These boundaries are shown in Fig. 15. The line-sinks that define streams and 
lakes inside a hydrologic unit domain are written to disk in separate files for each HUC 
domain. Inhomogeneity domains are also written to disk in separate files. This is done on 
the Tools>Export menu, see Fig. 16. These files will later be read back to form a local 
model. 
 



 
 
Figure 14. Defining Hydrological Unit Boundaries, associated Farfield Boundaries, and 
associated Model Boundaries. 
 



 
Figure 15: The inner red polygon defines a nearfield HUC domain, the green boundary its 
associated farfield boundary, and the yellow polygon is its associated model boundary. 
 
The inner red polygon in Figure 15 defines a nearfield HUC domain, the green boundary 
its associated farfield boundary, and the yellow polygon is its associated model boundary. 
The surrounding red polygons are domain boundaries of HUCs adjacent to the one shown 
in the center (the one with the missing smaller tributaries). Line-sinks inside the center 
domain boundary are treated as nearfield. Line-sinks inside adjacent HUCs and inside the 
farfield boundary (green polygon) are treated as semi-nearfield. Line-sinks between the 
farfield boundary and the model boundary (between the green and the yellow polygon) 
are treated as farfield. Finally, all line-sinks outside the yellow model boundary are 
ignored (not included in the model for the inside HUC).  



 
The model described above is defined in a file *.huc which is an ASCI file edited by hand 
or generated by a GIS system. The file is imported using Tools>Import>Hydrological 
Unit and it will trigger the importation of the data associated with the domains shown in 
Fig. 15. An example *.huc file is listed below. 
 
Path "C:\gflow\models" 
nearfield 
lcc_01.lss 
farfield 
lcc_02.lss 
lcc_03.lss 
lcc_04.lss 
CC_01.lss 
HC_03.lss 
HC_04.lss 
Tar_T3e.lss 
inhomogeneities 
LCC_Recharge.inh 
 
The “Path” identifies the location of the *.lss files and *.inh files. In the above example, 
the file “lcc_01.lss” contains all the line-sinks in the nearfield HUC as well as the 
Hydrologic Unit Boundary, the Farfield Boundary and Model Boundary for that domain. 
The *.lss listed under “farfield” contains the same data for the surrounding HUC 
domains. There is only one inhomogeneity domain specified, which defines recharge. 
 
The idea is to solve the model shown in Fig. 15 and make the necessary model 
modifications to achieve calibration. Once calibrated the inside HUC, which serves as the 
nearfield, is written back to disk, see Fig. 16. A new *.huc file is created for a model with 
one of the other HUC domains as nearfield. After model calibration, that nearfield HUC 
is written back to disk. The procedure is repeated until all HUCs that define the larger 
model have been included as nearfield in a local model. This series of overlapping 
models describes the groundwater flow regime in the entire model area. Of course, only 
the solutions in the nearfield HUCs should be relied upon (for instance the inner HUC 
domain in Fig. 15). 
 
 
 
 



 
Figure 16. A Hydrologic Unit containing a Hydrologic Unit Boundary, Farfield 
Boundary, Model Boundary and all line-sinks with attributes that define streams and 
lakes inside the domain are written to disk in ASCI files (option Hydrologic Unit). 
Similarly all data associated with a selected inhomogeneity domain are written to disk 
(option Inhomogeneity is gray, since no inhomogeneity is selected). 
 
  



 

Right-Click to get model results 
 
In case a line-sink or line-doublet (inhomogeneity domain element) is selected, a right-
click will open a data panel with model results that are specific to that element. In Fig. 17 
the data panel is shown for a line-sink that is a stream feature. 
 

 
Figure 17. The yellow line-sink has been selected (left-click on down gradient vertex) 
and a right-click brings up a Linesink Information panel. 
 
Note that the Width parameter on this data panel has been calculated by the Solver. The 
Width parameter on the Linesink String Properties dialog is set to the actual stream width 
(10 feet in this case). The Discharge is the sink density [L2/T] (extraction rate per unit 
length), the Total Discharge is the total extraction rate for the line-sink [L3/T] (Discharge 
times Linesink Length). The Cumulative Discharge is the total discharge for the entire 
line-sink string section up-gradient of the selected line-sink (which is included). The Base 



flow (=Stream flow for this case) is the cumulative discharge from the head waters down 
to the end of the yellow line-sink in Fig. 17. 
 

Database searches 
 

 
Figure 18. A database search is carried out on line-sink strings that define streams with 
the condition that the resistance be larger than 1 day. 
 
A database search may be conducted by clicking on the looking glass icon or clicking on 
Tools>Search. In the above example, all line-sink strings that define a stream network 
are searched for strings that have a resistance parameter larger than 1 day. The strings 
found are highlighted and their labels listed in the Search window, see Fig. 17. Similar 
searches may be done for all analytic element types and all attributes. 



Contouring 
 

 
Figure 19. There are 6 different types of contours and a custom setting for the contour 
grid resolution. 
 
The Contouring tab on Model>Settings includes various Contour Types and a custom 
setting for the contour grid resolution. Potentials are for special use when the “discharge 
potential” is to be contoured. The Discharge option provides a contour plot of the 
magnitude of the discharge vector, which is helpful in identifying stagnation zones. 
Stream Function is useful for producing stream lines in cross-sectional models, see the 
document “Modeling flow in the vertical plane with GFLOW.pdf.” Warning: in the 
presence of areal recharge, the stream function contours do not represent stream lines! 
The Drawdowns option will subtract the current heads from those contoured during a 
previous run. For instance, if the previous run has a zero pumping rate for a well, while 
the current run has that well active, drawdowns due to the well will be obtained. For this 
to work you must have contoured heads for the previous run. For the current run you 
must select Drawdowns. Warning: Do not change the Window or the Grid Resolution 
settings, otherwise the contour grids are incompatible and heads cannot be subtracted by 
GFLOW to produce the drawdowns. Also, remember to select proper Contour Level data 
for the drawdowns. Finally, remember to set the Drawdowns option back to Heads before 
making a new contour plot. 
 



The Grid Resolution is defined as the number of grid points along the horizontal 
dimension of the window. The vertical grid points are selected based on a square grid. 
The Coarse grid setting is 40 points, the Detailed grid setting is 80 points, and the 
Custom grid setting may be as high as 200 points. Note: for Stream Function contours a 
high grid resolution is recommended to reduce the size of so-called “branch cuts”. 
 

GUI options 

 
Figure 20. GUI options dialog to customize the GUI. 
 
Use Tools>GUI Options to customize contours and path lines. When using raster 
graphics base maps, analytic element, contour and path line overlays may be difficult to 
distinguish from the busy background. The GUI Options allow you to add a shading to 
line-sinks and haze the background map for better contrast with the overlays. 
 
The Linesink Shadow and Base Map Haze features are to improve visibility of the 
analytic element layout (streams and lakes) on busy base maps, e.g. satellite images. 
 
The option Suppress Coordinate Translation prevents the Solver to use local coordinates 
(relative to the lower left corner of the window in the GUI) rather than world coordinates. 
The use of local coordinates improves the solution accuracy, but makes it difficult to 
relate the Solver coordinate data to coordinates shown in the GUI. For some special 



testing cases it can be useful to select this option and have the same coordinates in the 
Solver output and the GUI. 
 

Particle tracking 
 

 
Figure 21. Use Model>Add Particle Grid to enter a grid of particles for path line tracing. 
 
In addition to entering single particles, you can now also enter a grid of particles by 
clicking Model>Add Particle Grid which brings up a + sign. Drag a window (hold left-
mouse button down) in which to distribute the particles. After the window is complete the 
dialog in Fig. 21 opens. Define the number of particles in the grid and their attributes, 
click OK.  Now click the calculator icon to calculate the pathlines. An example particle 
grid and associated traces are shown in Fig. 22. 
 
You can delete particles by simply clicking on them when in “delete particle mode,” see 
Edit>Delete Particle Mode. You may also delete all particles in the database at once 
selecting Edit>Delete All>Particles. 
 



 
Figure 22. Multiple path line traces from a particle grid. 
 
 

Lake feature 
The Lake option on the Linesink String Properties dialog invokes a line-sink based lake 
feature for which the lake stage will be calculated using a complete lake water balance, 
see the document “Modeling lake-groundwater interactions in GFLOW.pdf” accessible 
from the GFLOW>Help>PDF Help Files menu. 
The Solver will automatically add a “recharge only” inhomogeneity and assign an “added 
recharge” such that the net recharge over the lake is zero. This inhomogeneity will 
coincide exactly with the line-sinks that define the lake and are invisible in the GUI. The 
only place where the inhomogeneity may be seen is in the *.xtr file (see Model>View 
Model Run Files..>Inquiry File). Here the “recharge only” inhomogeneity is written with 
GFLOW labels that are the same as for the line-sinks that define the lake, except that the 
prefix “LS” is replaced by “IN”. 
 
Interface Flow 
GFLOW supports the modeling of steady state interface flow in coastal aquifers or 
elsewhere. There are two validation cases: circular interface.gfl and coastal interface 
with well.gfl, both found in the directory C:\GFLOW projects\validations. 
 



 
Figure 22a. Interface Flow activated on the Aquifer tab of the Model Settings dialog. 
 
Interface flow is activated on the Aquifer tab of the Model Setting dialog as shown in 
Fig. 22a.  
 

 
Figure 22b. Selecting to contour the interface elevation on the Contouring tab of the 
Model Setting dialog. 



Visualization of the interface may be done by contouring its elevation. This is initiated by 
selecting the radio button for “interface” on the Contouring tab of the Model Settings 
dialog, see Fig. 22b. 
 
Details on the modeling of interface flow in GFLOW is found in “Freshwater and salt 
water interface flow in GFLOW.pdf” accessible form the Help>PDF Help Files menu. 
 
 
 
 
Three-Dimensional flow near Partially Penetrating Wells 
Partial penetration of a well generally only affects the drawdown in the well, but given a 
pumping rate it does not affect the flow or heads (drawdowns) away from the well. In 
some rare cases, for instance when studying flow near monitoring wells that have a low 
pumping rate, a truly 3D solution may be helpful.  

 
Figure 22c. 3D Geometry tab of the Well Properties dialog. 
 
The Well Properties dialog has a tab for 3D Geometry on which the top and bottom of the 
well screen can be defined.   The default values are the top and bottom of the aquifer. In 
the case shown in Fig. 22c the top of the aquifer is set arbitrarily high to ensure 
unconfined flow in the entire model domain. These settings have no influence on the 
impact of the well on the flow regime; only the pumping rate has.  



 
Important: In case a MODFLOW model is to be extracted it is important to set the screen 
elevation correctly so that the well will be entered in the correct MODFLOW layer or 
layers. In the case shown, the well would be incorporated in all MODFLOW layers. 
 
Under confined flow conditions in GFLOW the aquifer top and bottom are horizontal 
planes and form the actual boundaries on the flow domain. In such a confined aquifer a 
truly three-dimensional solution can be used by checking the box “Use 3-D Partially 
Penetrating Function.”  Important: This 3D solution is only valid in a confined aquifer 
whereby the algorithm uses images with respect to both the bottom and aquifer top to 
enforce no-flow conditions along those boundaries. 
 
 
 
 
Transient flow near Wells 
While GFLOW is a steady state groundwater flow model, local transient flow due to a 
well that starts or stops pumping can be included in the solution. Since the transient 
effects are due to the well only they should not be allowed to extent out to other flow 
features. These other flow features would not correctly interact with these transient 
effects and the solution would become inaccurate. 
 

 



Figure 22d.  Transient Well tab on the Well Properties dialog.  
 
In Figure 22d the Transient Well tab on the Well Properties dialog is shown. The well 
(red marker just to the right of the dialog) may be modeled using the Theis solution 
whereby the well starts pumping at some time (0 in the case of Fig. 22d). Since the well 
is very close to the river, this solution would not be accurate when the drawdowns reach 
the river. However, the solution may be improved by using an image recharge well that 
starts injecting the same amount of water at the same time just across from the lower river 
boundary (not shown in Fig. 22d). This method of images for transient wells is discussed 
in (Haitjema 1995).  In the same text it is also discussed how superposition in time of 
Theis wells can be used to simulate cyclic pumping. Note: If the average pumping rate is 
represented with a regular (steady state) well and only the variations in pumping are 
represented by Theis wells, the transient effects remain local near the well, at least in 
unconfined aquifers, and nearby streams may not be affected by the transient effects. 
 
Horizontal Wells 
Horizontal wells are increasingly used in shallow aquifers near major surface waters 
(rivers). A particularly efficient method is the use of “radial collector wells” with several 
horizontal wells in a radial pattern surrounding a central caisson.  
 

 
Figure 22e. Radial collector well in the project file radialcollector.gfl in the directory 
c:\GFLOW projects\example. 



 
While GFLOW is a Dupuit-Forchheimer model in which the fully 3D flow patterns near 
the well in Fig. 22e cannot be represented, the line-sink strings that represent the radials 
can be given a resistance that represents the resistance due to the converging 3D flow 
patterns near these radials. In so doing the average heads near the collector well is 
obtained, see contours in Fig. 22e, and a good approximation of the total inflow in the 
well is obtained. The latter is often the objective of modeling different radial well 
collector configurations, particularly near or underneath surface waters. Details on the 
modeling of horizontal wells in GFLOW are found in: “Horizontal wells in 
GFLOW.pdf,” “Horizontal wells in GFLOW - supplement.pdf,” and “Horizontal wells in 
GFLOW-errata.pdf.” These documents are accessible from the Help>PDF Help Files 
menu in GFLOW. 
 
 
MODFLOW Extract 
Once a GFLOW model is created and calibrated it is possible to extract a MODFLOW 
model from this GFLOW model. The model grid may be rotated with respect to the world 
coordinates and may have more than one layer.  All model features and acquifer 
properties are translated into MODFLOW features and properties and exported to be 
imported in a MODFLOW GUI, such as Groundwater Vistas. The MODFLOW extract 
feature is documented in  
 

 



Figure 23.  Accessing the MODFLOW Extract dialog in GFLOW. 
 
To access the MODFLOW Extract feature make sure you have a valid solution and then 
go to Grid>MODFLOW Extract>Show Grid Dialog, see Fig. 23. 
 

 
Figure 24.  Setting the MODFLOW grid properties. 
 
On the MODFLOW Extract dialog define all relevant grid parameters, see Fig. 24. The 
“Rotation” is in degrees and is counter clockwise. Also note that the perimeter is “Flux 
Specified,” which means that the MODFLOW model cells around the grid perimeter will 
define inflows and outflows from the MODFLOW domain as sound in the GFLOW 
model. Alternatively, the perimeter may be “Head Specified,” which means that the cells 
around the grid perimeter will have constant heads as obtained from the GFLOW model. 
   
Important: The Educational Version is limited to a maximum of 50 rows and 50 columns. 
 



 
Figure 25.  Starting the process to transfer the analytic elements, aquifer properties and 
the initial heads in the grid cells.  
 
In Fig. 25 the cursor is hovered over the “Processing” tab to complete the MODFLOW 
extract process. The first step is to click on “Apply Analytic Elements” whereby wells, 
streams, lakes, recharge, and aquifer properties are transferred to the MODFLOW grid. 
Step two is to click on “Extract GFLOW Results” whereby perimeter fluxes or heads are 
applied and heads in other cells are defined as “initial heads.”  The last step is to click on 
“Make MODFLOW Files” whereby the GUI writes the necessary MODFLOW files. 
These files can be imported directly into the MODFLOW Solver, but are best imported 
into a MODFLOW GUI like Groundwater Vistas.  
 
It is recommended to first run MODFLOW without any modifications to the imported 
model and verify that the same solution is obtained as seen in GFLOW. After that 
properties can be changed and, for instance, transient simulations conducted. 
 
NOTE: The Educational Version of GFLOW only allows for a 50 by 50 
grid and 4 grid layers.  
 
 
 
 
 



 
Hybrid GFLOW-MODFLOW Modeling (professional version only) 
A hybrid GFLOW-MODFLOW model may be implemented using the “Leakage from 
MODFLOW” feature accessed from the Grid menu, see Fig. 26. 
 

 
Figure 26.  Accessing the Leakage from MODFLOW option in GFLOW. 
 
On the General tab of the Leakage from MODFLOW dialog select the basename.del file 
that defines the MODFLOW grid to be imported into GFLOW. Details on file formats 
are found in the document “Hybrid GFLOW-MODFLOW Modeling.pdf.”  
 



 
Figure 27. The General tab of the Leakage from MODFLOW dialog. 
 
Once the grid has been imported and georeferenced, see Fig. 27, the properties in the grid 
can be checked using the Tracking tab, see Fig. 28. 
 



 
Figure 28.  Tracking the properties in the MODFLOW grid imported in GFLOW. 
 
The GUI imports a file basename.vlk that contains the leakages between the lowest 
MODFLOW layer included in GFLOW and the MODFLOW layer just below it. Hence 
between the upper MODFLOW layer not in the GFLOW model and the GFLOW model. 
These leakages are obtained from the MODFLOW solution in the same model area as 
included in the GFLOW model. The cell-by-cell recharge rates at the top of the 
MODFLOW model are to be stored in the file basename.rta. This file is only read by the 
Solver, thus not by the GUI. Consequently, while the leakages are displayed in the grid, 
the recharge rates are not.  
 
The head contours shown in Fig. 28 are from the GFLOW solution that includes both the 
MODFLOW cell-by-cell recharge rates and the MODFLOW cell-by-cell leakage rates. 
The head distribution and the flow rates, however, do not suffer from the coarse 
MODFLOW grid resolution and offer detailed well – stream interactions, which are often 
the purpose of this hybrid modeling approach. 



More details are found in “Hybrid GFLOW-MODFLOW Modeling.pdf.” You may also 
want to read two articles in Groundwater found in: “Hybrid FD-AE model.pdf” and 
“Field test hybrid GFLOW-MODFLOW model.pdf.” All documents are accessible from 
the GFLOW>Help>PDF Help Files menu. 
 
 
Import and Export of analytic elements (professional version only) 
Line-sink strings, inhomogeneity domains, and horizontal barriers may be imported and 
exported in xml format.    

 
Figure 29.  Import of Line-sink Strings, Inhomogeneities, and Horizontal Barriers. 
 
This feature allows for GIS generated analytic elements, complete with all their 
attributes, to be imported in a GFLOW model. Similarly, analytic elements can also be 
exported in xml format by using the Export option just below the Import option on the 
Tools menu, see Figure 29. This allows the transfer of analytic elements between 
GFLOW models. The xml file formats are illustrated in annotated example xml files 
provided in PDF format, see  “import-export.lss.xml.pdf,” “import-export.inh.xml.pdf,” 
and “import-export.brr.xml.pdf” for line-sink strings, inhomogeneities, and horizontal 
barriers, respectively. All documents are accessible from the GFLOW>Help>PDF Help 
Files menu. These annotated xml files are based on the exported elements in the project 
file sample.gfl found in the directory: Documents and Settings/<username>/GFLOW 
projects/import-export. 
 
 


